error message disappears too fast

Bug #1246024 reported by Robert Lyon on 2013-10-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Low
Robert Lyon
1.7
Low
Robert Lyon
1.8
Low
Robert Lyon

Bug Description

when I try to add a 'is_singular' (can only add once) block to a page I get the error message similar to:

Cannot put more than one creativecommons block type into a page.

However the message fades out and disappears real quickly before I get a chance to read it.

The problem looks to be due to the git change 91be4c3d17c469d9dcddf8e5d16e965cb10530b4

Where a message is added to the page and then any old messages are removed - but the problem is the new message is counted as being one of the old messages so fades out straight away.

The new message needs to be ignored first time round.

Robert Lyon (robertl-9) wrote :
Changed in mahara:
status: New → In Progress
importance: Undecided → Low
assignee: nobody → Robert Lyon (robertl-9)
milestone: none → 1.8.1

Reviewed: https://reviews.mahara.org/2669
Committed: http://gitorious.org/mahara/mahara/commit/16e4fe3804fb0e15fc9d5c7658cd18dcaabbd780
Submitter: Aaron Wells (<email address hidden>)
Branch: master

commit 16e4fe3804fb0e15fc9d5c7658cd18dcaabbd780
Author: Robert Lyon <email address hidden>
Date: Wed Oct 30 08:47:17 2013 +1300

Error message fading too fast to read (bug 1246024)

The message was being removed due to the changes in this bug:
https://bugs.launchpad.net/mahara/+bug/1081309

Where the new message was been included in the cleanup of
old messages.

To test: add a creative commons block to page
- then try and add another. you will get the error message at top that
quickly fades away

With patch: the message should stay until you try to add block for
third time and the earlier message fades away

Change-Id: I298ba76d5f9696b3881d15868518f401236ac422
Signed-off-by: Robert Lyon <email address hidden>

Robert Lyon (robertl-9) wrote :

added patch for 1.8_STABLE
https://reviews.mahara.org/#/c/2740

added patch for 1.7_STABLE
https://reviews.mahara.org/#/c/2741

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/2741
Committed: http://gitorious.org/mahara/mahara/commit/0366c3e9e8a47526718443ddd61babfb3a4599e8
Submitter: Son Nguyen (<email address hidden>)
Branch: 1.7_STABLE

commit 0366c3e9e8a47526718443ddd61babfb3a4599e8
Author: Robert Lyon <email address hidden>
Date: Wed Oct 30 08:47:17 2013 +1300

Error message fading too fast to read (bug 1246024)

The message was being removed due to the changes in this bug:
https://bugs.launchpad.net/mahara/+bug/1081309

Where the new message was been included in the cleanup of
old messages.

To test: add a creative commons block to page
- then try and add another. you will get the error message at top that
quickly fades away

With patch: the message should stay until you try to add block for
third time and the earlier message fades away

Change-Id: I298ba76d5f9696b3881d15868518f401236ac422
Signed-off-by: Robert Lyon <email address hidden>

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/2740
Committed: http://gitorious.org/mahara/mahara/commit/8f9c7abb884589e7505cd9ff62c167cc8ca4a7c2
Submitter: Son Nguyen (<email address hidden>)
Branch: 1.8_STABLE

commit 8f9c7abb884589e7505cd9ff62c167cc8ca4a7c2
Author: Robert Lyon <email address hidden>
Date: Wed Oct 30 08:47:17 2013 +1300

Error message fading too fast to read (bug 1246024)

The message was being removed due to the changes in this bug:
https://bugs.launchpad.net/mahara/+bug/1081309

Where the new message was been included in the cleanup of
old messages.

To test: add a creative commons block to page
- then try and add another. you will get the error message at top that
quickly fades away

With patch: the message should stay until you try to add block for
third time and the earlier message fades away

Change-Id: I298ba76d5f9696b3881d15868518f401236ac422
Signed-off-by: Robert Lyon <email address hidden>

Aaron Wells (u-aaronw) on 2013-12-18
Changed in mahara:
status: Fix Committed → Fix Released
Aaron Wells (u-aaronw) on 2014-04-03
no longer affects: mahara/1.9
Robert Lyon (robertl-9) on 2014-04-22
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers