Skin description is not displayed

Bug #1239271 reported by Kristina Hoeppner on 2013-10-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
High
Robert Lyon
1.8
High
Robert Lyon

Bug Description

1.8.0 RC1

When you create a skin, you provide a description, yet it is not displayed anywhere.

Bob can't find any reference to it in the code for it being used.

Changed in mahara:
status: New → Confirmed
milestone: none → 1.8.1
importance: Undecided → High
Robert Lyon (robertl-9) wrote :

Going to get the description and author name to display for a skin on the skin/index.php and view/skin.php pages.

Looking to have a lightbox option on the skin/index.php page to show all metadata for the skin (currently to be description and author)
and to display the same info below the 'current skin' image on the view/skin.php page

Changed in mahara:
assignee: nobody → Robert Lyon (robertl-9)
Robert Lyon (robertl-9) wrote :

Have made patches for this change:

https://reviews.mahara.org/2716 - displays the metadata (incl title) in a popup box (or below item if js disabled) on skin/index.php page

https://reviews.mahara.org/2717 - displays the metadata (excl title) below the 'currentskin' on left hand side of view/skin.php page

Changed in mahara:
status: Confirmed → In Progress

Reviewed: https://reviews.mahara.org/2716
Committed: http://gitorious.org/mahara/mahara/commit/b50c60bd84b589798cd2ece891b3a5647ce83c1f
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit b50c60bd84b589798cd2ece891b3a5647ce83c1f
Author: Robert Lyon <email address hidden>
Date: Tue Nov 19 12:16:21 2013 +1300

Displaying metadata for skin on skin/index.php (bug #1239271)

Added a button to click to view metadata of a skin
- currently limited to title, owner, creation date, modified date
and description.

The creation date and owner reflect who currently owns the skin.
- so if the skin is imported it does not reflect the original creator
as this information is not currently recorded in skin export.

Change-Id: Ife7fdad2b613cd6a3c52252b90a46f869c665351
Signed-off-by: Robert Lyon <email address hidden>

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/2717
Committed: http://gitorious.org/mahara/mahara/commit/ece94630bd7bd675f6a3774415a8856c2b24dd2f
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit ece94630bd7bd675f6a3774415a8856c2b24dd2f
Author: Robert Lyon <email address hidden>
Date: Tue Nov 19 12:59:51 2013 +1300

Show skin metadata on the skin chooser page (bug #1239271)

Displays the metadata of the currently selected skin below the preview
image and save button. I placed it below the save button because the
description text could get quite long and push save button off bottom
of screen.

Change-Id: I78a5ad4c9749682d90472de22f33edf39b17f2dc
Signed-off-by: Robert Lyon <email address hidden>

Robert Lyon (robertl-9) on 2013-12-05
Changed in mahara:
status: In Progress → Fix Committed
Robert Lyon (robertl-9) wrote :
Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/2787
Committed: http://gitorious.org/mahara/mahara/commit/e57b74d318b2b67d07222ed972f3c9a91f5dbe73
Submitter: Son Nguyen (<email address hidden>)
Branch: 1.8_STABLE

commit e57b74d318b2b67d07222ed972f3c9a91f5dbe73
Author: Robert Lyon <email address hidden>
Date: Tue Nov 19 12:16:21 2013 +1300

Displaying metadata for skin on skin/index.php (bug #1239271)

Added a button to click to view metadata of a skin
- currently limited to title, owner, creation date, modified date
and description.

The creation date and owner reflect who currently owns the skin.
- so if the skin is imported it does not reflect the original creator
as this information is not currently recorded in skin export.

Change-Id: Ife7fdad2b613cd6a3c52252b90a46f869c665351
Signed-off-by: Robert Lyon <email address hidden>

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/2788
Committed: http://gitorious.org/mahara/mahara/commit/60b429159eb0aff56bb691d7a88bfeb96ace0407
Submitter: Son Nguyen (<email address hidden>)
Branch: 1.8_STABLE

commit 60b429159eb0aff56bb691d7a88bfeb96ace0407
Author: Robert Lyon <email address hidden>
Date: Tue Nov 19 12:59:51 2013 +1300

Show skin metadata on the skin chooser page (bug #1239271)

Displays the metadata of the currently selected skin below the preview
image and save button. I placed it below the save button because the
description text could get quite long and push save button off bottom
of screen.

Change-Id: I78a5ad4c9749682d90472de22f33edf39b17f2dc
Signed-off-by: Robert Lyon <email address hidden>

Aaron Wells (u-aaronw) on 2013-12-18
Changed in mahara:
status: Fix Committed → Fix Released
Robert Lyon (robertl-9) on 2014-04-22
Changed in mahara:
status: Fix Committed → Fix Released
no longer affects: mahara/1.9
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers