GoogleSpell has been discontinued -- remove it from TinyMCE spellchecker

Bug #1212541 reported by Aaron Wells on 2013-08-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Low
Aaron Wells

Bug Description

See https://tracker.moodle.org/browse/MDL-38867

The TinyMCE spellcheck plugin in Mahara by default uses the local aspell program (if it's present at /usr/bin/aspell, or $cfg->pathtoaspell). If that's not present, it attempts to use the GoogleSpell spellcheck engine, which was based on a non-public Google API that was discontinued in the second quarter of 2013.

We should follow suit with whatever approach Moodle decided on to deal with this.

I'm not sure how many places will be affected by this. Those running their sites on Linux will have /usr/bin/aspell present. It may be absent or inaccessible for places running on shared hosting, though.

For affected sites, a workaround would be to remove the spellcheck button from your TinyMCE by removing the word "spellchecker" from the list stored in the $adv_buttons variable in the smarty() function in htdocs/lib/web.php

Aaron Wells (u-aaronw) on 2013-11-12
Changed in mahara:
milestone: none → 1.9.0
Aaron Wells (u-aaronw) wrote :

Also https://moodle.org/mod/forum/discuss.php?d=229386

It looks like Moodle has:

1. Disabled the spellcheck button if you don't have aspell available
2. Activated a TinyMCE option that allows the browser to do spellchecking in the TinyMCE text box.

Mahara Bot (dev-mahara) wrote :

Patch for "master" branch: https://reviews.mahara.org/3051

Aaron Wells (u-aaronw) wrote :

I abandoned patch 3050 and sent 3051 instead.

Aaron Wells (u-aaronw) on 2014-02-27
Changed in mahara:
assignee: nobody → Aaron Wells (u-aaronw)

Reviewed: https://reviews.mahara.org/3051
Committed: http://gitorious.org/mahara/mahara/commit/75797883be7b3ed7e32a039ca1434f51ade69519
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 75797883be7b3ed7e32a039ca1434f51ade69519
Author: Aaron Wells <email address hidden>
Date: Thu Feb 27 14:31:57 2014 +1300

Replace obsolete TinyMCE GoogleSpell with in-browser spellcheck as default

Bug 1212541: The web service the TinyMCE GoogleSpell code was using,
is no longer in existence. This patch changes things so that TinyMCE will
let the browser's spellchecker work, by default.

The "pathtoaspell" is now null by default. If pathtoaspell is null, we
eliminate the TinyMCE spellcheck button and set the "gecko_spellcheck"
flag to let the browser spellcheck work. If pathtoaspell is not null,
we show the TinyMCE spellcheck button as before.

Change-Id: I9fd2b12169669d3d9705a1e23dc6c03af6f01948

Robert Lyon (robertl-9) on 2014-02-27
Changed in mahara:
status: Triaged → Fix Committed
tags: added: usermanualupdate
Changed in mahara-manual:
status: New → Confirmed
assignee: nobody → Kristina Hoeppner (kris-hoeppner)
milestone: none → 1.9.0
importance: Undecided → Medium
Robert Lyon (robertl-9) on 2014-04-22
Changed in mahara:
status: Fix Committed → Fix Released
tags: removed: usermanualupdate
no longer affects: mahara-manual
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers