The content of text boxes should be reset when clicking 'cancel' button

Bug #1212095 reported by Son Nguyen on 2013-08-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Medium
Lisa Seeto

Bug Description

Version: all
Platform: all

In many places of Mahara, e.g. 'Content/Resume/Interest', when an user clicks 'Cancel' button, the content should be reset to the initial value.

Son Nguyen (ngson2000) on 2013-08-14
summary: The content of text boxes should be reset when clicking 'cancel' button
- in

I cannot reproduce this issue. When I create a text box (or enter something in Resume -> Interest) and save that and go back in and enter more text and click "Cancel", the new text does not appear when I view the textbox again.

Please explain further where you see this issue.

I tested on Firefox in Ubuntu 12.10.

I used 1.8.0dev

Son Nguyen (ngson2000) wrote :

Here is the steps

1. Access Content/Resume/Interests page
2. Click Edit, enter 'abc', then click Save
3. Click Edit again, enter 'xyz', then click Cancel
4. Click Edit again
- Expected result: 'abc'
- Actual result: 'xyz'

When click Cancel, the context of the editor should be reset to 'abc'

Changed in mahara:
importance: High → Medium
Changed in mahara:
assignee: Son Nguyen (ngson2000) → nobody
status: New → Invalid
status: Invalid → Opinion

It's slightly more complicated. When you click "Cancel" and stay on the page and click "Edit" again, e.g. for the Cover letter, the text that you entered is still visible in the editor window (though not on what is displayed). I guess that is because the page didn't have a page reload yet. If you cancel and then go to a different page, the correct text will also be displayed in the editor window again.

1. Access Content/Resume/Interests page
2. Click Edit, enter 'abc', then click Save
3. Click Edit again, enter 'xyz', then click Cancel
4. Click Edit again
- Expected result: 'abc'
- Actual result: 'xyz'

BUT
1. Access Content/Resume/Interests page
2. Click Edit, enter 'abc', then click Save
3. Click Edit again, enter 'xyz', then click Cancel
4. Click onto a different page
5. Go back to the Interests and click Edit
- Expected result: 'abc'
- Actual result: 'abc'

Changed in mahara:
status: Opinion → Confirmed
Lisa Seeto (lisaseeto) on 2019-03-27
Changed in mahara:
status: Confirmed → In Progress
assignee: nobody → Lisa Seeto (lisaseeto)
Lisa Seeto (lisaseeto) wrote :

The original content is now being saved in the tinyMCE's initial setup. It will be restored as the content on cancellation.

Reviewed: https://reviews.mahara.org/9674
Committed: https://git.mahara.org/mahara/mahara/commit/09ef3aad8ba459e044b2ca3f7cc49f9782901787
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 09ef3aad8ba459e044b2ca3f7cc49f9782901787
Author: Lisa Seeto <email address hidden>
Date: Thu Mar 28 10:18:51 2019 +1300

Bug 1212095: The content of text boxes should be reset when clicking 'cancel' button

set content back to original content on cancellation via tinyMCE

behatnotneeded

Change-Id: I58c25cac88b437cb9eded3a9849ddef9bb0f5b9f
Signed-off-by: Lisa Seeto <email address hidden>

Robert Lyon (robertl-9) on 2019-03-29
Changed in mahara:
status: In Progress → Fix Committed
milestone: none → 19.04.0
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers