uninstalled plugins should be listed at top of extensions page

Bug #1206306 reported by Robert Lyon on 2013-07-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Wishlist
Robert Lyon

Bug Description

When one has a lot of plugins installed it is not obvious that there are non installed ones if they need to be scrolled down to.

would be better if the non-installed ones could be listed at the top of the extensions page for better UI.

Also having a message on admin/index.php page if new plugins exist on update of Mahara code would be handy as well.

Changed in mahara:
status: New → Confirmed
Aaron Wells (u-aaronw) on 2013-08-22
Changed in mahara:
status: Confirmed → Triaged
Robert Lyon (robertl-9) on 2014-04-06
Changed in mahara:
assignee: nobody → Robert Lyon (robertl-9)
milestone: none → 1.10.0
status: Triaged → In Progress

Reviewed: https://reviews.mahara.org/3203
Committed: http://gitorious.org/mahara/mahara/commit/f2262dee79ea9ebec4ab2b855ee8ddb97f73fa16
Submitter: Aaron Wells (<email address hidden>)
Branch: master

commit f2262dee79ea9ebec4ab2b855ee8ddb97f73fa16
Author: Robert Lyon <email address hidden>
Date: Mon Apr 7 11:03:17 2014 +1200

List un-installed plugins first for easier spotting (Bug #1206306)

Also getting the 'not installed plugins' title to be removed by js if last
un-installed in plugin for the plugin type has been added

Change-Id: I2223284aa1e9d5f5188bf199462260886036dd8f
Signed-off-by: Robert Lyon <email address hidden>

Aaron Wells (u-aaronw) wrote :

Robert's patch puts uninstalled plugins at the top of the extensions page.

We'll need another patch to put them onto the admin/index.php page.

Aaron Wells (u-aaronw) wrote :

Had a discussion with Robert about this on IRC. We agreed that it's not necessary to have an "install" notice on admin/index.php like the one we have for upgrades. That's because upgrading is a more urgent matter than installing (since potentially it's fixing important bugs), whereas it's okay to procrastinate on installing.

On the other hand, I think it's a fairly common user experience to drag in the plugin and then just expect it to work, without realizing you need to go to the extensions page (at least, this happens to me a lot). So we agreed it would be a good idea to put a warning/notice on admin/index.php that says "There are uninstalled plugins." and has a link to the extensions page.

tags: added: nominatedfeature
Changed in mahara:
status: In Progress → Fix Committed
Aaron Wells (u-aaronw) on 2014-10-21
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers