Installation hangs with "Mahara requires InnoDB tables. Please ensure InnoDB tables are enabled in your MySQL server."

Bug #1180243 reported by Hermann Klocker
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Fix Released
High
Son Nguyen
1.5
Fix Released
High
Son Nguyen
1.6
Fix Released
High
Son Nguyen

Bug Description

Fresh install 1.7.1 on OSX Server 10.7.5
MySQL 5.6.11 - MySQL Community Server
Chrome 26.0.1410.65

My MySQL Installation works flawlessly with some other products like moodle 2.5.
Any new tables created with the mahara user via phpMyAdmin are InnoDB tables,

show engines;

gives

InnoDB,DEFAULT,Supports transactions, row-level locking, and foreign keys,YES,YES,YES.

So how to continue?

Revision history for this message
Son Nguyen (ngson2000) wrote :

Hi Hermann;

I have no problem of installing Mahara on MySQL 5.6.9, Ubuntu 12.04.
Can you please provide the error log?

Cheers,
Son Nguyen

Revision history for this message
Hermann Klocker (hermann-klocker) wrote : Re: [Bug 1180243] Re: Installation hangs with "Mahara requires InnoDB tables. Please ensure InnoDB tables are enabled in your MySQL server."

Hi Son,

thank you for your reply. I think you meant the error_log of apache, so I send you the tail of this when trying to install:

[Thu May 16 06:02:23 2013] [error] [client 10.0.0.3] [WAR] e6 (lib/upgrade.php:73) Mahara requires InnoDB tables. Please ensure InnoDB tables are enabled in your MySQL server.
[Thu May 16 06:02:23 2013] [error] [client 10.0.0.3] Call stack (most recent first):
[Thu May 16 06:02:23 2013] [error] [client 10.0.0.3] * check_upgrades() at /Users/web/Sites/mahara/htdocs/admin/index.php:47
[Thu May 16 06:02:23 2013] [error] [client 10.0.0.3]

Regards,
Hermann

Am 16.05.2013 um 00:23 schrieb Son Nguyen:

> Hi Hermann;
>
> I have no problem of installing Mahara on MySQL 5.6.9, Ubuntu 12.04.
> Can you please provide the error log?
>
> Cheers,
> Son Nguyen
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1180243
>
> Title:
> Installation hangs with "Mahara requires InnoDB tables. Please ensure
> InnoDB tables are enabled in your MySQL server."
>
> Status in Mahara ePortfolio:
> New
>
> Bug description:
> Fresh install 1.7.1 on OSX Server 10.7.5
> MySQL 5.6.11 - MySQL Community Server
> Chrome 26.0.1410.65
>
> My MySQL Installation works flawlessly with some other products like moodle 2.5.
> Any new tables created with the mahara user via phpMyAdmin are InnoDB tables,
>
> show engines;
>
> gives
>
> InnoDB,DEFAULT,Supports transactions, row-level locking, and foreign
> keys,YES,YES,YES.
>
> So how to continue?
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/mahara/+bug/1180243/+subscriptions

Revision history for this message
Hermann Klocker (hermann-klocker) wrote :

These are the few lines added to my /var/log/apache2/error_log when refreshing my installation page:

[Thu May 16 06:02:23 2013] [error] [client 10.0.0.3] [WAR] e6 (lib/upgrade.php:73) Mahara requires InnoDB tables. Please ensure InnoDB tables are enabled in your MySQL server.
[Thu May 16 06:02:23 2013] [error] [client 10.0.0.3] Call stack (most recent first):
[Thu May 16 06:02:23 2013] [error] [client 10.0.0.3] * check_upgrades() at /Users/web/Sites/mahara/htdocs/admin/index.php:47
[Thu May 16 06:02:23 2013] [error] [client 10.0.0.3]

Revision history for this message
Hermann Klocker (hermann-klocker) wrote :

Hi Son,

after reading the error messages (I did not do this before, I am rather a newbie regarding maharas log-locations) I dug into it a little bit and found a hint why testing for Innodb did not success on my system: the test did in lib/upgrade.php

$result = $db->Execute("SHOW VARIABLES LIKE 'have_innodb'");

gives no result on my server (tested it with my account for mahara and the root account), I will attach all variables containig 'innodb' to this message (produced with /usr/local/mysql/bin/mysqladmin variables | grep innodb).

So I think one has to think over testing for innodb because I am pretty sure I enabled it on my system.

Regards,

Hermann

Am 16.05.2013 um 00:23 schrieb Son Nguyen:

> Hi Hermann;
>
> I have no problem of installing Mahara on MySQL 5.6.9, Ubuntu 12.04.
> Can you please provide the error log?
>
> Cheers,
> Son Nguyen
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1180243
>
> Title:
> Installation hangs with "Mahara requires InnoDB tables. Please ensure
> InnoDB tables are enabled in your MySQL server."
>
> Status in Mahara ePortfolio:
> New
>
> Bug description:
> Fresh install 1.7.1 on OSX Server 10.7.5
> MySQL 5.6.11 - MySQL Community Server
> Chrome 26.0.1410.65
>
> My MySQL Installation works flawlessly with some other products like moodle 2.5.
> Any new tables created with the mahara user via phpMyAdmin are InnoDB tables,
>
> show engines;
>
> gives
>
> InnoDB,DEFAULT,Supports transactions, row-level locking, and foreign
> keys,YES,YES,YES.
>
> So how to continue?
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/mahara/+bug/1180243/+subscriptions

Revision history for this message
Hermann Klocker (hermann-klocker) wrote :

I dug into it a little bit and found a hint why testing for Innodb did not success on my system: the test did in lib/upgrade.php

$result = $db->Execute("SHOW VARIABLES LIKE 'have_innodb'");

gives no result on my server (tested it with my account for mahara and the root account), I will attach all variables containig 'innodb' to this message (produced with /usr/local/mysql/bin/mysqladmin variables | grep innodb).

So I think one has to think over testing for innodb because I am pretty sure I enabled it on my system.

Revision history for this message
Hermann Klocker (hermann-klocker) wrote :

Sorry for double posting - did not know that email replies are posted here..
(Don't know how to delete these duplicates)

Revision history for this message
Kristina Hoeppner (kris-hoeppner) wrote :

Hello Hermann,

No worries about double posting. Now you know you can just reply via email :-)

Viele Gruesse
Kristina

Revision history for this message
Hermann Klocker (hermann-klocker) wrote :

Managed to fix the problem via a dirty hack: changed

'YES'

to

''

in line 72 in lib/upgrade.php. Installation cleanly finished.

Sure this is no solution but I have not enough mysql knowledge to propose a better test for innodb capabilities.

Thanks for pointing to the right location to investigate further.

Revision history for this message
Son Nguyen (ngson2000) wrote :

Hi Hermann;

Yes, this is not a solution. I will fix this

Thanks
Son Nguyen

Changed in mahara:
importance: Undecided → High
Revision history for this message
Son Nguyen (ngson2000) wrote :

Recently, MySQL has removed the variable 'have_innodb'. We need to run 'SHOW ENGINES' to check if Innodb is enable of not.

Revision history for this message
Kristina Hoeppner (kris-hoeppner) wrote :

Hi Son,

I suspect that this is a problem not just in 1.7?

Cheers
Kristina

Changed in mahara:
assignee: nobody → Son Nguyen (ngson2000)
status: New → Confirmed
milestone: none → 1.7.2
Revision history for this message
Son Nguyen (ngson2000) wrote :
Revision history for this message
Son Nguyen (ngson2000) wrote :

Test case:
 1. Install MySQL 5.6.x
 2. Create a new Mahara database
 3. Install Mahara using the database.

Make sure the installation is successful.

Revision history for this message
Aaron Wells (u-aaronw) wrote :

By the way Herman, can you paste here the results you get when you run the query "SHOW ENGINES;" in your MySQL database? It would be good to have another data point to make sure the code change we're working on is correct. :)

Cheers,
Aaron

Revision history for this message
Son Nguyen (ngson2000) wrote :

Hi Aaron;

Actually, Herman has pasted the results of the query "SHOW ENGINES". It was

"InnoDB,DEFAULT,Supports transactions, row-level locking, and foreign keys,YES,YES,YES."

Revision history for this message
Mahara Bot (dev-mahara) wrote : A change has been merged

Reviewed: https://reviews.mahara.org/2198
Committed: http://gitorious.org/mahara/mahara/commit/2edb8e01c49996a93d041537d9093418ceef9e58
Submitter: Son Nguyen (<email address hidden>)
Branch: master

commit 2edb8e01c49996a93d041537d9093418ceef9e58
Author: Son Nguyen <email address hidden>
Date: Mon May 20 12:33:39 2013 +1200

Fix InnoDB verification issue for MySQL 5.6 (Bug #1180243)

Use the command 'SHOW ENGINES' instead of 'SHOW VARIABLES'
See also:
http://dev.mysql.com/doc/refman/5.6/en/server-system-variables.html#sysvar_have_innodb

Change-Id: Ib97f7e1fdcc3c305db7864359fee7626f2f8a4f3
Signed-off-by: Son Nguyen <email address hidden>
Signed-off-by: Aaron Wells <email address hidden>

Revision history for this message
Aaron Wells (u-aaronw) wrote :

Oh, you're right, the result of "SHOW ENGINES;" in Herman's DB is right there in the bug description. Cool, looks like it will match up with the bug fix we've written.

Revision history for this message
Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/2272
Committed: http://gitorious.org/mahara/mahara/commit/5484d4f9c08a0c62962d8c27ecc69fb15e250d1f
Submitter: Robert Lyon (<email address hidden>)
Branch: 1.7_STABLE

commit 5484d4f9c08a0c62962d8c27ecc69fb15e250d1f
Author: Son Nguyen <email address hidden>
Date: Mon May 20 12:33:39 2013 +1200

Fix InnoDB verification issue for MySQL 5.6 (Bug #1180243)

Use the command 'SHOW ENGINES' instead of 'SHOW VARIABLES'
See also:
http://dev.mysql.com/doc/refman/5.6/en/server-system-variables.html#sysvar_have_innodb

Change-Id: Ib97f7e1fdcc3c305db7864359fee7626f2f8a4f3
Signed-off-by: Son Nguyen <email address hidden>
Signed-off-by: Aaron Wells <email address hidden>

Revision history for this message
Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/2271
Committed: http://gitorious.org/mahara/mahara/commit/4529f691605bfa73248ae11f9b7b804a0a3bd989
Submitter: Robert Lyon (<email address hidden>)
Branch: 1.6_STABLE

commit 4529f691605bfa73248ae11f9b7b804a0a3bd989
Author: Son Nguyen <email address hidden>
Date: Mon May 20 12:33:39 2013 +1200

Fix InnoDB verification issue for MySQL 5.6 (Bug #1180243)

Use the command 'SHOW ENGINES' instead of 'SHOW VARIABLES'
See also:
http://dev.mysql.com/doc/refman/5.6/en/server-system-variables.html#sysvar_have_innodb

Change-Id: Ib97f7e1fdcc3c305db7864359fee7626f2f8a4f3
Signed-off-by: Son Nguyen <email address hidden>
Signed-off-by: Aaron Wells <email address hidden>

Revision history for this message
Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/2270
Committed: http://gitorious.org/mahara/mahara/commit/5ac7a34daf4f96994c6fa576ad2420e396cb04ed
Submitter: Robert Lyon (<email address hidden>)
Branch: 1.5_STABLE

commit 5ac7a34daf4f96994c6fa576ad2420e396cb04ed
Author: Son Nguyen <email address hidden>
Date: Mon May 20 12:33:39 2013 +1200

Fix InnoDB verification issue for MySQL 5.6 (Bug #1180243)

Use the command 'SHOW ENGINES' instead of 'SHOW VARIABLES'
See also:
http://dev.mysql.com/doc/refman/5.6/en/server-system-variables.html#sysvar_have_innodb

Change-Id: Iee3ff04384f9115ceb7af3c7d852899efbd1d4de
Signed-off-by: Son Nguyen <email address hidden>

Robert Lyon (robertl-9)
Changed in mahara:
status: Confirmed → Fix Committed
Robert Lyon (robertl-9)
Changed in mahara:
status: Fix Committed → Fix Released
Aaron Wells (u-aaronw)
Changed in mahara:
milestone: 1.7.2 → 1.8.0
Aaron Wells (u-aaronw)
no longer affects: mahara/1.8
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers