program code error when create new rss feed in mahara 1.7.1

Bug #1177187 reported by William Chan
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mahara
Fix Released
Critical
Aaron Wells
1.5
Fix Released
Critical
Unassigned
1.6
Fix Released
Critical
Unassigned
1.7
Fix Released
Critical
Unassigned

Bug Description

I just install mahara 1.7.1 in our development server to test it before lauch to production.
However, I find rss feed error.
When I want to create new rss feed in my mahara new page . it show "A nonrecverable error occurred. This probabiliy means that you have encountered a bug in the system". While creating new rss feed in mahara 1.7 is okay.

From apache error log, the following is shown,
[Mon May 06 10:45:56 2013] [error] [client 121.125.125.157] [WAR] 4c (lib/dml.php:1576) Array to string conversion, referer: http://maharadev.atc.edu/view/blocks.php?id=125
[Mon May 06 10:45:56 2013] [error] [client 121.125.125.157] Call stack (most recent first):, referer: http://maharadev.atc.edu/view/blocks.php?id=125
[Mon May 06 10:45:56 2013] [error] [client 121.125.125.157] * log_message("Array to string conversion", 8, true, true, "/local/www/mahara/lib/dml.php", 1576) at /local/www/mahara/lib/errors.php:446, referer: http://maharadev.atc.edu/view/blocks.php?id=125
[Mon May 06 10:45:56 2013] [error] [client 121.125.125.157] * error(8, "Array to string conversion", "/local/www/mahara/lib/dml.php", 1576, array(size 4)) at Unknown:0, referer: http://maharadev.atc.edu/view/blocks.php?id=125
[Mon May 06 10:45:56 2013] [error] [client 121.125.125.157] * implode(",", array(size 3)) at /local/www/mahara/lib/dml.php:1576, referer: http://maharadev.atc.edu/view/blocks.php?id=125
[Mon May 06 10:45:56 2013] [error] [client 121.125.125.157] * create_sql_exception_message(object(ADODB_Exception), "SELECT * FROM "blocktype_externalfeed_data" WHERE ...", array(size 3)) at /local/www/mahara/lib/dml.php:492, referer: http://maharadev.atc.edu/view/blocks.php?id=125
[Mon May 06 10:45:56 2013] [error] [client 121.125.125.157] * get_recordset_sql("SELECT * FROM "blocktype_externalfeed_data" WHERE ...", array(size 3), 0, 2) at /local/www/mahara/lib/dml.php:333, referer: http://maharadev.atc.edu/view/blocks.php?id=125
[Mon May 06 10:45:56 2013] [error] [client 121.125.125.157] * get_record_sql("SELECT * FROM "blocktype_externalfeed_data" WHERE ...", array(size 3)) at /local/www/mahara/lib/dml.php:365, referer: http://maharadev.atc.edu/view/blocks.php?id=125
[Mon May 06 10:45:56 2013] [error] [client 121.125.125.157] * get_record_select("blocktype_externalfeed_data", ""url" = ? AND "authuser" = ? AND "authpassword" ...", array(size 3)) at /local/www/mahara/lib/dml.php:1143, referer: http://maharadev.atc.edu/view/blocks.php?id=125
[Mon May 06 10:45:56 2013] [error] [client 121.125.125.157] * ensure_record_exists("blocktype_externalfeed_data", array(size 3), object(stdClass), "id", true) at /local/www/mahara/blocktype/externalfeed/lib.php:272, referer: http://maharadev.atc.edu/view/blocks.php?id=125
[Mon May 06 10:45:56 2013] [error] [client 121.125.125.157] * PluginBlocktypeExternalfeed::instance_config_save(array(size 9), object(BlockInstance)) at Unknown:0, referer: http://maharadev.atc.edu/view/blocks.php?id=125
[Mon May 06 10:45:56 2013] [error] [client 121.125.125.157] * call_user_func_array(array(size 2), array(size 2)) at /local/www/mahara/lib/mahara.php:1365, referer: http://maharadev.atc.edu/view/blocks.php?id=125
[Mon May 06 10:45:56 2013] [error] [client 121.125.125.157] * call_static_method("PluginBlocktypeExternalfeed", "instance_config_save", array(size 9), object(BlockInstance)) at /local/www/mahara/blocktype/lib.php:537, referer: http://maharadev.atc.edu/view/blocks.php?id=125
[Mon May 06 10:45:56 2013] [error] [client 121.125.125.157] * BlockInstance->instance_config_store(object(Pieform), array(size 15)) at Unknown:0, referer: http://maharadev.atc.edu/view/blocks.php?id=125
[Mon May 06 10:45:56 2013] [error] [client 121.125.125.157] * call_user_func_array(array(size 2), array(size 2)) at /local/www/mahara/lib/pieforms/pieform.php:514, referer: http://maharadev.atc.edu/view/blocks.php?id=125
[Mon May 06 10:45:56 2013] [error] [client 121.125.125.157] * Pieform->__construct(array(size 15)) at /local/www/mahara/blocktype/lib.php:906, referer: http://maharadev.atc.edu/view/blocks.php?id=125
[Mon May 06 10:45:56 2013] [error] [client 121.125.125.157] * BlockInstance->build_configure_form() at /local/www/mahara/view/blocks.php:87, referer: http://maharadev.atc.edu/view/blocks.php?id=125
[Mon May 06 10:45:56 2013] [error] [client 121.125.125.157] , referer: http://maharadev.atc.edu/view/blocks.php?id=125
[Mon May 06 10:45:56 2013] [error] [client 121.125.125.157] [WAR] 4c (lib/errors.php:749) Failed to get a recordset: mysql error: [1054: Unknown column 'Array' in 'where clause'] in adodb_throw(SELECT * FROM "blocktype_externalfeed_data" WHERE "url" = 'http://www.feedforall.com/sample-feed.xml' AND "authuser" = '' AND "authpassword" = Array LIMIT 2, ), referer: http://maharadev.atc.edu/view/blocks.php?id=125
[Mon May 06 10:45:56 2013] [error] [client 121.125.125.157] [WAR] 4c (lib/errors.php:749) Command was: SELECT * FROM "blocktype_externalfeed_data" WHERE "url" = ? AND "authuser" = ? AND "authpassword" = ? and values was (http://www.feedforall.com/sample-feed.xml,,Array), referer: http://maharadev.atc.edu/view/blocks.php?id=125
[Mon May 06 10:45:56 2013] [error] [client 121.125.125.157] Call stack (most recent first):, referer: http://maharadev.atc.edu/view/blocks.php?id=125
[Mon May 06 10:45:56 2013] [error] [client 121.125.125.157] * log_message("Failed to get a recordset: mysql error: [1054: Unk...", 8, true, true) at /local/www/mahara/lib/errors.php:109, referer: http://maharadev.atc.edu/view/blocks.php?id=125
[Mon May 06 10:45:56 2013] [error] [client 121.125.125.157] * log_warn("Failed to get a recordset: mysql error: [1054: Unk...") at /local/www/mahara/lib/errors.php:749, referer: http://maharadev.atc.edu/view/blocks.php?id=125
[Mon May 06 10:45:56 2013] [error] [client 121.125.125.157] * SQLException->__construct("Failed to get a recordset: mysql error: [1054: Unk...") at /local/www/mahara/lib/dml.php:492, referer: http://maharadev.atc.edu/view/blocks.php?id=125
[Mon May 06 10:45:56 2013] [error] [client 121.125.125.157] * get_recordset_sql("SELECT * FROM "blocktype_externalfeed_data" WHERE ...", array(size 3), 0, 2) at /local/www/mahara/lib/dml.php:333, referer: http://maharadev.atc.edu/view/blocks.php?id=125
[Mon May 06 10:45:56 2013] [error] [client 121.125.125.157] * get_record_sql("SELECT * FROM "blocktype_externalfeed_data" WHERE ...", array(size 3)) at /local/www/mahara/lib/dml.php:365, referer: http://maharadev.atc.edu/view/blocks.php?id=125
[Mon May 06 10:45:56 2013] [error] [client 121.125.125.157] * get_record_select("blocktype_externalfeed_data", ""url" = ? AND "authuser" = ? AND "authpassword" ...", array(size 3)) at /local/www/mahara/lib/dml.php:1143, referer: http://maharadev.atc.edu/view/blocks.php?id=125
[Mon May 06 10:45:56 2013] [error] [client 121.125.125.157] * ensure_record_exists("blocktype_externalfeed_data", array(size 3), object(stdClass), "id", true) at /local/www/mahara/blocktype/externalfeed/lib.php:272, referer: http://maharadev.atc.edu/view/blocks.php?id=125
[Mon May 06 10:45:56 2013] [error] [client 121.125.125.157] * PluginBlocktypeExternalfeed::instance_config_save(array(size 9), object(BlockInstance)) at Unknown:0, referer: http://maharadev.atc.edu/view/blocks.php?id=125
[Mon May 06 10:45:56 2013] [error] [client 121.125.125.157] * call_user_func_array(array(size 2), array(size 2)) at /local/www/mahara/lib/mahara.php:1365, referer: http://maharadev.atc.edu/view/blocks.php?id=125
[Mon May 06 10:45:56 2013] [error] [client 121.125.125.157] * call_static_method("PluginBlocktypeExternalfeed", "instance_config_save", array(size 9), object(BlockInstance)) at /local/www/mahara/blocktype/lib.php:537, referer: http://maharadev.atc.edu/view/blocks.php?id=125
[Mon May 06 10:45:56 2013] [error] [client 121.125.125.157] * BlockInstance->instance_config_store(object(Pieform), array(size 15)) at Unknown:0, referer: http://maharadev.atc.edu/view/blocks.php?id=125
[Mon May 06 10:45:56 2013] [error] [client 121.125.125.157] * call_user_func_array(array(size 2), array(size 2)) at /local/www/mahara/lib/pieforms/pieform.php:514, referer: http://maharadev.atc.edu/view/blocks.php?id=125
[Mon May 06 10:45:56 2013] [error] [client 121.125.125.157] * Pieform->__construct(array(size 15)) at /local/www/mahara/blocktype/lib.php:906, referer: http://maharadev.atc.edu/view/blocks.php?id=125
[Mon May 06 10:45:56 2013] [error] [client 121.125.125.157] * BlockInstance->build_configure_form() at /local/www/mahara/view/blocks.php:87, referer: http://maharadev.atc.edu/view/blocks.php?id=125
[Mon May 06 10:45:56 2013] [error] [client 121.125.125.157] , referer: http://maharadev.atc.edu/view/blocks.php?id=125

Tags: mysql rss
Revision history for this message
Aaron Wells (u-aaronw) wrote :

Thanks for the bug report! It looks like this is a regression caused by the security changes I made around RSS block passwords in 1.7.1, and it only shows up if your database is MySQL.

I've posted a bug fix on the tracker here: https://reviews.mahara.org/2147

Cheers,
Aaron

Changed in mahara:
status: New → In Progress
importance: Undecided → Critical
assignee: nobody → Aaron Wells (u-aaronw)
milestone: none → 1.7.2
milestone: 1.7.2 → none
tags: added: mysql rss
Revision history for this message
Mahara Bot (dev-mahara) wrote : A change has been merged

Reviewed: https://reviews.mahara.org/2147
Committed: http://gitorious.org/mahara/mahara/commit/6d1791e6e43772460ee642f91f9803172acaf438
Submitter: Son Nguyen (<email address hidden>)
Branch: 1.7_STABLE

commit 6d1791e6e43772460ee642f91f9803172acaf438
Author: Aaron Wells <email address hidden>
Date: Mon May 13 11:28:00 2013 +1200

blocktype/externalfeed: Fix MySQL problem when creating new RSS block

Bug 1177187

Signed-off-by: Aaron Wells <email address hidden>
Change-Id: I5c0bc5c7067571042bd8c4f5d51664f40b8fe671

Revision history for this message
Aaron Wells (u-aaronw) wrote :
Revision history for this message
Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/2148
Committed: http://gitorious.org/mahara/mahara/commit/32f54d3d0b547779baaea3becb5a625bb808a5a3
Submitter: Aaron Wells (<email address hidden>)
Branch: 1.5_STABLE

commit 32f54d3d0b547779baaea3becb5a625bb808a5a3
Author: Aaron Wells <email address hidden>
Date: Mon May 13 11:28:00 2013 +1200

blocktype/externalfeed: Fix MySQL problem when creating new RSS block

Bug 1177187

Signed-off-by: Aaron Wells <email address hidden>
Change-Id: I5c0bc5c7067571042bd8c4f5d51664f40b8fe671

Revision history for this message
Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/2149
Committed: http://gitorious.org/mahara/mahara/commit/3898ec03fa9b38e643ea4e52d2b3f8eb104de672
Submitter: Aaron Wells (<email address hidden>)
Branch: 1.6_STABLE

commit 3898ec03fa9b38e643ea4e52d2b3f8eb104de672
Author: Aaron Wells <email address hidden>
Date: Mon May 13 11:28:00 2013 +1200

blocktype/externalfeed: Fix MySQL problem when creating new RSS block

Bug 1177187

Signed-off-by: Aaron Wells <email address hidden>
Change-Id: I5c0bc5c7067571042bd8c4f5d51664f40b8fe671

Revision history for this message
Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/2150
Committed: http://gitorious.org/mahara/mahara/commit/8e9f8ef309a62fd3bda3e3ab3f3d5239e3335330
Submitter: Aaron Wells (<email address hidden>)
Branch: master

commit 8e9f8ef309a62fd3bda3e3ab3f3d5239e3335330
Author: Aaron Wells <email address hidden>
Date: Mon May 13 11:28:00 2013 +1200

blocktype/externalfeed: Fix MySQL problem when creating new RSS block

Bug 1177187

Signed-off-by: Aaron Wells <email address hidden>
Change-Id: I5c0bc5c7067571042bd8c4f5d51664f40b8fe671

Aaron Wells (u-aaronw)
Changed in mahara:
milestone: none → 1.8.0rc1
no longer affects: mahara/1.8
Changed in mahara:
status: In Progress → Fix Committed
Aaron Wells (u-aaronw)
Changed in mahara:
milestone: 1.8rc1 → 1.8.0
Aaron Wells (u-aaronw)
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers