Make it more obvious when adding a page to a collection that same access rules apply

Bug #1070019 reported by Kristina Hoeppner on 2012-10-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
High
Robert Lyon

Bug Description

When a user creates a collection and makes that accessible to a group of people, all pages within the collection receive the same access permissions (wanted behavior).

When the user adds another page to the collection, this page immediately takes on these access permissions as well (wanted behavior). However, the user is not alerted to that fact but it is only implied.

It should be more obvious that when a page gets added to a collection that the same access permissions apply as to the rest of the collection to give the user the chance to review these access permissions.

Changed in mahara:
status: New → Triaged
importance: Medium → High
Son Nguyen (ngson2000) wrote :

I think we can improve this with:

1. A better message when adding a page into a collection (/collection/views.php):
"Page added to collection and took access from the collection. Collection updated to include access from new page."
2. Show list of pages in a collection in /view/share.php like those in /collection/index.php

Clarification for my initial report: A message is displayed saying that the access permissions have been updated, but there is no shared page notification sent out because the pages had already been shared previously. Sure, this avoids notifications, but the current message is not very obvious (it's small and in green).

I think a popup message would be better than just a screen confirmation as that is overlooked very easily. We might also have to have different messages, e.g. one for when the collection takes on the access permissions of the pages that were added to the collection and another one for when a new page is added to a collection and takes on these sharing permissions.

The issue is not that the user doesn't know what pages are in the collection, but that the information about the access permissions is not easily visible. Thus, for this bug here I would not add the pages on /view/share.php for the collection. If that is an issue for users, it should receive it's own feature request.

tags: added: academy
Son Nguyen (ngson2000) on 2013-03-10
Changed in mahara:
assignee: nobody → Son Nguyen (ngson2000)
Son Nguyen (ngson2000) on 2013-03-11
Changed in mahara:
assignee: Son Nguyen (ngson2000) → Aaron Wells (u-aaronw)
Aaron Wells (u-aaronw) on 2013-03-14
Changed in mahara:
milestone: 1.7.0 → 1.8.0
Aaron Wells (u-aaronw) on 2013-08-19
Changed in mahara:
milestone: 1.8.0rc1 → none
Robert Lyon (robertl-9) on 2014-08-04
Changed in mahara:
assignee: Aaron Wells (u-aaronw) → Robert Lyon (robertl-9)
status: Triaged → In Progress
milestone: none → 1.10.0

Reviewed: https://reviews.mahara.org/3472
Committed: http://gitorious.org/mahara/mahara/commit/e3f082d7c850cbe4a0db98b63949b74bf4ce5e93
Submitter: Son Nguyen (<email address hidden>)
Branch: master

commit e3f082d7c850cbe4a0db98b63949b74bf4ce5e93
Author: Robert Lyon <email address hidden>
Date: Thu Jul 3 17:30:23 2014 +1200

Alerting if added pages to collection change access perms (Bug #1070019)

A popup alert containing the name of the page(s) that have changed
permissions.

If an added page has a permssion that the parent doesn't then the
alert will contain the names of the existing pages in the collection
as well because their access permissions will have also changed.

Change-Id: If7391427ab2b358ebcf85a3292282ab5075ffbe4
Signed-off-by: Robert Lyon <email address hidden>

Changed in mahara:
status: In Progress → Fix Committed
tags: added: usermanualupdate
Aaron Wells (u-aaronw) on 2014-10-21
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers