Wishlist : enabling to download an entire folder

Bug #1013022 reported by Jean-Baptiste BOUGNET on 2012-06-14
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Mahara
Medium
Jono Mingard

Bug Description

This is not a bug record, but a new item for the wishlist.
I'd like to add the ability to download a folder at once.
Right now (Mahara 1.5 or previous versions), if you want to download the content of a folder, you have to download each files one by one.
Would it be possible to enable to download a complete folder at once ? (zipped ?)
Thanks

Changed in mahara:
importance: Undecided → Wishlist
status: New → Triaged
tags: removed: wishlist
Changed in mahara:
assignee: nobody → Christopher Tombleson (christopher-k)
Hugh Davenport (hugh-davenport) wrote :
Changed in mahara:
status: Triaged → In Progress
Changed in mahara:
milestone: none → 1.7.0

Because it will support usability, I vote for it.

Aaron Wells (u-aaronw) on 2013-04-19
Changed in mahara:
milestone: 1.7.0 → 1.8.0
importance: Wishlist → Medium
Aaron Wells (u-aaronw) on 2013-09-30
Changed in mahara:
milestone: 1.8rc1 → 1.8.0
Aaron Wells (u-aaronw) on 2013-10-03
Changed in mahara:
milestone: 1.8.0 → 1.9.0
Robert Lyon (robertl-9) wrote :

The following test failed for this patch

As admin:
I enable the download folders option

As user A:
I create a folder in Content -> files and add some files there
I add the folder block to a page
I share page with logged-in users

As user B:
I view page and click on download folder button
- I get "Access denied
You do not have access to view this page."

Steven (stevens-q) wrote :

=== Bug #1013022 enabling to download an entire folder ===

**Prerequisites**
As admin: enable the download folders option found under the Extensions tab => Plugin type: artefact => file [ Configuration ]

=== How to test ===
1. Log in as a user and create a folder in Content -> files and add some files there
2. add the folder block to a page
3. share page with logged-in users
4. log in as another user and view page with the folder block and click on download button
5. Confirm that the folder can be downloaded as a zip file

=== Test Results ===
5. Confirmed that the folder can be downloaded as a zip file ✔

Catalyst QA Approved ✔

Steven (stevens-q) wrote :

=== Bug #1013022 enable/disable users to download an entire folder from within a folder block ===

**Prerequisites**
As admin: enable the download folders option found under the Extensions tab => Plugin type: artefact => file [ Configuration ]

=== How to test ===
1. Log in as a user and create 2 folders with files inside in Content -> files
2. add 2 folder blocks to a page
3. Set one folder block to "Download folders as a zip file" check box to ticked and the other folder block to unticked
4. share page with logged-in users
5. log in as another user and view page with the folder blocks and click on download button
6. Confirm that the folder can be downloaded as a zip file
7. Confirm that the other folder block does not have an option to download

=== Test Results ===
5. Confirmed that the folder can be downloaded as a zip file ✔
6. Confirmed that the other folder block does not have an option to download ✔

Catalyst QA Approved ✔

Aaron Wells (u-aaronw) wrote :

Robert also uploaded this patch, which lets the "download" link be enabled/disabled on a per-block basis: https://reviews.mahara.org/#/c/2874/

Mahara Bot (dev-mahara) wrote :

Patch for "master" branch: https://reviews.mahara.org/2889

Reviewed: https://reviews.mahara.org/2888
Committed: http://gitorious.org/mahara/mahara/commit/189d268e2865ce27524bf7fbf26ba2a4fb0a9860
Submitter: Aaron Wells (<email address hidden>)
Branch: master

commit 189d268e2865ce27524bf7fbf26ba2a4fb0a9860
Author: Robert Lyon <email address hidden>
Date: Wed Jan 8 14:50:54 2014 +1300

Stringifying some download folder zip hardcoded strings (bug 1013022)

Change-Id: If994c53831801ca20ed90003e3fc7581eada2a20
Signed-off-by: Robert Lyon <email address hidden>

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/2889
Committed: http://gitorious.org/mahara/mahara/commit/474a34aa6fd060800fddc272db53fb1322afcf6c
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 474a34aa6fd060800fddc272db53fb1322afcf6c
Author: Robert Lyon <email address hidden>
Date: Wed Jan 8 14:54:39 2014 +1300

Turning on download zip by default for new installs (bug 1013022)

Change-Id: Ib726d0d6ffd2286006ccef4f0c1cfce7c9778d66
Signed-off-by: Robert Lyon <email address hidden>

Aaron Wells (u-aaronw) wrote :

I just realized one more thing we should change relating to this. The sitewide config setting to enable/disable it belongs under the "Plugin type: blocktype -> file/folder -> Configuration" page. Currently it's under "Plugin type: artefact -> file -> file -> Configuration".

The sitewide config for how long to keep the zip files... that one is trickier. Since we potentially might be using those zip files for downloading folders via the "Content -> Files" page as well as via the block, it probably makes sense to leave it under the artefact config.

Changed in mahara:
assignee: Christopher Tombleson (christopher-k) → nobody
assignee: nobody → Jono Mingard (mingard)
tags: added: nominatedfeature
Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/2801
Committed: http://gitorious.org/mahara/mahara/commit/bd3d6184bcdc5fd411e8d36c6df431b955758890
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit bd3d6184bcdc5fd411e8d36c6df431b955758890
Author: Jono Mingard <email address hidden>
Date: Mon Dec 16 10:32:46 2013 +1300

Download any folder as a zip file (from file browser) (Bug #1013022)

Modified artefact/file/downloadfolder.php to allow downloading a
user's home folder
Added "Download" link to bottom of file browser which downloads the
current directory

Also removed the extra '.' appended to files with no extension by
download_title() and stringified some hardcoded values introduced by
the previous patch

Also got the download link to show when viewing artefact.

Change-Id: I098aef225f4d67b162dcc0881b3c04662ce9d3fe
Signed-off-by: Jono Mingard <email address hidden>
Signed-off-by: Jono Mingard <email address hidden>

Reviewed: https://reviews.mahara.org/3128
Committed: http://gitorious.org/mahara/mahara/commit/797a04f84d3db9043dfa14798273c5cde8f50ff9
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 797a04f84d3db9043dfa14798273c5cde8f50ff9
Author: Kristina D.C. Hoeppner <email address hidden>
Date: Thu Mar 27 20:28:08 2014 +1300

Small lang string fix (Bug 1013022)

Get rid of the non-HTML arrow which can cause
accessibility issues.

Change-Id: I3d4086b3bbd8c22db0da617ee070d5f47a8a4efa
Signed-off-by: Kristina D.C. Hoeppner <email address hidden>

Robert Lyon (robertl-9) on 2014-03-27
Changed in mahara:
status: In Progress → Fix Committed
Robert Lyon (robertl-9) on 2014-04-22
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers