Magento Connection Access denied in Synchronize Referential

Bug #610450 reported by Almanar on 2010-07-27
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Magento OpenERP Connector
Invalid
Undecided
Unassigned

Bug Description

From my openerp Gtk client, to create a new instance in Magento Connection > Core Settings > Magento Instances
When I click the button ; Synchronize Referential Setting , it get this Error :

Magento Connection:Attempting connection with Settings:http://localhost/magento/index.php/api/xmlrpc/,u1,magento

ERROR:Magento Connection:[16]: Error in connecting:<Fault 2: 'Access denied.'>

WARNING:Magento Call:Webservice Failure,

I use Openerp-5.0.10
Xampp 1.6.4
Magento 1.6.4
Ubuntu 9.04

Almanar (moudarir-yahoo) wrote :

by the way, i create a web user service with password, that i mentiened in the openerp magento instance.

I use the last version 1.0 (not 0.2 in launchpad) of the connector downloaded from this site :
http://openlabs.co.in/openerp/repositories/miscellaneous/magentoerpconnect/

And the other module also from openlabs :
product_m2mcategories, base_sale_multichannels, product_images_olbs,

Almanar (moudarir-yahoo) wrote :

Hi every body,
So now I install Magento 1.3.4.2 under ubuntu apache, php and mysql, not under xampp (lampp)
But I can not install the Openlabs_magentoopenerpconnector module under Connector Manager
Neither by manually with ./pear
It download it, but i dont see that it install it
I copied the file and directory manualy fro; the tgz file dowloaded

Maybe it's pear version probleme ?

I have not get the error <Fault 2: 'Access denied.'>

When click on button : Synchronize Referentiel
I see in the Openerp server log that I'm loged in succefully with the username and the Api key (password)

But indeed I have another error :

<Fault 3: 'Unknown Api Path.'>

Please Help.

ntrubert-cobweb (ntrubert) wrote :

Which kind of url you have ?

I got same error when I was using:

Location : http://mywebsite.com/shop

I did sub-domain

Location : http://shop.mywebsite.com

And it works!

Almanar (moudarir-yahoo) wrote :
Download full text (3.4 KiB)

I have exactly this Openerp Error :

[2010-07-28 11:05:04,044] INFO:Magento Connection:Attempting connection with Settings:http://ifrane.com/magento/index.php/api/xmlrpc/,magwebservice,magwebservice
[2010-07-28 11:05:04,461] INFO:Magento Connection:Login Successful
[2010-07-28 11:05:04,482] INFO:Magento Connection:Calling Method:ol_websites.list,Arguments:[]

[2010-07-28 11:05:05,563] ERROR:Magento Call:[16]: Method: ol_websites.list
[2010-07-28 11:05:05,563] ERROR:Magento Call:[17]: Arguments:[]
[2010-07-28 11:05:05,563] ERROR:Magento Call:[18]: Error:
[2010-07-28 11:05:05,569] WARNING:Magento Call:Webservice Failure, sleeping 1 second before next attempt
[2010-07-28 11:05:06,577] INFO:Magento Connection:Calling Method:ol_websites.list,Arguments:[]

[2010-07-28 11:05:10,677] INFO:Magento Connection:Calling Method:ol_websites.list,Arguments:[]

[2010-07-28 11:05:18,307] ERROR:web-services:[17]: File "/openerp/openerp-server5010/bin/osv/osv.py", line 58, in wrapper
[2010-07-28 11:05:18,308] ERROR:web-services:[18]: return f(self, dbname, *args, **kwargs)
[2010-07-28 11:05:18,308] ERROR:web-services:[19]: File "/openerp/openerp-server5010/bin/osv/osv.py", line 119, in execute
[2010-07-28 11:05:18,308] ERROR:web-services:[20]: res = pool.execute_cr(cr, uid, obj, method, *args, **kw)
[2010-07-28 11:05:18,308] ERROR:web-services:[21]: File "/openerp/openerp-server5010/bin/osv/osv.py", line 111, in execute_cr
[2010-07-28 11:05:18,308] ERROR:web-services:[22]: return getattr(object, method)(cr, uid, *args, **kw)
[2010-07-28 11:05:18,308] ERROR:web-services:[23]: File "/openerp/openerp-server5010/bin/addons/magentoerpconnect/magerp_core.py", line 58, in core_sync
[2010-07-28 11:05:18,309] ERROR:web-services:[24]: self.pool.get('external.shop.group').mage_import_base(cr, uid,core_imp_conn, inst.id, defaults={'referential_id':inst.id})
[2010-07-28 11:05:18,313] ERROR:web-services:[25]: File "/openerp/openerp-server5010/bin/addons/magentoerpconnect/magerp_osv.py", line 223, in mage_import_base
[2010-07-28 11:05:18,316] ERROR:web-services:[26]: data = conn.call(list_method, context['ids_or_filter'])
[2010-07-28 11:05:18,317] ERROR:web-services:[27]: File "/openerp/openerp-server5010/bin/addons/magentoerpconnect/magerp_osv.py", line 53, in call
[2010-07-28 11:05:18,317] ERROR:web-services:[28]: res = self.ser.call(self.session, method, arguments)
[2010-07-28 11:05:18,317] ERROR:web-services:[29]: File "/usr/lib/python2.6/xmlrpclib.py", line 1199, in __call__
[2010-07-28 11:05:18,317] ERROR:web-services:[30]: return self.__send(self.__name, args)
[2010-07-28 11:05:18,317] ERROR:web-services:[31]: File "/usr/lib/python2.6/xmlrpclib.py", line 1489, in __request
[2010-07-28 11:05:18,317] ERROR:web-services:[32]: verbose=self.__verbose
[2010-07-28 11:05:18,318] ERROR:web-services:[33]: File "/usr/lib/python2.6/xmlrpclib.py", line 1253, in request
[2010-07-28 11:05:18,318] ERROR:web-services:[34]: return self._parse_response(h.getfile(), sock)
[2010-07-28 11:05:18,318] ERROR:web-services:[35]: File "/usr/lib/python2.6/xmlrpclib.py", line 1392, in _parse_response
[2010-07-28 11:05:18,318] ERROR:web-service...

Read more...

Almanar (moudarir-yahoo) wrote :

[Resolved]

Oh God, I finally success to Synchronize Referential Setting :)

Here's the step :

If you don't success with magento version 1.3.2.4 to install Openlabs_OpenERPConnector Extension in Magento Connect Manager then :

1- upload the magento-module : Openlabs_OpenERPConnector-1.3.1.tgz
The copied it manualy in magento/app/....
the exact directories destination is in package.xml file

2- Generate a Package in Magento Connect / Package Extension

in Content Tabs
Openlabs/OpenERPConnector as Magento Community Module (type Recursive Directory)
modules/Openlabs_OpenERPConnector.xml as Magento Global Configuration (File)

in Load local Package : yous can see Openlabs_OpenERPConnector select it and clik "Save data and Create Package"

In each step you can clik "Save".

3- Delete all cache : rm file in magento/var/session/* and magento/var/cache/*

and now the synchronize can be done ok

Please Thomas, take a look to this extension 1.3.1 to be installed automatiquely from Magento Connect Manager interface, in the simple environnement within Apache2, php5, mysql, instead of only the xampp or wampp one.

Almanar (moudarir-yahoo) wrote :

Don't forget to verify that you have XML_Util-1.2.3 installed

Because of version Magento 1.3.2.4, XML/Util.php is missing from directory ...downloader/pearlib/php/

you can download the file from http://pear.php.net/package/XML_Util/download
or pear install XML_Util-1.2.1

Extract the file to here ... downloader/pearlib/php/

Kyle Waid (midwest) wrote :

You also have to have your settings to download beta packages, or it will fail.

Kyle Waid (midwest) on 2011-01-18
Changed in magentoerpconnect:
status: New → Invalid
Ivan Candelas (shellbofh) wrote :

Hi folks,

I got the same error and i can't resolve following the instructions of #5, ima using magento 1.5, is this compatible with the extension?

Kyle Waid (midwest) wrote :

You could have 3 issues. This will be the end of this problem.

1. You have not defined a webservice user in magento with all rights assigned or you have the credentials wrong

2. you have specified a wrong path for your website. http://www.site.com

3. you have improperly installed the magento side module.
a. You must get the right source for the module, not some package
b. You have to properly install it. After you place the files in the "correct" locations you must reload your system configuration so it will recognize the module as being installed. You can check if the module is installed properly by going to your system configuration in your admin panel.

Kyle Waid (midwest) wrote :

Some additional information for you.
if you get successful connection then
Method:ol_websites.list,Arguments:[]
and then invalid api path. It means that your module in magento is not installed properly. The core magento API does not return a list of websites which is the initial request from openerp. the openerp magento module responds with that request.

andreas owen (aowen) wrote :

I am using Magento 1.5.1 on a linux nas with apache2, mysql, python 2.6 and was able to install the module with Magento Connector 2.0

The install worked without errors and Openlabs_OpenERPConnector 1.3.1.1 (alpha) is listed as installed in the Magento Connector

deleted var/cache/*

reindexed cache in System / Cache Management

There is no Menu entry in System / Configuration

When Openerp tries to connect it gets the typical Invalid Api error: Method:ol_websites.list,Arguments:[]

I checked the folder app/code/community and it contains the OpenLabs folder as defined in package.xml

I havent got a xml file in app/etc/modules

What can I do now?

Arno Nebauer (arno-shopnix) wrote :

@ kyle:

You wrote:
 3. you have improperly installed the magento side module.
 a. You must get the right source for the module, not some package

I understand this very well, but which of all those sources is the right source for the magento-module Openlabs_OpenERPConnector 1.3.1.1 (alpha) ?

Kyle Waid (midwest) wrote :

Arno,

you are talking about the magento connect repository but there is a repository here on launchpad.
lp:magentoerpconnect/magento-module

Try installing the module manually,
clear the session data and cache
go to system > advanced > advanced
click save, it will reload your modules

If you still have problems after trying the different versions you would need to have someone look at it for you. Let me know if this works for you and if it doesnt contact me via email and I will see if I can help you.

Andreas,
I would suggest following the same. the folder structure is somewhat like
/etc/code/community/Openlabs/OpenERPConnector

You can do the same if you cant figure it out. Thanks!

Download full text (8.0 KiB)

Hi Kyle,

even with the module from launchpad, I got the same error messages.
Really strange is the fact, that i received the products categories
perfectly.

In the Apache Logfiles are only successful requests. Maybe the error
message "Invalid api path" appears under several circumstances.

Mentioned below you will find the error messages in detail.

I have OpenERP (6.02) as well as Magento (1.5.1) up and running as test
installation in the internet. Any help is really welcome.

Best regards,
Arno Nebauer

Deleted Magento cache in /var/cache

Klick on "2 - Synchronize Referential Settings" results in Error <Fault
3: 'Invalid api path.'>:
+++++++++++++++++++++++++++++++++++++++
Environment Information :
System : Linux-2.6.32-5-686-i686-with-debian-6.0.2
OS Name : posix
Distributor ID: Debian
Description: Debian GNU/Linux 6.0.2 (squeeze)
Release: 6.0.2
Codename: squeeze
Operating System Release : 2.6.32-5-686
Operating System Version : #1 SMP Mon Jun 13 04:13:06 UTC 2011
Operating System Architecture : 32bit
Operating System Locale : de_DE.UTF8
Python Version : 2.6.6
OpenERP-Client Version : 6.0.2
Last revision No. & ID :Bazaar Package not Found !Traceback (most recent
call last):
   File "/usr/share/pyshared/openerp-server/netsvc.py", line 489, in
dispatch
     result = ExportService.getService(service_name).dispatch(method,
auth, params)
   File "/usr/share/pyshared/openerp-server/service/web_services.py",
line 599, in dispatch
     res = fn(db, uid, *params)
   File "/usr/share/pyshared/openerp-server/osv/osv.py", line 122, in
wrapper
     return f(self, dbname, *args, **kwargs)
   File "/usr/share/pyshared/openerp-server/osv/osv.py", line 176, in
execute
     res = self.execute_cr(cr, uid, obj, method, *args, **kw)
   File "/usr/share/pyshared/openerp-server/osv/osv.py", line 167, in
execute_cr
     return getattr(object, method)(cr, uid, *args, **kw)
   File
"/usr/share/pyshared/openerp-server/addons/magentoerpconnect.zip/magentoerpconnect/magerp_core.py",
line 64, in core_sync
     self.pool.get('external.shop.group').mage_import_base(cr,
uid,core_imp_conn, inst.id, defaults={'referential_id':inst.id})
   File
"/usr/share/pyshared/openerp-server/addons/magentoerpconnect.zip/magentoerpconnect/magerp_osv.py",
line 227, in mage_import_base
     data = conn.call(list_method, context['ids_or_filter'])
   File
"/usr/share/pyshared/openerp-server/addons/magentoerpconnect.zip/magentoerpconnect/magerp_osv.py",
line 53, in call
     res = self.ser.call(self.session, method, arguments)
   File "/usr/lib/python2.6/xmlrpclib.py", line 1199, in __call__
     return self.__send(self.__name, args)
   File "/usr/lib/python2.6/xmlrpclib.py", line 1489, in __request
     verbose=self.__verbose
   File "/usr/lib/python2.6/xmlrpclib.py", line 1253, in request
     return self._parse_response(h.getfile(), sock)
   File "/usr/lib/python2.6/xmlrpclib.py", line 1392, in _parse_response
     return u.close()
   File "/usr/lib/python2.6/xmlrpclib.py", line 838, in close
     raise Fault(**self._stack[0])
Fault: <Fault 3: 'Invalid api path.'>
++++++++++++++++++++++++++++++++++++++++++++++++
Apaches logfile says:
46.4.216.219 - - [18...

Read more...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers