NotReadableJobError: ('Could not unpickle.', 'False')

Bug #1362258 reported by Atul
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Magento OpenERP Connector

Bug Description

I installed magento connector and it was working fine but unfortunatly my customer update it connector module from Apps Menu ,
Now i am getting no handler error but when i go back and look my log file then i got the error

Client Traceback (most recent call last):
  File "/opt/openerp/server/openerp/addons/web/", line 204, in dispatch
    response["result"] = method(self, **self.params)
  File "/opt/openerp/server/openerp/addons/web/controllers/", line 1132, in call_button
    action = self._call_kw(req, model, method, args, {})
  File "/opt/openerp/server/openerp/addons/web/controllers/", line 1120, in _call_kw
    return getattr(req.session.model(model), method)(*args, **kwargs)
  File "/opt/openerp/server/openerp/addons/web/", line 42, in proxy
    result = self.proxy.execute_kw(self.session._db, self.session._uid, self.session._password, self.model, method, args, kw)
  File "/opt/openerp/server/openerp/addons/web/", line 30, in proxy_method
    result = self.session.send(self.service_name, method, *args)
  File "/opt/openerp/server/openerp/addons/web/", line 103, in send
    raise xmlrpclib.Fault(, formatted_info)

Server Traceback (most recent call last):
  File "/opt/openerp/server/openerp/addons/web/", line 89, in send
    return openerp.netsvc.dispatch_rpc(service_name, method, args)
  File "/opt/openerp/server/openerp/", line 296, in dispatch_rpc
    result = ExportService.getService(service_name).dispatch(method, params)
  File "/opt/openerp/server/openerp/service/", line 626, in dispatch
    res = fn(db, uid, *params)
  File "/opt/openerp/server/openerp/osv/", line 190, in execute_kw
    return self.execute(db, uid, obj, method, *args, **kw or {})
  File "/opt/openerp/server/openerp/osv/", line 132, in wrapper
    return f(self, dbname, *args, **kwargs)
  File "/opt/openerp/server/openerp/osv/", line 199, in execute
    res = self.execute_cr(cr, uid, obj, method, *args, **kw)
  File "/opt/openerp/server/openerp/osv/", line 187, in execute_cr
    return getattr(object, method)(cr, uid, *args, **kw)
  File "/opt/openerp/magento_addons/openerp-connector/connector/queue/", line 393, in requeue
    self.pool.get('queue.job').requeue(cr, uid, job_ids, context=context)
  File "/opt/openerp/magento_addons/openerp-connector/connector/queue/", line 127, in requeue
    self._change_job_state(cr, uid, ids, PENDING, context=context)
  File "/opt/openerp/magento_addons/openerp-connector/connector/queue/", line 110, in _change_job_state
    job = storage.load(job.uuid)
  File "/opt/openerp/magento_addons/openerp-connector/connector/queue/", line 246, in load
    func = _unpickle(str(stored.func))
  File "/opt/openerp/magento_addons/openerp-connector/connector/queue/", line 71, in _unpickle
    raise NotReadableJobError('Could not unpickle.', pickled)
NotReadableJobError: ('Could not unpickle.', 'False')

For avoiding this error i also follow some patched which is provided by other's contributor

also follow this

please any one can help me

Revision history for this message
Atul (jain-atul43) wrote :

i already update modules and also database , now please tell me how to get out from this bug

Changed in magentoerpconnect:
status: New → In Progress
status: In Progress → New
Revision history for this message
Guewen Baconnier @ Camptocamp (gbaconnier-c2c) wrote :


Here is the bug tracker for the Magento Connector for OpenERP 7.0:
If your customer updated the module from the Apps menu, it means that it installed an old version.
You must remove the module that has been installed by Apps.

Changed in magentoerpconnect:
status: New → Invalid
Revision history for this message
Guewen Baconnier @ Camptocamp (gbaconnier-c2c) wrote :

is merged already, so if you does not have this, it means you are running an old version

Revision history for this message
Atul (jain-atul43) wrote :

But i also update latest module from launchpad but it showinng me same error

and i also try to use this patch's and solution but still not able to solve this issue

even i also update the addons (new addons )

i also update database but stoll got same issue

Changed in magentoerpconnect:
status: Invalid → New
Revision history for this message
Atul (jain-atul43) wrote :

Noupdate regarding this bugs

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers