MadWifi - Atheros Drivers

Upgrade Atheros drivers to snapshot/trunk to support AR5008/AR5418

Reported by Don Smith on 2007-06-27
48
Affects Status Importance Assigned to Milestone
MadWifi
Fix Released
Unknown
linux-restricted-modules-2.6.22 (Baltix)
Undecided
Unassigned
linux-restricted-modules-2.6.24 (Ubuntu)
Low
Unassigned
Hardy
Low
Unassigned

Bug Description

The current atheros svn trunk includes support for AR5008. It would be great if this worked without making people compile the module themselves.

Also supported is the AR5418 (MacBook Pro) and AR5212 (Lenovo Thinkpad T61).

Don Smith (donsmith77) wrote :

See http://madwifi.org/ticket/1001 for details (Adding from svn trunk would enable wifi on 2nd gen macbooks and macbook pros without ndiswrapper)

Changed in linux-restricted-modules-2.6.22:
assignee: nobody → canonical-kernel-team
Tim Gardner (timg-tpi) wrote :

I'll incorporate updated Atheros support into linux-restricted-modules when madwifi.org releases the next official version.

Changed in linux-restricted-modules-2.6.22:
assignee: canonical-kernel-team → timg-tpi
importance: Undecided → Medium
Erik Meitner (e.meitner) wrote :

I just want to add a note that for my Thinkpad t60(8744-5bu) with the Atheros 5418 chip(PCI ID 168c:0024) I had to download and install the latest madwifi code to have it be recognized and usable. Running Gutsy.

linux-image-2.6.22-7-generic 2.6.22-7.14
linux-restricted-modules-2.6.22-7-generic 2.6.22.2-7.2

Stefano Rivera (stefanor) wrote :

Note that current atheros trunk is experiencing an irritating bug (although it's still better than nothing):
http://madwifi.org/ticket/1017

Tim Gardner (timg-tpi) wrote :

I updated Gutsy l-r-m with madwifi 0.9.3.2.

Changed in linux-restricted-modules-2.6.22:
importance: Medium → Low
status: New → Fix Committed
Don Smith (donsmith77) wrote :

9.3.2 does not include the driver for the new 802.11n chipsets in apple macbooks. Only trunk has this. 9.3.2 is off of a branch. This still forces users to either use ndiswrapper, or overwrite the madwifi driver in order to get basic wireless support.

The bug I mentioned now has patch that seems to help a lot.

Changed in linux-restricted-modules-2.6.22:
status: Fix Committed → Confirmed
Changed in madwifi:
status: Unknown → Fix Released
Stefano Rivera (stefanor) wrote :

Forget that last comment, I think it was just fluke that it helped.

We need to update to trunk, to support this card on amd64 (where ndiswrapper isn't an option)

On a fresh install of Ubuntu 7.10 Tribe 5 I have no wireless. No device detected, etc. Is this planned for this release or is there simply a package needed/missing?

Stefano Rivera (stefanor) wrote :

Christer, what wireless card do you have?

lspci -vvnn

Gutsy Gibbon / Tribe 5. Macbook/Madwifi works after following these instructions:

https://help.ubuntu.com/community/MacBook

Just compile the module (trunk) and install it. No other steps were necessary.

Hi Mikko (2007.09.15_22:17:54_+0200)
> Gutsy Gibbon / Tribe 5. Macbook/Madwifi works after following these
> instructions:
>
> https://help.ubuntu.com/community/MacBook
>
> Just compile the module (trunk) and install it. No other steps were
> necessary.

That's exactly why this bug report exists :-)

It works with trunk.

SR

> Erik Meitner wrote on 2007-07-08: (permalink)
> I just want to add a note that for my Thinkpad t60(8744-5bu) with the Atheros 5418 chip(PCI ID 168c:0024) I had to
> download and install the latest madwifi code to have it be recognized and usable. Running Gutsy.
> linux-image-2.6.22-7-generic 2.6.22-7.14
> linux-restricted-modules-2.6.22-7-generic 2.6.22.2-7.2

I'll add that the Lenovo 3000 V100 notebooks also have this chip. I too had to compile from SVN (with 2.6.22) to get wireless working on it. It would be nice to have this compiled into the Ubuntu kernels so it "just works" for most users.

@Stephano - attached is my lspci -vvnn output. I have the second-gen C2D macbook.

zonemath (zonemath-gmail) wrote :

Samething here ... AR5008 not working on the official 7.10 release.

Tim Gardner (timg-tpi) wrote :

Retarget for Hardy.

Changed in linux-restricted-modules-2.6.22:
milestone: none → hardy-alpha-2
status: Confirmed → In Progress
status: New → Invalid
mabovo (mabovo) wrote :

mabovo@macbook:~$ sudo iwconfig
lo no wireless extensions.

wifi0 no wireless extensions.

ath0 IEEE 802.11g ESSID:"" Nickname:""
          Mode:Managed Frequency:2.427 GHz Access Point: Not-Associated
          Bit Rate:0 kb/s Tx-Power:14 dBm Sensitivity=1/1
          Retry:off RTS thr:off Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=0/70 Signal level=-96 dBm Noise level=-96 dBm
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0

eth0 no wireless extensions.

mabovo (mabovo) wrote :
mabovo (mabovo) wrote :
mabovo (mabovo) wrote :

mabovo@macbook:~$ sudo lshw -C network
  *-network
       description: Ethernet interface
       product: 88E8053 PCI-E Gigabit Ethernet Controller
       vendor: Marvell Technology Group Ltd.
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: eth0
       version: 22
       serial: 00:17:f2:df:89:b5
       size: 100MB/s
       capacity: 1GB/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm vpd msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=sky2 driverversion=1.20 duplex=full firmware=N/A ip=192.168.0.107 latency=0 link=yes module=sky2 multicast=yes port=twisted pair speed=100MB/s
  *-network
       description: Wireless interface
       product: AR5418 802.11a/b/g/n Wireless PCI Express Adapter
       vendor: Atheros Communications, Inc.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wifi0
       version: 01
       serial: 00:1b:63:05:81:11
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list logical ethernet physical wireless
       configuration: broadcast=yes driver=ath_pci latency=0 module=ath_pci multicast=yes wireless=IEEE 802.11g
mabovo@macbook:~$

Changed in linux-restricted-modules-2.6.24:
milestone: hardy-alpha-2 → hardy-alpha-3
Steve Langasek (vorlon) wrote :
Changed in linux-restricted-modules-2.6.24:
milestone: hardy-alpha-3 → none
mabovo (mabovo) wrote :

Temptative to add ath_pci into kernel failed usind madwifi

mabovo (mabovo) wrote :

With the last updates I got the AR5418 (same family of AR5008) working on my network although without any level of security.

mabovo (mabovo) wrote :

Testing Network-manager 0.7 I couldn't connect AR5418 even after reinstalling latest Madwifi driver madwifi-ng-r3318-20080201 in kernel 2.6.24-5-generic.
It detects but not connects WPA or WPA-2 or security disable.

Don Smith (donsmith77) wrote :

ath5k has been added to upstream kernel 2.6.25. A backport of the module might fix the issue.

Hi Don (2008.02.27_22:26:14_+0200)
> ath5k has been added to upstream kernel 2.6.25. A backport of the module
> might fix the issue.

IIRC ath5k doesn't support AR5008. Only madwifi trunk does.

SR

--
+------------------------------------------------------------------+
| Stefano Rivera http://rivera.za.net |
| H: +27 21 794 7937 Don't use Word DOC files: |
| C: +27 72 419 8559 http://en.wikipedia.org/wiki/OpenDocument |
+------------------------------------------------------------------+
Windows 2000, Users Zilch.

mabovo (mabovo) wrote :

Hardy A6/2.6.24-12.20 NM-0.6.6 Madwifi svn r3367
  *-network
       description: Wireless interface
       product: AR5418 802.11abgn Wireless PCI Express Adapter
       vendor: Atheros Communications, Inc.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wifi0
       version: 01
       serial:
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list logical ethernet physical wireless
       configuration: broadcast=yes driver=ath_pci ip=192.168.10.101 latency=0 module=ath_pci multicast=yes wireless=IEEE 802.11g

Neil J. Patel (njpatel) wrote :

Hardy 2.6.24-12 NM-0.6.6 Madwifi svn r3367

Same problem with the madwifi drivers, they can see the networks, but cannot connect to any of them (they all have WEP or WPA enabled). I haven't been able to test with a network without security.

njp@Neils-MBP:~$ sudo iwconfig
wifi0 no wireless extensions.

ath0 IEEE 802.11g ESSID:"" Nickname:""
          Mode:Managed Frequency:2.437 GHz Access Point: Not-Associated
          Bit Rate:0 kb/s Tx-Power:14 dBm Sensitivity=1/1
          Retry:off RTS thr:off Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=0/70 Signal level=-96 dBm Noise level=-96 dBm
          Rx invalid nwid:2920 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0

====

njp@Neils-MBP:~$ sudo lshw -C network
  *-network
       description: Wireless interface
       product: AR5418 802.11abgn Wireless PCI Express Adapter
       vendor: Atheros Communications, Inc.
       physical id: 0
       bus info: pci@0000:0b:00.0
       logical name: wifi0
       version: 01
       serial: 00:1b:63:cb:69:99
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list logical ethernet physical wireless
       configuration: broadcast=yes driver=ath_pci latency=0 module=ath_pci multicast=yes wireless=IEEE 802.11g
  *-network
       description: Ethernet interface
       product: Marvell Yukon 88E8058 PCI-E Gigabit Ethernet Controller
       vendor: Marvell Technology Group Ltd.
       physical id: 0
       bus info: pci@0000:0c:00.0
       logical name: eth0
       version: 13
       serial: 00:1b:63:95:df:f8
       size: 100MB/s
       capacity: 1GB/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm vpd msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=sky2 driverversion=1.20 duplex=full firmware=N/A latency=0 link=yes module=sky2 multicast=yes port=twisted pair speed=100MB/s

Fisslefink (erin-simonds) wrote :
Download full text (8.6 KiB)

Same problem with Macbook Core 2 Duo and Hardy Heron Beta: The module inserts OK, I can see many networks on Network Manager and using "iwlist", and it even gives the appearance of connecting to a router, but I never get an IP. Even connecting to a network without security does not work.

me@ubuntu-bootcamp:~/Linux/madwifi/trunk$ cat svnversion.h
#define SVNVERSION "svn r3407"

me@ubuntu-bootcamp:~/Linux/madwifi/trunk$ lsmod|grep ath
ath_pci 193196 0
ath_rate_sample 16128 1
wlan 252016 4 ath_pci,wlan_scan_sta,ath_rate_sample
ath_hal 233824 3 ath_pci,ath_rate_sample

me@ubuntu-bootcamp:~/Linux/madwifi/trunk$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wifi0 no wireless extensions.

ath0 IEEE 802.11g ESSID:"" Nickname:""
          Mode:Managed Frequency:2.437 GHz Access Point: Not-Associated
          Bit Rate:0 kb/s Tx-Power:14 dBm Sensitivity=1/1
          Retry:off RTS thr:off Fragment thr:off
          Power Management:off
          Link Quality=0/70 Signal level=-96 dBm Noise level=-96 dBm
          Rx invalid nwid:7085 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0

me@ubuntu-bootcamp:~/Linux/madwifi/trunk$ iwlist ath0 scanning
ath0 Scan completed :
          Cell 01 - Address: 00:1C:10:56:25:D0
                    ESSID:"HomeN"
                    Mode:Master
                    Frequency:2.412 GHz (Channel 1)
                    Quality=39/70 Signal level=-56 dBm Noise level=-95 dBm
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
                              12 Mb/s; 48 Mb/s
                    Extra:bcn_int=100
                    Extra:wme_ie=dd180050f2020101000003a4000027a4000042435e0062322f00
          Cell 02 - Address: 00:1D:4F:A8:CA:69
                    ESSID:"Apple Network a8ca69"
                    Mode:Master
                    Frequency:2.412 GHz (Channel 1)
                    Quality=12/70 Signal level=-83 dBm Noise level=-95 dBm
                    Encryption key:off
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    Extra:bcn_int=100
          Cell 03 - Address: 00:12:88:E2:EC:F1
                    ESSID:"2WIRE615"
                    Mode:Master
                    Frequency:2.437 GHz (Channel 6)
                    Quality=13/70 Signal level=-82 dBm Noise level=-95 dBm
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    Extra:bcn_int=100
          Cell 04 - Address: 00:90:4C:7E:00:6E
                    ESSID:"SFGODZILLA"
                    Mode:Master
                    Frequency:2.462 GHz (Channel 11)
                    Quality=31/...

Read more...

Fisslefink (erin-simonds) wrote :

Forgot to post kernel version and lspci:

me@ubuntu-bootcamp:~/Linux/madwifi/trunk$ uname -a
Linux ubuntu-bootcamp 2.6.24-12-generic #1 SMP Wed Mar 12 23:01:54 UTC 2008 i686 GNU/Linux

me@ubuntu-bootcamp:~/Linux/madwifi/trunk$ lspci|grep Ath
0b:00.0 Network controller: Atheros Communications, Inc. AR5418 802.11abgn Wireless PCI Express Adapter (rev 01)

Fisslefink (erin-simonds) wrote :

However, ndiswrapper works fine following these directions:
http://jbopensrc.wordpress.com/2007/12/03/quickfix-ar5418-with-ndiswrapper/

...except that "modprobe ndiswrapper" resulted in the error:
FATAL: Module ndiswrapper not found.

...solution: find the module...
me@ubuntu-bootcamp:~/Linux/ndiswrapper$ locate ndiswrapper
/lib/modules/2.6.24-12-generic/ubuntu/misc/ndiswrapper
/lib/modules/2.6.24-12-generic/ubuntu/misc/ndiswrapper/ndiswrapper.ko

...OK we found the module, now run depmod:
me@ubuntu-bootcamp:~/Linux/ndiswrapper$ sudo depmod /lib/modules/2.6.24-12-generic/ubuntu/misc/ndiswrapper/ndiswrapper.ko

...voila!
me@ubuntu-bootcamp:~/Linux/ndiswrapper$ lsmod|grep ndis
ndiswrapper 192920 0
usbcore 146028 8 ndiswrapper,hci_usb,uvcvideo,appletouch,usbhid,ehci_hcd,uhci_hcd

...and finally...
me@ubuntu-bootcamp:~/Linux/ndiswrapper$ ifconfig
ath0 Link encap:Ethernet HWaddr 00:1c:b3:b3:1b:71
          inet addr:192.168.2.118 Bcast:192.168.2.255 Mask:255.255.255.0
          inet6 addr: fe80::21c:b3ff:feb3:1b71/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:15 errors:0 dropped:0 overruns:0 frame:0
          TX packets:37 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1723 (1.6 KB) TX bytes:5493 (5.3 KB)
          Interrupt:16 Memory:97300000-97310000

Pavel Rojtberg (rojtberg) wrote :

did anyone manage to get the ar5008 working under hardy at all? I tried network manger, but it crashes in most cases if i try to connect...

Tim Gardner (timg-tpi) wrote :

Looks like the madwifi milestone for AR5008 support has changed to 0.9.5 (yet to be released), which means it won't make the Hardy release. Perhaps in a future update post Hardy release.

Changed in linux-restricted-modules-2.6.24:
assignee: timg-tpi → ubuntu-kernel-team
status: In Progress → Triaged
Tim Gardner (timg-tpi) on 2008-04-02
Changed in linux-restricted-modules-2.6.24:
assignee: ubuntu-kernel-team → tjaalton
status: Triaged → In Progress
  • unnamed Edit (1.8 KiB, text/html; charset=ISO-8859-1)

Someone updated the Wireless section of the "Installing Ubuntu on a Macbook
Pro"<https://help.ubuntu.com/community/MacBookPro#head-688700b3e0e48847a28daba8bc557d4439a30927>wiki
to say that the madwifi drivers later than version SVN r3403 do not
work with the Ar5418 chip. This was reported as bug
1852
<http://madwifi.org/ticket/1852>at
madwifi.org and many users have confirmed that r3403 works for this chip,
but not with r3408 and later. In the cases where it did not work, they
could see networks, but not join them.

I suspect the broken SVN version caused the problems I reported on this
Ubuntu bug ticket, as I was using . Just something to keep in mind --
madwifi is still a work in progress, but it can work if you get the right
SVN version.

On Wed, Apr 2, 2008 at 9:44 AM, Tim Gardner <email address hidden>
wrote:

> ** Changed in: linux-restricted-modules-2.6.24 (Ubuntu Hardy)
> Assignee: Ubuntu Kernel Team (ubuntu-kernel-team) => Timo Aaltonen
> (tjaalton)
>
> ** Changed in: linux-restricted-modules-2.6.24 (Ubuntu Hardy)
> Status: Triaged => In Progress
>
> --
> Upgrade Atheros drivers to snapshot/trunk to support AR5008
> https://bugs.launchpad.net/bugs/122703
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Fisslefink (erin-simonds) wrote :
  • unnamed Edit (2.2 KiB, text/html; charset=ISO-8859-1)

sorry, should be "as I was using r3407"

On Wed, Apr 2, 2008 at 4:49 PM, Erin Simonds <email address hidden> wrote:

> Someone updated the Wireless section of the "Installing Ubuntu on a
> Macbook Pro"<https://help.ubuntu.com/community/MacBookPro#head-688700b3e0e48847a28daba8bc557d4439a30927>wiki to say that the madwifi drivers later than version SVN r3403 do not
> work with the Ar5418 chip. This was reported as bug 1852<http://madwifi.org/ticket/1852>at
> madwifi.org and many users have confirmed that r3403 works for this chip,
> but not with r3408 and later. In the cases where it did not work, they
> could see networks, but not join them.
>
> I suspect the broken SVN version caused the problems I reported on this
> Ubuntu bug ticket, as I was using . Just something to keep in mind --
> madwifi is still a work in progress, but it can work if you get the right
> SVN version.
>
>
>
>
> On Wed, Apr 2, 2008 at 9:44 AM, Tim Gardner <email address hidden>
> wrote:
>
> > ** Changed in: linux-restricted-modules-2.6.24 (Ubuntu Hardy)
> > Assignee: Ubuntu Kernel Team (ubuntu-kernel-team) => Timo Aaltonen
> > (tjaalton)
> >
> > ** Changed in: linux-restricted-modules-2.6.24 (Ubuntu Hardy)
> > Status: Triaged => In Progress
> >
> > --
> > Upgrade Atheros drivers to snapshot/trunk to support AR5008
> > https://bugs.launchpad.net/bugs/122703
> > You received this bug notification because you are a direct subscriber
> > of the bug.
> >
>
>

wow, thanks a lot! after installing r3402 my WLAN finally works. (T60)

Changed in linux-restricted-modules-2.6.24:
milestone: none → ubuntu-8.04.1
Pavel Rojtberg (rojtberg) wrote :

fyi - you can use latest trunk again, since the changes that broke everything were reverted.

Steve Langasek (vorlon) on 2008-06-07
Changed in linux-restricted-modules-2.6.24:
milestone: ubuntu-8.04.1 → none
Steve Langasek (vorlon) wrote :

Timo, is this bug still 'in progress'?

I'm dropping the 8.04.1 milestone, which I don't believe to be a realistic goal at this juncture, but an SRU for this issue still looks reasonable to me.

Changed in linux-restricted-modules-2.6.24:
milestone: ubuntu-8.04.1 → none
Alexander Jones (alex-weej) wrote :

Trunk has been working fine for a while, now, for my AR5418 in a MacBook Pro. SRU! :D

description: updated
Timo Aaltonen (tjaalton) wrote :

Steve: "in progress" in upstream, it seems. The bug was assigned to me, but best to reassign it to the kernel team so they can judge whether this is something that could be fixed by a SRU.

Changed in linux-restricted-modules-2.6.24:
assignee: tjaalton → ubuntu-kernel-team
status: In Progress → Confirmed
assignee: tjaalton → nobody
status: In Progress → Confirmed
Tim Gardner (timg-tpi) wrote :

The current release on madwifi.org is still 0.9.4, which is the version in Hardy LRM.

This doesn't matter anymore because of ath5k

-----Original Message-----
From: Tim Gardner <email address hidden>
Sent: Monday, June 30, 2008 4:08 PM
To: <email address hidden>
Subject: [Bug 122703] Re: Upgrade Atheros drivers to snapshot/trunk to support AR5008/AR5418

The current release on madwifi.org is still 0.9.4, which is the version
in Hardy LRM.

--
Upgrade Atheros drivers to snapshot/trunk to support AR5008/AR5418
https://bugs.launchpad.net/bugs/122703
You received this bug notification because you are a direct subscriber
of the bug.

Alexander Jones (alex-weej) wrote :

ath5k doesn't support a lot of chipsets yet due to there not being a free HAL.

Michael Rooney (mrooney) wrote :

Alright, so what is the goal? The 8.04.1 milestone was dropped, what about 8.04.2? The problem is that if it isn't shipped (if it just comes as an update), a lot of users won't get the update because they don't have internet access, and many people might not have access to ethernet.

And is this a non-issue for Intrepid, is this is in the Intrepid kernel, or should this be targeted for 8.10 as well? Thanks!

Alexander Jones (alex-weej) wrote :

No, this still affects 8.10.

The problem is that Madwifi have been reluctant to make a release for
a very long time now. Whilst packaging trunk head may bring support
for MacBook Pro owners, it may also introduce regressions for
otherwise stable Atheros chipsets.

What a pickle.

Zac Brown (rufius) wrote :

You can add Atheros 5212 to this list as well. I have a Lenovo Thinkpad T61 with the 5212 driver and had to compile the drivers from madwifi's latest svn to get my wireless card working.

Michael Rooney (mrooney) on 2008-07-10
description: updated
Michael Rooney (mrooney) wrote :

Thanks Zac, I added it in the description.

Alexander, is there some way we could package current head and make a PPA, and call for testing? It shouldn't be impossible to get enough people to test it that we can see what regressions exist on common cards that already work, and see what new cards are supported. After initial testing and perhaps a few patches, we can put it in +1 and get further testing that way. It wouldn't necessarily be a small undertaking but, is there really a better solution, and might it not be worth it to attempt? I would not be averse to help leading this if it seems a worthy undertaking and others are interested. I don't have a great idea of how many different Atheros versions are supported, and what percentage of the non-functional ones fixed in head represent our users. As in, would this help 5% of Ubuntu users with Atheros, or 25%? Without a good idea of scope I don't know how important this bug is.

Alexander Jones (alex-weej) wrote :

Hm. There may be issues using the PPA service, as the HAL is a uuencoded blob.

ath5k is supposed to be the way forward.

Michael Rooney (mrooney) wrote :

I guess after more thought, I don't understand why we can't just package the madwifi/ath5k trunk and only use it for known-incompatible chipsets with the current package (or further, known compatible chipsets with the trunk package). "Oh, this is a [5008|5212|5418|etc], I'll use the trunk package, it can't be worse!"

This of course assumes 1) it is easy to detect a chipset, 2) it is easy to have package logic based on chipset and 3) it actually can't be worse. Point 3 however can be mitigated by only using it for whitelisted chipsets.

Is something like this possible?

Zac Brown (rufius) wrote :

Mike:

At least on my laptop, lspci reports the chipset version. I think its probably consistent across their line. I think that solution is better than none at all. Its disappointing to install an LTS and not have wireless working on your laptop.

-Zac

Stefano Rivera (stefanor) wrote :

I believe that the existence of ath9k means that old atheros/trunk is no longer needed by anybody? Or is it?

ath9k inclusion request bug #252554

Changed in linux-restricted-modules-2.6.24:
status: Confirmed → Invalid
mabovo (mabovo) wrote :

ath9k needs to be packed in dependency of kernel version. So when Hardy upgrade to 2.6.24-20 there will be need to recompile it to a new debian package. Not a big deal, but I hope it could be inserted in the kernel some way.

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

matthieu (matthieu-baechler) wrote :

ath9k supports AR5008/AR5418 in kernel on ubuntu 9.04.
We no longer needs madwifi upgrade.
I suggest to close this bug.

mabovo (mabovo) wrote :

Agreed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.