Command "launch " interrupted in sub-command:

Bug #1786599 reported by CUBE on 2018-08-11
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
MadDM
Undecided
Unassigned

Bug Description

The following switches determine which programs are run:
/=========================================================================\
| 1. Compute the Relic Density relic = ON |
| 2. Compute direct(ional) detection direct = directional |
| 3. Compute indirect detection/flux indirect = OFF |
| 4. Run Multinest scan nestscan = OFF |
\=========================================================================/
 You can also edit the various input card:
 * Enter the name/number to open the editor
 * Enter a path to a file to replace the card
 * Enter set NAME value to change any parameter to the requested value
 /=============================================================================\
 | 5. Edit the model parameters [param] |
 | 6. Edit the MadDM options [maddm] |
 \=============================================================================/

>
INFO: Start computing relic,direct
maddm_card missed argument print_sigmas. Takes default: False
INFO: compilation done
At line 235 of file direct_detection.f
Fortran runtime error: Index '1' of dimension 1 of array 'dd_eff_process_names' above upper bound of 0
quit
Command "launch " interrupted in sub-command:
"launch" with error:
IOError : [Errno 2] No such file or directory: '/home/ygh/program/MadDM_v3.0.beta/PROC_PLUGIN_InertDoublet_UFO_0/output/run_01/maddm.out'
Please report this bug on https://bugs.launchpad.net/mg5amcnlo
More information is found in 'MG5_debug'.
Please attach this file to your report.

CUBE (1244+) wrote :
Download full text (6.1 KiB)

#************************************************************
#* MadGraph5_aMC@NLO *
#* *
#* * * *
#* * * * * *
#* * * * * 5 * * * * *
#* * * * * *
#* * * *
#* *
#* *
#* VERSION 2.6.2.beta 2018-04-02 *
#* *
#* The MadGraph5_aMC@NLO Development Team - Find us at *
#* https://server06.fynu.ucl.ac.be/projects/madgraph *
#* *
#************************************************************
#* *
#* Command File for MadGraph5_aMC@NLO *
#* *
#* run as ./bin/mg5_aMC filename *
#* *
#************************************************************
set default_unset_couplings 99
set group_subprocesses Auto
set ignore_six_quark_processes False
set loop_optimized_output True
set loop_color_flows False
set gauge unitary
set complex_mass_scheme False
set max_npoint_for_channel 0
import model sm
define p = g u c d s u~ c~ d~ s~
define j = g u c d s u~ c~ d~ s~
define l+ = e+ mu+
define l- = e- mu-
define vl = ve vm vt
define vl~ = ve~ vm~ vt~
install PPPC4DMID
launch
launch
launch
launch
launch dark1
Traceback (most recent call last):
  File "/home/ygh/program/MadDM_v3.0.beta/madgraph/interface/extended_cmd.py", line 1501, in onecmd
    return self.onecmd_orig(line, **opt)
  File "/home/ygh/program/MadDM_v3.0.beta/madgraph/interface/extended_cmd.py", line 1450, in onecmd_orig
    return func(arg, **opt)
  File "/home/ygh/program/MadDM_v3.0.beta/PLUGIN/maddm/maddm_interface.py", line 717, in do_launch
    self._MDM.exec_cmd('launch ' + line.replace(args[1], ''))
  File "/home/ygh/program/MadDM_v3.0.beta/madgraph/interface/extended_cmd.py", line 1528, in exec_cmd
    stop = Cmd.onecmd_orig(current_interface, line, **opt)
  File "/home/ygh/program/MadDM_v3.0.beta/madgraph/interface/extended_cmd.py", line 1450, in onecmd_orig
    return func(arg, **opt)
  File "/home/ygh/program/MadDM_v3.0.beta/PLUGIN/maddm/maddm_run_interface.py", line 838, in do_launch
    self.save_remove_output(scan = True) ## this is to remove or save spectra, not the scan summary file!
  File "/home/ygh/program/MadDM_v3.0.beta/PLUGIN/maddm/maddm_run_interface.py", line 1837, in save_remove_output
    shutil.rmtree(out_dir)
  File "/usr/lib/python2.7/shutil.py", line 239, in rmtree
    onerror(os.listdir, path, sys.exc_info())
  File "/usr/lib/python2.7/shutil.py", line 237, in rmtree
    names = os.listdir(path)
OSError: [Errno 2] No such file or directory: '/home/ygh/program/MadDM_v3....

Read more...

CUBE (1244+) wrote :
Download full text (90.7 KiB)

ygh@ygh:~/program/MG5_aMC_v3_0_0$ ./bin/maddm.py
Plugin PLUGIN.maddm has marked as NOT being validated with this version.
It has been validated for the last time with version: 2.6.3
            ====================================================
            | MadDM v3.0 |
            ====================================================

                #########
             ###\\####//##### Launchpad: launchpad.net/maddm
           ######\\##//########
          ########\\//###########
         #########//\\############ arXiv:1308.4955
        #########//##\\############ arXiv:1505.04190
       ########//#####\\########### arXiv:1804.00444
       ######################### ## ___________________________________________
       ####################### 0 # _ _ _ _____ _ _
       ############# 0 ### ## | \ / | ___ ___|| | ___ \ | \ / |
       ############## ######### ||\\ //|| / __ | / __ | || || ||\\ //||
        ########################## || V || ||__|| ||__|| ||___|| || V ||
         ################### ## || || \_____\ \____| |_____/ || ||
          ############ ### ___________________________________________
           ########## ######
             ################
                 ########

            Need to learn? -> type tutorial

            ====================================================
            | A MadGraph5_aMC@NLO plugin. |
            ====================================================
* VERSION 3.0.0 2018-05-01 *

load MG5 configuration from input/mg5_configuration.txt
set ninja to /home/ygh/program/MG5_aMC_v3_0_0/HEPTools/lib
set collier to /home/ygh/program/MG5_aMC_v3_0_0/HEPTools/lib
None does not seem to correspond to a valid fastjet-config executable (v3+). We will use fjcore instead.
 Please set the 'fastjet'variable to the full (absolute) /PATH/TO/fastjet-config (including fastjet-config).
 MG5_aMC> set fastjet /PATH/TO/fastjet-config

/home/ygh/program/MG5_aMC_v3_0_0/HEPTools/lhapdf5/bin/lhapdf-config does not seem to correspond to a valid lhapdf-config executable.
Please set the 'lhapdf' variable to the (absolute) /PATH/TO/lhapdf-config (including lhapdf-config).
Note that you can still compile and run aMC@NLO with the built-in PDFs
 MG5_aMC> set lhapdf /PATH/TO/lhapdf-config

Using default text editor "vi". Set another one in ./input/mg5_configuration.txt
Using def...

affects: mg5amcnlo → maddm

Hi,

Sorry I only realize this bug report now.
Which model are you using?
Such that I can try to reproduce such issue.

Cheers,

Olivier

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers