[Jaunty] No sound output by default with MacBook 5.1

Reported by Chris Lasher on 2009-03-04
54
This bug affects 6 people
Affects Status Importance Assigned to Milestone
ALSA driver
New
Undecided
Unassigned
Mactel Support
Medium
Unassigned
linux (Ubuntu)
Undecided
Unassigned

Bug Description

There is no sound output for MacBook 5.1 for Jaunty (Ubuntu 9.04) as of Alpha 5 unless "options snd_hda_intel model=mbp3" is added manually to /etc/modprobe.d/options. Adding this should not be required.

Chris Lasher (chris.lasher) wrote :
Chris Lasher (chris.lasher) wrote :
Changed in mactel-support:
importance: Undecided → High
Ricky Campbell (cyberdork33) wrote :

Chris can you check if this bug represents your problem? If so, this should be marked as a duplicate.
https://bugs.edge.launchpad.net/ubuntu/+source/alsa-driver/+bug/337314

Either way, providing the data provided by running the script:
http://www.alsa-project.org/alsa-info.sh
Will be helpful for this bug.

Chris Lasher (chris.lasher) wrote :

It might, but I get no sound at all--not out of the speakers, nor out of the headphone jack. It's interesting because the users in that thread who got sound working got the ALSA libs from Jaunty, which is what I'm running (Alpha 5). There's been mention in the forum threads about needing to set the channels from 2 channel to 6 channel, but I have not found where that setting is located (pointers on the wiki page and forum don't work for me--I don't see the option in gnome-volume-control or in alsamixer).

I ran the alsa.sh script and my results are here:
http://www.alsa-project.org/db/?f=698959d0acde505730bbadfdd70e68ee87967808

Chris Lasher (chris.lasher) wrote :

Can I provide any more information to help?

Nuno Brito (mail-nunobrito) wrote :

I confirm that sound is working on my MacBook 5,1 with a fresh install Ubuntu 9.04 Jaunty beta - I used the same intructions found for Ubuntu 8.10

https://help.ubuntu.com/community/MacBook5-1/Intrepid#Sound

:)

Alex Murray (alexmurray) wrote :

@Chris - Right click on the volume icon on your gnome panel and open the volume control dialog. Make sure the device is selected as NVIDIA HDA something (sorry I'm writing this from memory at work). Then click the Preferences button and enable the checkbox labelled 'Source' or 'Channel Options' or 'Channel Source' (sorry again I can't really remember what the option is called). This should then provide an option back in the volume control dialog to select either 2 or 6 channel. Also make sure you enable 'Line Out' and set the line out volume (since this controls the volume of the speakers). You should then get sound out of atleast the right speaker - the left one doesn't appear to work - see bug https://bugs.edge.launchpad.net/ubuntu/+source/alsa-driver/+bug/337314

Chris Lasher (chris.lasher) wrote :

@Alex I'm afraid I do not have that option, still. Here's what I have done up to this point:

1) In /etc/modules, I placed the following line, then rebooted:
options snd_hda_intel model=mbp3

2) Right-clicked the volume icon on GNOME panel.

3) Went to Open Volume Control.

4) Ensured that HDA NVidia (Alsa mixer) was selected as "Device"

5) Clicked the Preferences Button.

6) The following appeared with checkboxes beside them. I will place a [ ] for an empty (unchecked) check box, and a [x] for a checked one:

[x] Master
[x] Headphone
[x] PCM
[x] Front
[x] Surround
[x] Microphone
[ ] Mic Boost
[ ] Capture
[ ] Capture 1
[ ] IEC958
[ ] IEC958 Capture
[ ] IEC958 Default PCM
[ ] Input Source
[ ] Input Source

7) Checked the first "Input Source". A new tab in the Volume Control window appeared called "Options"

8) Went to "Options" tab. The only thing that appears is "Input Source" from which I can select "Mic" only.

9) Checked the other "Input Source", same result, now with an additional "Input Source" and "Mic" combo in the "Options" tab.

10) Gave up again and posted to here.

Further suggestions more than welcome.

Chris

Chris Lasher (chris.lasher) wrote :

Am I the only one who does NOT have the 2 channel/6 channel option available on a MacBook 5.1? Do I have different sound hardware? (View my lspci attachment above and compare.)

Jim Rorie (jfrorie) wrote :

Chris,

The line:

options snd_hda_intel model=mbp3

goes in the file /etc/modprobe.d/options, NOT /etc/modules. Move the entry and the channel option should appear under preferences. Then follow the rest of the procedure.

Richard Elkins (texadactyl) wrote :

I can confirm Nuno Brito's comment about a Mactel work-around on an iMac circa October 2007:

 - gksudo gedit /etc/modprobe.d/options
 - Add at the end of the file: options snd_hda_intel model=mbp3
        - sudo reboot

I called it a work-around because it seems to me that Ubuntu should auto-detect the need for special handling of snd_hda_intel. However, it is nice to have audio back.

Jim Rorie (jfrorie) wrote :

The workaround gives partial audio. The right speaker is the only one working, which makes music a little dodgy. I upgraded to Alsa x.19 and this did not solve the issue, so it lies elsewhere.

Ricky Campbell (cyberdork33) wrote :

Richard,

your model might work (as well or better) with "imac24" as well.
Also, please try to find the version string of your Mac. See:
https://wiki.ubuntu.com/MactelSupportTeam/CommunityHelpPages#Determine%20your%20model%20and%20hardware%20revision
This will help make sure we are know what hardware you are talking about.

Chris Lasher (chris.lasher) wrote :

Thanks, Jim. Indeed, I placed that line in the wrong file. After correctly placing the line in /etc/modprobe.d/options, I now have audio in the headphones and the right speaker. No audio is played from the left speaker, but this is described in Bug #337314.

description: updated
tags: added: alsa mactel sound
summary: - [Jaunty] No sound output with MacBook 5.1
+ [Jaunty] No sound output by default with MacBook 5.1
Changed in mactel-support:
importance: High → Medium
status: New → Confirmed
Yura Tolstik (yltsrc) wrote :
P. Dunbar (vigilcode) wrote :

the patch posted in this bug https://bugs.edge.launchpad.net/ubuntu/+source/alsa-driver/+bug/337314
resolves the issue listed here:

"There is no sound output for MacBook 5.1 for Jaunty (Ubuntu 9.04) as of Alpha 5 unless "options snd_hda_intel model=mbp3" is added manually to /etc/modprobe.d/options. Adding this should not be required."

With the patch sound is working without any additional options in the option file on mbp5,1 and 5,2

Josh Kupershmidt (schmiddy) wrote :

I have a very recent MacBook Pro 13". The command 'sudo dmidecode -s system-product-name' gives me 'MacBookPro5,5'. I've attached the output of 'lspci'. Neither speakers nor headphone output worked for me with the default Jaunty install.

After adding (actually, creating this file from scratch -- it didn't exist yet) the line "options snd_hda_intel model=mbp3" to /etc/modprobe.d/options and rebooting, I still have no sound in either speakers or headphones.

When I open "Volume Control" by right-clicking the gnome volume slider, I have the soundcard options:

 * HDA Nvidia (Alsa Mixer)
 * Generic 1013 ID 4206 (OSS Mixer)
 * Playback: HDA Nvidia - HDA Generic (PulseAudo Mixer)
 * Capture: Monitor of HDA Nvidia - HDA Generic (PulseAudio Mixer)
 * Capture: HDA Nvidia - HDA Generic (PulseAudio Mixer)

I've tried playing with the first three soundcard options with no luck. When I click on the "Preferences" button for option "HDA Nvidia (Alsa Mixer)" I see a "Volume Control Preferences" box with a "Select tracks to be visible" prompt with the following options:

 [x] | Master | Playback
 [x] | PCM | Playback
 [ ] | Capture | Recording

None of the preferences for any of the soundcard options I see say anything about 2 channels vs. 6 channels. Can anyone help me out?

Maja Djordjevic (ovcica) wrote :

I have the exact same problem as described in the last post by Josh Kupershmidt.
The sounds works with USB headphones, meaning that all the codecs are set up properly.

Jeremy Foshee (jeremyfoshee) wrote :

Hi Chris,

This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/lucid.

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 337947

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kernel-sound
tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Chris Lasher (chris.lasher) wrote :

This bug was resolved in Ubuntu 9.04 Karmic Koala, and can be closed. Thanks for checking.

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers