ath9k performances are unacceptable

Bug #297965 reported by Romuald on 2008-11-14
62
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Unknown
Mactel Support
Medium
Unassigned
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Tested with a Macbook Pro 2G (late 2006, Core 2 Duo + Atheros AR5008) and Intrepid.

I'm the lucky guy with a pretty good internet bandwith, around 10 Mb/s.

With Intrepid, the wifi works "out of the box" thanks to the ath9k driver, unfortunately, the price is poor performances, my connection speed can't get more than 1 Mb/s (instead of 10).

This bug report is not based on the NetworkManager reported speed, but based on some internet ADSL speed test web sites.

The last time I did the test with the following web site : http://www.degrouptest.com/test-debit.php, the reported performances were :
- Hardy + madwifi ng 20080301 -> 7700 kb/s
- Intrepid + ath9k -> 935 kb/s

I made this test with several other web sites at different times, and same result. Anyone can easily understand this is not acceptable.

I also did a real test case : watch the TV through the ADSL connection, with the Hardy configuration, no problem, with Intrepid it is just not possible.

I'm sorry because I won't be able to perform further tests, I need my Internet connection and as I couldn't be able to find a working fix, I downgraded my computer to Hardy...and I'm waiting for some progresses in Jaunty.

But I can answer questions.

Romuald (romu70) on 2008-11-14
description: updated
description: updated
description: updated
Romuald (romu70) wrote :

Just a little comment to warn that I created a bug report in the kernel database, it is here:
http://bugzilla.kernel.org/show_bug.cgi?id=12093

Obviously, some patches are available to fix the problem. So please, include them into the Intrepid Kernel for a kernel update or, at least, for Jaunty.

Thanks.

Changed in linux:
status: Unknown → Fix Released
John Pugh (jpugh) wrote :

Marked incomplete since we need more information and testing on the latest 2.6.27 kernel in intrepid. I cannot reproduce.

Changed in linux:
status: New → Incomplete
Salvador Diaz (salvadordiaz) wrote :

I can give any information and make any tests you might need. Just tell me what you need.

Aaron Kelley (aaronkelley) wrote :

I grabbed and installed the new(ish?) version of the kernel, 2.6.27-11, from intrepid-proposed (along with the related packages). This seems to have improved the situation for me. (Previously, using ath9k, I got terrible performance on a 802.11n network but now I am able to achieve transfers over 1 MB/sec on the LAN.) I will continue testing to see if there are any problems, but even if it is not fixed, it seems for the moment to be improved enough to be usable.

Have you tried with 2.6.27-11?

Aaron Kelley (aaronkelley) wrote :

My machine just crashed (KERNEL PANIC) while running 2.6.27-11, after using the wireless for a few hours. This is the firs time that I have used the wireless for an extended period of time since installing 2.6.27-11. I'm back on 2.6.27-9 for now. I believe this was caused by the updated ath9k module.

This is the same kind of behavior I found when trying to use an updated ath9k kernel module from compat-wireless (http://wireless.kernel.org/en/users/Download). Performance is much better but the driver is unstable, I got kernel panic while using the compat-wireless module as well.

On Mon, Jan 19, 2009 at 08:45:44PM -0000, Aaron Kelley wrote:
> My machine just crashed (KERNEL PANIC) while running 2.6.27-11, after
> using the wireless for a few hours. This is the firs time that I have
> used the wireless for an extended period of time since installing
> 2.6.27-11. I'm back on 2.6.27-9 for now. I believe this was caused by
> the updated ath9k module.

Please file a bug if you haven't already, and link it into this bug.

Romuald (romu70) wrote :

Hi all,
I can confirm this bug is now fixed, I tested this morning with Intrepid, all last updates and ath9k and I reach more than 8 Mb/s on my internet connection.

Well done.

But, the connection is very very unstable, I face frequent deconnection from my wifi. So I'm going to enter a new bug about the ath9k unstability.

Thanks for the efforts.

Salvador Diaz (salvadordiaz) wrote :

I tested my wireless connection yesterday with all the latest patches in Intrepid and I can confirm that there's a performance improvement. I cannot confirm the 8Mbps figure though, as the "Connection information" dialog (right click on NetworkManager tray icon > "Connection information") still displays a 1Mbps connection speed.

Would you care to elaborate on the method you used to get the 8Mbps figure Romuald ?

Cheers

Aaron Kelley (aaronkelley) wrote :

It's been noted by the people who wrote this driver that 1 Mbps will always be reported as the connection speed... it is not necessarily accurate. The driver does not properly report the connection speed. You'll have to actually do some transfers and watch the speed to get a measure of how fast your link is.

Salvador Diaz (salvadordiaz) wrote :

Ok, so I made a couple of bandwidth tests both on Intrepid and Leopard and I'm happy to report that the performance of the linux driver is only slightly inferior to that of the mac driver (4.9Mbps vs 5.2Mbps).

I didn't notice any of the stability problems noted by others though, but I didn't conduct any extensive testing. I'll be happy to report back any other findings. In the meanwhile, is this bug going to be closed or do you need any other information?

Changed in mactel-support:
importance: Undecided → Medium
status: New → In Progress
Eric Pasch (epasch) wrote :

I am also having speed issues with ath9k. using NDISWrapper with the windows drivers I can pull my full internet speed according to multiple test sites (20Mbps). When I switch over the ath9k I can only pull about 10Mbps. If I restrict my router to the 5Ghz Wireless-N only with wide channels enabled, I can pull 15Mbps. In any case, I should pass an internet speed test with around 20Mbps just like I do using NDISWrapper. I am running Intrepid Kernel 2.6.27-11 with an Atheros 5008 card. Unfortunately I don't have much else to report besides the lack of performance I have seen. In any case, I think the driver is coming along and I look forward to seeing it's full potential.

Ricky Campbell (cyberdork33) wrote :

Eric, one thing to consider is that, I think when using ndiswrapper, your card is only capable of 802.11g connections while the ath9k driver is capable of 802.11n connections. (which may be where the issue is). Can you try restricting the router to g connections?

Kent deVillafranca (kdevilla) wrote :

Ricky, are you sure? I seem to be getting 802.11n speeds when using ndiswrapper (it reports the speed as 130 Mb/s, and transfers are faster than what I usually see from 802.11g).

Maybe it has been updated since I last tried. Hence the "I think"

Ricky

On Mar 2, 2009, at 1:02 PM, Kent deVillafranca <email address hidden> wrote:

> Ricky, are you sure? I seem to be getting 802.11n speeds when using
> ndiswrapper (it reports the speed as 130 Mb/s, and transfers are
> faster
> than what I usually see from 802.11g).
>
> --
> ath9k performances are unacceptable
> https://bugs.launchpad.net/bugs/297965
> You received this bug notification because you are a member of Mactel
> Support, which is the registrant for Mactel Support.
>
> Status in The Linux Kernel: Fix Released
> Status in Mactel Support: In Progress
> Status in “linux” source package in Ubuntu: Incomplete
>
> Bug description:
> Tested with a Macbook Pro 2G (late 2006, Core 2 Duo + Atheros
> AR5008) and Intrepid.
>
> I'm the lucky guy with a pretty good internet bandwith, around 10 Mb/
> s.
>
> With Intrepid, the wifi works "out of the box" thanks to the ath9k
> driver, unfortunately, the price is poor performances, my connection
> speed can't get more than 1 Mb/s (instead of 10).
>
> This bug report is not based on the NetworkManager reported speed,
> but based on some internet ADSL speed test web sites.
>
> The last time I did the test with the following web site : http://www.degrouptest.com/test-debit.php
> , the reported performances were :
> - Hardy + madwifi ng 20080301 -> 7700 kb/s
> - Intrepid + ath9k -> 935 kb/s
>
> I made this test with several other web sites at different times,
> and same result. Anyone can easily understand this is not acceptable.
>
> I also did a real test case : watch the TV through the ADSL
> connection, with the Hardy configuration, no problem, with Intrepid
> it is just not possible.
>
> I'm sorry because I won't be able to perform further tests, I need
> my Internet connection and as I couldn't be able to find a working
> fix, I downgraded my computer to Hardy...and I'm waiting for some
> progresses in Jaunty.
>
> But I can answer questions.
>
> _______________________________________________
> Mailing list: https://launchpad.net/~mactel-support
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~mactel-support
> More help : https://help.launchpad.net/ListHelp

Eric Pasch (epasch) wrote :

I just reinstalled NDISWrapper and sure enough, according to my router, I am connected at 130Mbps. I also went ahead and did the Internet speed test as well. Once again I got 20mbps down and 5mbps up. I still rather not use windows drivers on my linux computer haha Aside from the slight speed issues with ath9k, I love it. Frankly 15mbps is plenty fast to cruise the net so I'll be good until the driver is refined.

Romuald (romu70) wrote :

Hi just a little comment,
I self compiled the compat-wireless package with the date February, 26, 2009. And I think the speed is definitely not more an issue. Great work.

JeffThurston (jthurston) wrote :

Hi everyone, I too am having problems with ath9k stability as well as possibly speed.
I have tried testing this with 2.6.27-11 & 2.6.27-13 as well as the latest compat-wireless source for March 8th 2009 with my Atheros 5008 chipset (it's a Sparklan mPCIe card).

After about 10-15 seconds transfering a 1GB file, the connection stalls. Prior to that the transfer rate is stated at around 8-9MB/s.

If anyone one would more detailed information about my system and configuration just let me know.
Other than that I guess this is just a "me too" comment. Speed seems fixed, but stability is not, nm-applet of course reports either unknown or 1mb/s.

My system is a Dell Latitude D531 AMD x2 1.9GHz, I'm running the 32bit version of intrepid.

Haven't tried ndiswrapper yet, seems like a good workaround to get this card at least going for now.

JeffThurston (jthurston) wrote :

I also tried using just wpa (tkip) which resulted in the same disconnection under heavy network load.
Haven't tried wep or open. I mention this because I've seen alot of people say that this solves their problems.

Didn't do anything for me.

BarrettWilliams (barwi) wrote :

I have the same problem with a Lenovo-branded AR5008 that I installed in my Toshiba Tecra M7. I have heard about compatibility issues between this chipset and the Intel 945 or 965 chipsets, I can't remember. However, I get good reliability in Windows and Mac; it's just Linux and the ath9k driver that proves problematic. I think madwifi was better in terms of reliability.

Romuald (romu70) wrote :

Dear Jeff and Barrett,
The ath9k performance problem has been fixed in the latest Intrepid updates. Now the problem comes from stability, please check out the related bug : https://bugs.launchpad.net/bugs/333730

We need to change its state from "incomplete" to "confirmed".

Thanks.

Krzysztof Janowicz (janowicz) wrote :

maybe this also related to my bug report https://bugs.launchpad.net/ubuntu/+source/linux/+bug/362985 about jaunty? how to find out which version of ath9k is used?

Romuald (romu70) wrote :

I reopened this bug report because the problem is same on Jaunty, please have a look at the bug report on the kernel.

Changed in linux (Ubuntu):
status: Incomplete → New
Changed in linux:
status: Fix Released → Confirmed
Romuald (romu70) wrote :

My mistake, my apologizes, this is obviously wrong.

Changed in linux (Ubuntu):
status: New → Fix Released
Changed in linux:
status: Confirmed → Fix Released
Giancaldo (giancaldo) wrote :

I have the same problem with the ar5008. It manages to connect fine, but it only works for the first 5 or 10 seconds or so. If I place the laptop right beside the router the signal is still something like only 60% but it works slightly better, but still unusable.

Giancaldo (giancaldo) wrote :

using the git wireless drivers seems to have helped. However it's still very flaky. It will work fine for 2 or 3 minutes, then it will all of a sudden stop working for maybe a minute or so. It will remain connected, but there will be no throughput.

Massimo Mund (qos) wrote :

Giancaldo, i guess this is another problem. Take a look on my comment here:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/333730/comments/32

John Pugh (jpugh) on 2013-07-19
Changed in mactel-support:
status: In Progress → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.