reverse-proxy service is not displayed for region controller

Bug #1982984 reported by Anton Troyanov
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
Fix Committed
High
Anton Troyanov
3.2
Fix Released
High
Anton Troyanov
maas-ui
New
Unknown

Bug Description

If MAAS is deployed only with the region controller role, `reverse-proxy` service is missing in the services list.

It says 6 is running (and the 6th one is a reverse-proxy which is not displayed)

```
Services

 6 running

 regiond
 bind9
 ntp
 proxy
 syslog
```

The issue is this condition:
```
(node.node_type == 2 || node.node_type == 4) && services.reverse_proxy
```

We want it to be shown if node_type is 3 or 4
```
RACK_CONTROLLER = 2
REGION_CONTROLLER = 3
REGION_AND_RACK_CONTROLLER = 4
```

maas/src/maasserver/models/service.py
```
REGION_SERVICES = frozenset(
    {
        "bind9",
        "ntp_region",
        "proxy",
        "regiond",
        "reverse_proxy",
        "syslog_region",
    }
)
```

Tags: ui
Changed in maas:
importance: Undecided → High
Changed in maas-ui:
importance: Undecided → Unknown
Changed in maas:
assignee: nobody → Anton Troyanov (troyanov)
status: Triaged → In Progress
Changed in maas:
status: In Progress → Fix Committed
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.