volume group creation fails on md device - MAAS 3.2

Bug #1981536 reported by Lirim
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
Fix Committed
High
Anton Troyanov
3.2
Fix Released
High
Anton Troyanov

Bug Description

With Maas 3.2 (snap) creating a volume group on top of previously configured RAID device (0 or 1) is failing with:

errorlist Select a valide choice.722 is not one of the available choices.

Step to reproduce:

On Maas dashboard:
- Commission a machine with 3 disks
- Under Storage, create a RAID 0 or 1 from two of the disks
- Try creating a volume group on top of newly created md0 device

However creating a volume group directly on the disks works. Also with Maas 3.1 both methods seem to work.

Related branches

Revision history for this message
Lirim (lirim-osmani) wrote :
Lirim (lirim-osmani)
description: updated
Alberto Donato (ack)
Changed in maas:
milestone: none → 3.3.0
importance: Undecided → High
status: New → Triaged
Revision history for this message
Alberto Donato (ack) wrote :

This seems related to the fix for LP:1938296, which creates a partition table on the raid device when a raid is created.

This makes the raid device unavailable for creating a volume group on.

Revision history for this message
Jerzy Husakowski (jhusakowski) wrote :

After some discussions, the best way forward seems to be to revert the fix for LP:1938296. We will also take this particular issue onto our backlog, as the proper fix may affect the UI and API in non-trivial ways.

Changed in maas:
assignee: nobody → Anton Troyanov (troyanov)
status: Triaged → In Progress
Changed in maas:
status: In Progress → Fix Committed
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers