MAAS CLI with anonymous access fails when TLS is enabled

Bug #1980436 reported by Anton Troyanov
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
MAAS
Fix Committed
High
Anton Troyanov
3.2
Fix Released
High
Anton Troyanov

Bug Description

maas login foo https://maas-lab:5443/MAAS/ --cacerts ~/cacerts.pem
maas login foo https://maas-lab:5443/MAAS/ -k

Fails with an error:

requests.exceptions.SSLError: HTTPSConnectionPool(host='10.0.1.21', port=5443): Max retries exceeded with url: /MAAS/api/2.0/account/?op=create_authorisation_token (Caused by SSLError(SSLError("bad handshake: Error([('SSL routines', 'tls_process_server_certificate', 'certificate verify failed')])")))

Related branches

Revision history for this message
Anton Troyanov (troyanov) wrote :

Until this fix is released: workaround is to add CA into trusted root

description: updated
Changed in maas:
importance: Undecided → Critical
importance: Critical → High
milestone: none → 3.3.0
Changed in maas:
status: In Progress → Fix Committed
summary: - MAAC CLI with anonymous access fails when TLS is enabled
+ MAAS CLI with anonymous access fails when TLS is enabled
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers