When deploying a machine as LXD host, a version higher than 4.0 should be installed

Bug #1941050 reported by Alberto Donato
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
Fix Released
High
Alberto Donato
3.0
Fix Committed
High
Alberto Donato

Bug Description

MAAS currently installs LXD 4.0 when deploying a machine as a LXD host.

That version doesn't support the `custom_block_volumes` extension (https://github.com/lxc/lxd/blob/master/doc/api-extensions.md#custom_block_volumes) which is needed to be able to compose VMs with more than one disk.

Related branches

Alberto Donato (ack)
Changed in maas:
status: Triaged → In Progress
Changed in maas:
status: In Progress → Fix Committed
Bill Wear (billwear)
Changed in maas:
milestone: next → 3.1.0-beta1
Bill Wear (billwear)
Changed in maas:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers