Unable to network boot VM on IBM Z DPM Partition

Bug #1919001 reported by Lee Trager
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
Fix Released
High
Unassigned
Ubuntu on IBM z Systems
Fix Released
Undecided
Unassigned

Bug Description

I used MAAS to deploy a Ubuntu 20.04 with a KVM host. Currently MAAS uses libvirt when deploying a KVM host. While I was able to compose a VM the VM never boots over the network. If I watch the VM console it tries 10 times to receive a DHCP response but never gets one.

Tags: s390x maas
Frank Heimes (fheimes)
tags: added: maas s390x
Revision history for this message
Lee Trager (ltrager) wrote :

I looked at some packet dumps while trying to debug this. It looks like the request is going out and MAAS is receiving it. For whatever reason the VM isn't receiving the response.

Revision history for this message
Lee Trager (ltrager) wrote :
Revision history for this message
Lee Trager (ltrager) wrote :
Changed in maas:
milestone: 3.0-beta1 → 3.0-beta2
Revision history for this message
Lee Trager (ltrager) wrote :

After speaking with fheimes and xnox it seems the issue is that on IBM Z the device a bridge is associated with must be put into promiscuous mode. This can be done in the CEC in the HMC, with the chzdev command, or possibly with the ip command. The issue is that on IBM Z DPM partitions Hypersockets share an underlying physical network device. Only one Hypersocket can be set into promiscuous mode at a time. If two partitions both need to run KVM hosts each Hypersocket must be connected to a different physical interface.

This isn't something we can handle on the Ubuntu/MAAS side so for now we will add documentation about what an administrator needs to do in the HMC.

Frank Heimes (fheimes)
Changed in ubuntu-z-systems:
status: New → Triaged
Changed in maas:
milestone: 3.0-beta2 → 3.0-beta3
Changed in maas:
milestone: 3.0.0-beta3 → 3.0.0-beta4
Changed in maas:
milestone: 3.0.0-beta4 → 3.0.0-beta5
Changed in maas:
milestone: 3.0.0-beta5 → 3.0.0-rc1
Changed in maas:
milestone: 3.0.0-rc1 → 3.0.1
Revision history for this message
Lee Trager (ltrager) wrote :

This was fixed in 99513c7e42ebc0c54cb93c057eb891802d3540f1

Changed in maas:
status: Triaged → Fix Committed
milestone: 3.0.1 → 3.0.0-rc1
Frank Heimes (fheimes)
Changed in ubuntu-z-systems:
status: Triaged → Fix Committed
Changed in maas:
status: Fix Committed → Fix Released
Revision history for this message
Julian Wiedmann (jwiedmann) wrote :

(drive-by comment)

Hey @fheimes! If the issue here is that you need multiple HiperSockets devices on the same network in ~promiscuous mode, then maybe give the VNICC features a try. When you piece together all the *_flooding options, that should give you the same RX promiscuity as with the old 'bridgeport' feature.

Revision history for this message
Frank Heimes (fheimes) wrote :

Hi Julian, sorry, this LP bug was not updated with the latest details.

We indeed moved from promiscuous mode to VNICC characteristics "learning" which solved the situation for us.
And VNICC "learning" is now automatically enabled on the based device that is used for the bridge (bridge port) by MAAS (in case of a KVM host installation).
That not only helped to make sure that the traffic is able to find it's way back through the bridge, in case of PXE booting a KVM guest, it also helps to overcome the promiscuous mode limitations (only one interface can be in that mode at a certain time).

We tested that properly at a z14 GA2 system where we developed and ported MAAS for DPM/LPARs.

So this is actually closed as Fixed Released.

Changed in ubuntu-z-systems:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers