2.9 UI is broken, seems to loop between user intro and machines pages endlessly

Bug #1915087 reported by Jeff Lane 
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
MAAS
Fix Released
High
Caleb Ellis
2.9
Fix Released
Undecided
Caleb Ellis
maas-ui
Fix Released
Unknown

Bug Description

We just did a fresh MAAS install of 2.9 from the snap in a LXD container for the cert lab. I logged in using our default user account and created a personal account for myself. I then logged in using my personal account. The first thing that I should see is the intro stuff, and what I actually got was a lot of pain.
On log in, I got the machines list with no tabs to navigate. At the top the only options were "skip", my user account, and "Log out".

Skip doesn't seem to do anything at, clicking it does nothing. I clicked my user account and tried pulling in my ssh keys from launchpad. This resulted in an endless cycle of going between a blank page for l/user/intro and a populated page for /machines/ until I finally clicked my account again, returning me.

I created two user accounts, and both displayed exactly the same behaviour.

maas 2.9.1-9153-g.66318f531 11322 2.9/stable canonical✓ -
maas-cli 0.6.5 13 latest/stable canonical✓ -

See the attached video that demonstrates the issue.

also note, this is a snap. So obviously any sort of modifications and debugging is nigh impossible. And we cannot just delete the snap and start over, this is a production machine, unfortunately. So we'd like to work to resolve this in 2.9.1.

Tags: ui
Revision history for this message
Jeff Lane  (bladernr) wrote :
Revision history for this message
Rod Smith (rodsmith) wrote :

I ran into this, too, but was able to overcome it by stopping the page loading and then going back to the base URL (e.g., http://{machineip}:5240/MAAS/). I was using Google Chrome (not Chromium) on Ubuntu 20.04.

tags: added: ui
Changed in maas-ui:
importance: Undecided → Unknown
Changed in maas:
status: New → In Progress
importance: Undecided → High
assignee: nobody → Caleb Ellis (caleb-ellis)
milestone: none → 2.9.x
Changed in maas:
milestone: 2.9.x → 2.10-beta1
Changed in maas-ui:
status: New → Fix Released
summary: - 2.9 UI is broken, seems to loop between user intro and machiens pages
+ 2.9 UI is broken, seems to loop between user intro and machines pages
endlessly
Changed in maas:
milestone: 3.0-beta1 → 3.0-beta2
Changed in maas:
milestone: 3.0-beta2 → 3.0-beta3
Changed in maas:
milestone: 3.0.0-beta3 → 3.0.0-beta4
Huw Wilkins (huwshimi)
Changed in maas:
status: In Progress → Fix Committed
Changed in maas:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.