Can't delete LXD VM in offline state

Bug #1908434 reported by Andrey Grebennikov
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
Fix Released
High
Adam Collard
2.9
Fix Released
High
Unassigned

Bug Description

MAAS 2.9, the host is registered as KVM pod via LXD.
Compose VM on the pod, VM in the "ready" state and offline.

When trying to delete it getting error "Unable to decompose machine because: Failed talking to pod: The instance is already stopped"
This is not an issue with libvirt-based pod.

Expected behaviour - MAAS should be able to remove the machine from the console, as well as undefine it at the LXD level.

Related branches

Changed in maas:
status: New → Triaged
status: Triaged → In Progress
importance: Undecided → High
assignee: nobody → Adam Collard (adam-collard)
milestone: none → 2.10-next
summary: - [lxd pod] can't delete VM in offline state
+ Can't delete LXD VM in offline state
Changed in maas:
status: In Progress → Fix Committed
Changed in maas:
milestone: 3.0.0 → 3.0-beta1
Changed in maas:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers