Impossible to delete zombie LXD VM

Bug #1887797 reported by Adam Collard
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
Fix Released
Medium
Alberto Donato
2.9
Fix Committed
Medium
Alberto Donato

Bug Description

Given a VM in MAAS associated with a LXD host, when the LXD API endpoint goes away it becomes impossible[1] to remove the machine.

Steps to reproduce
1. Setup LXD
2. Add a LXD VM Host to MAAS pointing at the LXD you setup in 1.
3. Compose a machine
4. Uninstall LXD on the host you setup in 1.
5. Delete the machine you created in 3.

MAAS will fail to connect to the LXD API (because, surprise surprise, it's not there!), and leave you stuck with zombie machines.

MAAS version: 2.9.0~alpha1 (8723-g.01084b142)

[1] https://paste.ubuntu.com/p/WzPGhN6pPT/ for the adventurous/desperate

Related branches

Revision history for this message
Bill Wear (billwear) wrote :

as of MAAS 2.9.0, attempting to fix this by refreshing the KVM cause the entire server to fail with:

Error:The server connection failed with the error "Cannot read property 'id' of undefined".

A browser refresh reconnects, but the KVM has not refreshed and the zombie VMs are still in play.

Alberto Donato (ack)
Changed in maas:
status: New → In Progress
milestone: none → 2.10-beta1
Alberto Donato (ack)
Changed in maas:
milestone: 2.10-beta1 → 2.10.0
Alberto Donato (ack)
Changed in maas:
importance: Undecided → Medium
assignee: nobody → Alberto Donato (ack)
Changed in maas:
status: In Progress → Fix Committed
Changed in maas:
milestone: 3.0.0 → 3.0-beta1
Changed in maas:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers