Cannot edit physical interface in gui

Bug #1864241 reported by Adam Nave on 2020-02-21
62
This bug affects 13 people
Affects Status Importance Assigned to Milestone
MAAS
High
Caleb Ellis
2.7
Undecided
Unassigned
maas-ui
Fix Released
Unknown

Bug Description

I have a new maas server and newly added machine. I was attempting to modify the physical network interfaces and set them to static IPs via the gui, but I could not change any part of the devices. In the gui I received the error "tags: Item 0 in the array did not validate: This field cannot be null." This is the case when the machine is in the NEW or READY or ALLOCATED states.

I have tried deleting the machine and adding it again via PXE, and the result is the same for both interfaces. I can add an additional vlan interface successfully or disconnect/reconnect the interface, but changes to the physical interface config such as adding tags, changing the IP mode or even making no changes and just hitting save result in the exact same error every time.

Using the cli, I was eventually able to set the ip mode to DHCP using this command. I did have to use force=True, otherwise it just added a new eth1.1 alias with the config.
sudo maas admin interface link-subnet td8t43 eth1 mode=DHCP subnet="10.XX.XX.0/17" force=True

Steps to reproduce:
1. Add new machine via pxe
2. while it is in the NEW state, attempt to update the net config in the gui to use a static or dhcp IP and save.
3. Note the error.
4. Commission the machine
5. Again, attempt to update the net config. Note the error.

Expected behavior:
I should be able to change the network settings of the physical device using the gui.

I don't know if this is related, but I have specificed kernel parameters "net.ifnames=0 biosdevname=0" in order to use old style network names. I also have a fabric with an untagged vlan for the private network and a vlan for the public. I have also previously worked with this machine using maas 2.3 and the same network, and did not have any similar issues.

I'm using a snap install.
maas 2.7.0-8233-g.a7907fcc4 4940 2.7 canonical
maas-cli 0.6.5 13 stable canonical

Stack trace from regiond.log for the gui errors is attached, and mildly redacted fabric, subnet and interface configs from cli (from before I set the mode with the cli). This stack trace is identical no matter what the attempted change was.

Tags: ui Edit Tag help
Revision history for this message
Adam Nave (xcorvis) wrote :
Revision history for this message
Adam Nave (xcorvis) wrote :
Alberto Donato (ack) on 2020-02-24
tags: added: ui
Revision history for this message
eXtace (djandruczyk) wrote :

I am seeing the same problem when trying to edit an interface for a recently commissioned machine. The stack trace from the reporter is the same for me as well.

Running maas 2.7.0-8232-g.6e1dba4ab-0ubuntu1~18.04.1 from the ubuntu PPA http://ppa.launchpad.net/maas/2.7/ubuntu

Changed in maas:
status: New → Triaged
importance: Undecided → High
Revision history for this message
Maksim (ogremax) wrote :

Same problem.
2.7.0 (8232-g.6e1dba4ab-0ubuntu1~18.04.1)

Revision history for this message
Juan Pablo Vargas Soruco (jpvs1978) wrote :

Here is a work around that I used.

1. Install jq, is like sed for json.

sudo apt install jq

2. Then execute this to obtain host Ids

maas admin machines read | jq ".[] | \
{hostname:.hostname, system_id: .system_id, status:.status}" --compact-output

3. On each host you want to configure, Where c8c3w is the id of the host, this will get You the Ids of the NICs.

maas admin interfaces read c8c3ew | jq ".[] | \
{id:.id, name:.name, mac:.mac_address, vid:.vlan.vid, fabric:.vlan.fabric}" --compact-output

4. Then You can configure the interfaces on the vlan/subnet of your choice. 9 is the id of the NIC

maas admin interface link-subnet c8c3ew 9 mode=DHCP subnet="192.168.xx.0/24" force=True

5. If you want to create Bonds

maas admin interfaces create-bond c8c3ew name=bond0 \
parents=9 parents=14 \
bond_mode=active-backup \
bond_updelay=200 bond_downdelay=200 mtu=9000

Changed in maas-ui:
status: Unknown → New
Revision history for this message
Ram Meena (ram.meena) wrote :

Isn't there any temp workaround by changing a small piece of code?

Revision history for this message
Hakan Saplakoglu (hakasapl) wrote :

Some more information:
When a tag exists there seems to be the issue. If I remove the tag from the CLI (doesn't let me from the web UI) using

maas admin interface remove-tag <machineid> <interface> tag=sriov

I can then edit whatever I want including the static IP through the web UI.

Revision history for this message
Sean Feole (sfeole) wrote :

I was able to set the static ip via,

maas server-maas interface link-subnet kecx4s 241 mode=STATIC ip_address="XX.XX.XX.XX" subnet="XX.XX.XX.XX" default_gateway="XX.XX.XX.XX" subnet="XX.XX.XX.XX/21" force=True -d

Which is also outlined in comment# 5

Changed in maas:
status: Triaged → In Progress
assignee: nobody → Caleb Ellis (caleb-ellis)
milestone: none → 2.8.0rc1
Changed in maas-ui:
status: New → Fix Released
Alberto Donato (ack) on 2020-05-01
Changed in maas:
milestone: 2.8.0b3 → 2.8.0rc1
Revision history for this message
Igor Gnip (igorgnip) wrote :

Is this going to be fixed in 2.7 ?

Revision history for this message
Igor Gnip (igorgnip) wrote :

Any chance to backport this to 2.7 urgently ?

Changed in maas:
status: In Progress → Fix Committed
Revision history for this message
Igor Gnip (igorgnip) wrote :

2.7 ?

Revision history for this message
Caleb Ellis (caleb-ellis) wrote :

Yes we will be backporting this fix to 2.7

Alberto Donato (ack) on 2020-05-11
Changed in maas:
status: Fix Committed → Fix Released
Revision history for this message
Ventsislav Georgiev (vgeorgiev) wrote :

We've encountered this problem when we update MaaS.
Current MAAS version: 2.7.1~beta1 (8260-g.c0c9e2acd-0ubuntu1~18.04.1)
I'm unable to find this MAAS 2.7.1rc1 as listed above.

The solution for "maas admin interface remove-tag <machineid> <interface> tag=sriov" works just fine, but this is not optimal long term.

Any updates on this?

Revision history for this message
Ventsislav Georgiev (vgeorgiev) wrote :

A 'rc' is nowhere to be found on the ppa:2.7 repo.

Revision history for this message
dann frazier (dannf) wrote :

I hit this on 2.7 today as well, upgraded to 2.8 to get passed it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.