[2.7.0] MAAS did not detect any storage devices during commissioning

Bug #1863323 reported by Alexey Ponomarev on 2020-02-14

This bug report will be marked for expiration in 59 days if no further activity occurs. (find out why)

6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
Undecided
Unassigned

Bug Description

When commissioning starts on the Huawei 2288H V5 server, disk verification fails during the execution of the smartctl-validate script.

--------------------------------------------------------------------------
MAAS version: 2.7.0~rc7 (8231-g.dcbd7b4b6-0ubuntu1~18.04.1)
Product Name (Alias): 2288H V5 (2288H V5 10GE BASE-T)
RAID Controller Type: LSI SAS3508
--------------------------------------------------------------------------

Error executing smartctl-validate script in UI:

Unable to run 'smartctl-validate': 'MAAS did not detect any storage devices during commissioning!'
Given parameters:
{'storage': {'argument_format': '{path}', 'type': 'storage', 'value': 'all'}}
Discovered storage devices:
[]
Discovered interfaces:
{'98:03:9b:0c:9c:ce': 'enp134s0f0'}

description: updated
description: updated
Alberto Donato (ack) wrote :

Can you please attach output for commissioning scripts?

Changed in maas:
status: New → Incomplete
Alexey Ponomarev (brewle) wrote :

Logs from the directory /var/log/maas/rsyslog/

description: updated
Alexey Ponomarev (brewle) wrote :

Output for commissioning scripts

Changed in maas:
status: Incomplete → Confirmed
status: Confirmed → New
Alberto Donato (ack) wrote :

Could you please also add the output for the 50-maas-01-commissioning commissioning script?

Changed in maas:
status: New → Incomplete
Alexey Ponomarev (brewle) wrote :

Output for the 50-maas-01-commissioning commissioning script

Changed in maas:
status: Incomplete → New
Alberto Donato (ack) wrote :

Could you try setting the commissioning kernel to the "hwe" one, see if that makes a difference?

You can set it from Settings -> Commissioning -> Default minimum kernel version, setting one of the "hwe" ones.

Then try running commissioning again.

Changed in maas:
status: New → Incomplete
Alexey Ponomarev (brewle) wrote :

The commissioning kernel is configured to "bionic (hwe-18.04)".
After restarting the commissioning, the problem with detecting disks persisted.
Maybe the old version of smartmontool is used? Current version: smartd 6.6 2016-05-31 r4324 [x86_64-linux-4.15.0-74-generic] (local build)
As far as I know, the latest version 7.1 was released 2019-12-30

Changed in maas:
status: Incomplete → New
Alberto Donato (ack) wrote :

It doesn't seem to be an issue with smartd, but the kernel not detecting disks.

Does that controller need special drivers, maybe not included in the standard kernel?

Changed in maas:
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers