maas enlists multiple 'phantom' VMs

Bug #1851800 reported by Peter De Sousa on 2019-11-08

This bug report will be marked for expiration in 56 days if no further activity occurs. (find out why)

6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
Undecided
Unassigned

Bug Description

Hi,

Problem:

When rebooting the node with maas installed maas starts enlisting multiple
machines with unknown origin, with default configuration but with different names.

It seems like a UI defect, but only happens on reboot of the maas machine.

Included maas logs and machines.json in an archive.

Expected:

No VMs to be enlisted randomly

Steps to Reproduce:

1. Install MAAS and MAAS Rackd on a single machine, (Typical Orangebox setup)
2. Create pods on any of the baremetal nodes
3. Create VMs on the baremetal nodes via Juju
4. Powerdown all nodes at the same time (VMs and Baremetal)
5. sudo shutdown now on the MAAS node
6. Power-on maas node
7. Power-on all nodes at the same time, go through any VMs that haven't started and start them
8. Within 5-10 minutes random 'phantom' VMs should start popping up in the MAAS UI

If more information is required please feel free to ask.

Cheers,

Peter

Peter De Sousa (pjds) on 2019-11-08
description: updated
Adam Collard (adam-collard) wrote :

Please don't link to external archive of logs, it's far better to attach individual files to the bug.

Additionally can you please confirm which version of MAAS you're using? Pods on the controllers has had some recent bug fixes

Changed in maas:
status: New → Incomplete
Peter De Sousa (pjds) wrote :

Apologies, attached archive.

description: updated
Peter De Sousa (pjds) wrote :

Re: version: MAAS: 2.6.1

Thank you
Peter

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers