[2.6] Performance regression on machine listing page

Bug #1835199 reported by Adam Collard
54
This bug affects 10 people
Affects Status Importance Assigned to Milestone
MAAS
Fix Released
High
Caleb Ellis
2.6
Fix Released
Critical
Kit Randel
2.7
Fix Released
High
Caleb Ellis

Bug Description

As per https://discourse.maas.io/t/updated-to-2-6-from-2-5-now-ui-slow-and-not-usable/738/

Multiple users are seeing performance issues with MAAS 2.6, on the machine listing view.

"it takes 2/3 minutes to load ~200 nodes."

Tags: performance

Related branches

Revision history for this message
Luca Cervigni (cervigni) wrote :

I don't know if useful or not. But it could be related to loading physical machines or a certain type of machines.

The loading time takes the most for the first 3 batches of 25. After 75 loaded, it speeds up and the rest is loaded within 30 seconds.

Revision history for this message
Luca Cervigni (cervigni) wrote :

And btw, it is not only the performance regression on the list. It is also that the list is not cached, and browsing any other MAAS page other than the machine list page, makes the list re-loading after clicking again on "machines". This behaviour was not there in 2.5

Revision history for this message
Kit Randel (blr) wrote :

Thanks Luca, we should have some performance improvements land in the machine listing UI in the next point release. I've also opened https://bugs.launchpad.net/maas/+bug/1835316 which is related to the postgresql cpu usage issue you're seeing.

Changed in maas:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers