[2.6.0] bridge-utils not installed on xenial deployment

Bug #1834751 reported by Ebbex on 2019-06-29
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
MAAS
Undecided
Unassigned
curtin
High
Unassigned

Bug Description

Create a bridge on your primary pxe interface, and assign your primary ip to that bridge. When deploying xenial the bridge-utils aren’t installed, so when it reboots after install the interface won’t come up.

I’ve worked around it by adding a late_command in-target apt install bridge-utils to the /etc/maas/preseed/curtin_userdata, but looking through the source code maybe it should go in maasserver/preseed.py as an exception/special case for xenial?

Ebbex (eb4x) on 2019-06-29
summary: - bridge-utils not installed on xenial deployment
+ [2.6.0] bridge-utils not installed on xenial deployment
Changed in maas:
status: New → Invalid
Ryan Harper (raharper) wrote :

Thanks for filing a bug. Could you provide some debugging data:

https://discourse.maas.io/t/getting-curtin-debug-logs/169

A verbose curtin install.log should help us see what's going on.

This is likely related to 2.6 sending network-config v2 and the dependency
map for v2 did not
specify packages due to netplan not needing any. However, we should still
generate the possible
packages needed and we already check target system for netplan, and if it
has netplan we filter out
bridge-utils, ifenslave and vlan if presented as network-config dependent
packages.

On Mon, Jul 1, 2019 at 12:50 PM Ryan Harper <email address hidden>
wrote:

> Thanks for filing a bug. Could you provide some debugging data:
>
> https://discourse.maas.io/t/getting-curtin-debug-logs/169
>
> A verbose curtin install.log should help us see what's going on.
>
> --
> You received this bug notification because you are subscribed to curtin.
> Matching subscriptions: curtin-bugs-all
> https://bugs.launchpad.net/bugs/1834751
>
> Title:
> [2.6.0] bridge-utils not installed on xenial deployment
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/curtin/+bug/1834751/+subscriptions
>

Ebbex (eb4x) wrote :
Ebbex (eb4x) wrote :
Ebbex (eb4x) wrote :

I did the curtin_verbose thing from the guide as you can see here;

maas erikberg maas get-config name=curtin_verbose
Success.
Machine-readable output follows:
true

redeployed, but no sign of the curtin-logs.tar anywhere. Then added a second interface to the node and recommissioned it, moved the bridge on to the secondary interface so the install could complete. Now it installs, but the bridge on the secondary interface is dead (as expected) but still can't find any curtin-logs.tar. Did I miss something?

Ryan Harper (raharper) wrote :

I suspect there won't be any logs since there wasn't an "error" in the install; we capture some debug data in a tarball if install fails; but on success no such tarball is collected.

I don't need any further data; I can see where the bug is; thanks for reporting.

Changed in curtin:
status: New → Confirmed

This bug is fixed with commit 09e8d090 to curtin on branch master.
To view that commit see the following URL:
https://git.launchpad.net/curtin/commit/?id=09e8d090

Changed in curtin:
status: Confirmed → Fix Committed
Ryan Harper (raharper) on 2019-10-07
Changed in curtin:
importance: Undecided → High

This bug is believed to be fixed in curtin in version 19.3. If this is still a problem for you, please make a comment and set the state back to New

Thank you.

Changed in curtin:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers