[2.5] Pod websocket not notified if host interfaces change

Bug #1796426 reported by Mike Pontillo on 2018-10-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
High
Mike Pontillo

Bug Description

Steps to reproduce:

(1) Configure a hosted pod on a MAAS controller
(2) Add, change, or remove interfaces on the controller

Expected behavior:
 - The pod should be notified about an update (since changes to hosted pod interfaces mean a different set of potential VLANs or subnets to attach to), resulting in UI changes when composing a machine.

Actual behavior:
 - The pod websocket is not notified (thus the pod object is never updated)

Related branches

Changed in maas:
status: Triaged → In Progress
Changed in maas:
status: In Progress → Fix Committed
Changed in maas:
milestone: 2.5.0rc1 → 2.5.0beta3
Changed in maas:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers