[2.5] Attempting to register a rack without secret (and likely with incorrect secret) causes unhandled error

Bug #1792029 reported by Andres Rodriguez on 2018-09-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
High
Mike Pontillo

Bug Description

I attempted to register a rack controller to a region cluster but I forgot to create the secret file. The region logs started showing unhandled errors.

2018-09-11 20:52:53 RegionServer,187,::ffff:10.90.90.5: [info] RegionServer connection lost (HOST:IPv6Address(TCP, '::ffff:192.168.100.1', 5252) PEER:IPv6Address(TCP, '::ffff:10.90.90.5', 51842))
2018-09-11 20:52:53 maasserver.rpc.regionservice: [critical] Rack controller 'None' could not be authenticated; dropping connection.
        Traceback (most recent call last):
        Failure: twisted.protocols.amp.UnhandledCommand: (b'UNHANDLED', 'Unknown Error [node03:pid=6732:cmd=Authenticate:ask=1]')

2018-09-11 20:52:53 maasserver.rpc.regionservice: [info] Rack controller 'None' disconnected.
2018-09-11 20:52:53 RegionServer,189,::ffff:10.90.90.5: [info] RegionServer connection lost (HOST:IPv6Address(TCP, '::ffff:10.90.90.1', 5251) PEER:IPv6Address(TCP, '::ffff:10.90.90.5', 44784))
2018-09-11 20:52:53 maasserver.rpc.regionservice: [critical] Rack controller 'None' could not be authenticated; dropping connection.
        Traceback (most recent call last):
        Failure: twisted.protocols.amp.UnhandledCommand: (b'UNHANDLED', 'Unknown Error [node03:pid=6732:cmd=Authenticate:ask=1]')

To reproduce
------------

1. installed maas-rack-controller
2. configured /etc/maas/rackd.conf
3. sudo service maas-rackd restart

Expected behavior
-----------------

I would have expected that the regiond would not spit unhandled errors, rather, say that the rack controller failed to authenticate due to a missing secret (or incorrect secret).

Related branches

Changed in maas:
assignee: nobody → Mike Pontillo (mpontillo)
importance: Undecided → High
status: New → Triaged
milestone: none → 2.5.0beta1
Changed in maas:
status: Triaged → Fix Committed
Changed in maas:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers