[2.4, regression] Machine fails to enter rescue mode due to attempting to boot hwe-18.04 kernel

Bug #1768321 reported by Andres Rodriguez on 2018-05-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
Critical
Andres Rodriguez

Bug Description

This is a regression caused by:

LP: #1730525 - ea1b23b4f2020d3746b1b450558fa7e2f3290003

I'm running MAAS 2.4, I have both bionic and xenial images imported and my settings are as such:

1. The /default/ commissioning operating system is 'Bionic' with 'no minimum kernel'
2. The /default/ deployment operating system is 'Xenial' with 'no minimum kernel'

When I deploy a machine, the machine ends up with:

When I enter rescue mode, the machine attempts to boot the 'hwe-18.04' kernel which doesn't even exist:

2018-05-01 17:09:25 provisioningserver.rackdservices.tftp: [info] pxelinux.cfg/01-00-e0-81-d1-b1-47 requested by 00:e0:81:d1:b1:47
2018-05-01 17:09:25 provisioningserver.rackdservices.tftp: [info] ubuntu/amd64/hwe-18.04/bionic/no-such-image/boot-kernel requested by 00:e0:81:d1:b1:47

To reproduce:

1. Fresh install of MAAS
2. download bionic and xenial images
3. set the /default/ deployment OS as 'xenial' (don't set kernel
4. deploy xenial
5. enter rescue mode
6. The machine will fail due to no existing hwe-18.04.

Related branches

description: updated
description: updated
Changed in maas:
importance: Undecided → Critical
status: New → Triaged
milestone: none → 2.4.0rc1
summary: - [2.4] Machine fails to enter rescue mode due to attempting to boot
- hwe-18.04 kernel
+ [2.4, regression] Machine fails to enter rescue mode due to attempting
+ to boot hwe-18.04 kernel
Changed in maas:
assignee: nobody → Lee Trager (ltrager)
Changed in maas:
assignee: Lee Trager (ltrager) → Andres Rodriguez (andreserl)
Changed in maas:
status: Triaged → In Progress
Changed in maas:
status: In Progress → Fix Committed
Changed in maas:
milestone: 2.4.0rc1 → 2.4.0beta3
Changed in maas:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers