[2.x] Curtin config doesn't output tmpfs and ramfs YAML storage layout

Bug #1767979 reported by Blake Rouse on 2018-04-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
High
Alberto Donato
curtin
Medium
Scott Moser

Bug Description

I added 2 special filesystems to my machine both tmpfs and ramfs.

Machine output with filesystems: http://paste.ubuntu.com/p/nBSgNPwDzj/
Curtin preseed: http://paste.ubuntu.com/p/5yfNYHbzDZ/

The curtin preseed should contain the required YAML so the /etc/fstab is written correctly. At the moment curtin doesn't actually has a defined YAML for this.

Related branches

Changed in curtin:
status: New → Confirmed
Changed in maas:
assignee: nobody → Mike Pontillo (mpontillo)
Changed in maas:
assignee: Mike Pontillo (mpontillo) → Alberto Donato (ack)
Revision history for this message
Scott Moser (smoser) wrote :

started something at
 https://code.launchpad.net/~smoser/curtin/+git/curtin/+ref/bug/1767979-support-tmpfs-mounts

the intent there is to allow storage config to contain
 'spec' and 'fstype'

So MAAS could send something like:

storage:
 version: 1
 config:
   - id: mytmpfs
     type: mount
     spec: mytmpfs
     path: /tmpfs
     options: noexec,size=1024k

Revision history for this message
Blake Rouse (blake-rouse) wrote :

Do you mean:

spec: tmpfs ?

in the comment you have:

spec: mytmpfs

Revision history for this message
Ryan Harper (raharper) wrote : Re: [Bug 1767979] Re: [2.x] Curtin config doesn't output tmpfs and ramfs YAML storage layout

For non device based mounts, you can use whatever, it may make more
sense to put tmpfs, or proc, or ramfs, etc...

That ultimately renders out to this fstab entry:

mytmpfs tmpfs /tmpfs noexec,size=1024k

On Fri, May 4, 2018 at 12:14 AM, Blake Rouse <email address hidden> wrote:
> Do you mean:
>
> spec: tmpfs ?
>
>
> in the comment you have:
>
> spec: mytmpfs
>
> --
> You received this bug notification because you are subscribed to curtin.
> Matching subscriptions: curtin-bugs-all
> https://bugs.launchpad.net/bugs/1767979
>
> Title:
> [2.x] Curtin config doesn't output tmpfs and ramfs YAML storage layout
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/curtin/+bug/1767979/+subscriptions

Scott Moser (smoser) on 2018-05-04
Changed in curtin:
importance: Undecided → Medium
Changed in curtin:
status: Confirmed → In Progress
Alberto Donato (ack) on 2018-05-08
Changed in maas:
status: Triaged → In Progress
Scott Moser (smoser) on 2018-05-08
Changed in curtin:
assignee: nobody → Scott Moser (smoser)
Changed in maas:
status: In Progress → Fix Committed
Revision history for this message
Ryan Harper (raharper) wrote :

An upstream commit landed for this bug.

To view that commit see the following URL:
https://git.launchpad.net/curtin/commit/?id=9e6e66af

Changed in curtin:
status: In Progress → Fix Committed
Changed in maas:
status: Fix Committed → Fix Released
Revision history for this message
Ryan Harper (raharper) wrote : Fixed in curtin version 18.1-17-gae48e86f-0ubuntu1.

This bug is believed to be fixed in curtin in version18.1-17-gae48e86f-0ubuntu1. If this is still a problem for you, please make a comment and set the state back to New

Thank you.

Changed in curtin:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers