[2.3] Default install is now importing bionic by default instead of xenial.

Bug #1767137 reported by Chris Gregan on 2018-04-26
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
MAAS
High
Andres Rodriguez

Bug Description

Overnight MAAS 2.3 deployments of Xenial now fail. It seems a change to make Bionic a default download in 2.4 has effected 2.3

{github.com/juju/gomaasapi/client.go:124: } {ServerError: 400 BAD REQUEST ({"distro_series": ["'xenial' is not a valid distro_series. It should be one of: '', 'ubuntu/bionic'."]})}])

Related branches

Chris Gregan (cgregan) on 2018-04-26
summary: - MAAS 2.3.x Xenial deploys now fail 00 BAD REQUEST ({"distro_series":
+ MAAS 2.3.x Xenial deploys now fail 400 BAD REQUEST ({"distro_series":
["'xenial' is not a valid distro_series.
summary: - MAAS 2.3.x Xenial deploys now fail 400 BAD REQUEST ({"distro_series":
- ["'xenial' is not a valid distro_series.
+ [2.3] Default install is now importing bionic by default instead of
+ xenial.
Changed in maas:
milestone: none → 2.3.3
importance: Undecided → High
status: New → Triaged
Jason Hobbs (jason-hobbs) wrote :

The workaround is to explicitly sync xenial images. You can go to the images tab and select xenial there. If you're using foundation engine, you can add this to your infra.yaml:

maas_boot_source_selections:
- release: 'xenial'
  arches: ['amd64']

Changed in maas:
assignee: nobody → Andres Rodriguez (andreserl)
status: Triaged → In Progress
Jason Hobbs (jason-hobbs) wrote :

You also need to change the default commissioning release back to xenial.

Changed in maas:
status: In Progress → Fix Committed
Chris Gregan (cgregan) wrote :

@Andres,
When is 2.3.3 scheduled for release? We are now hitting this in the field

Changed in maas:
status: Fix Committed → Fix Released
to-hiro (to-hiro) wrote :

Hello,

my maas( 2.4.0~beta2, which was the default "apt install maas" ) on Bionic has the same issue. It seems only physical machines have "distro_series" parameter and VMs (Bionic) don't. Better to install 2.3.3?

$ juju bootstrap mymaas
Creating Juju controller "mymaas" on mymaas
Looking for packaged Juju agent version 2.3.8 for amd64
Launching controller instance(s) on mymaas...
ERROR failed to bootstrap model: cannot start bootstrap instance: unexpected: ServerError: 400 Bad Request ({"distro_series": ["'xenial' is not a valid distro_series. It should be one of: '', 'ubuntu/bionic'."]})

$ maas admin nodes read | grep distro
        "distro_series": "",
        "distro_series": "",
        "distro_series": "",
        "distro_series": "",
        "distro_series": "",
        "distro_series": "",
        "distro_series": "bionic",

Blake Rouse (blake-rouse) wrote :

@to-hiro

With 2.4 18.04 (bionic) is the default ubuntu release that is sync on a new installation of MAAS. You just need to go to the Images tab and sync 16.04 (xenial) and then juju will be able to bootstrap.

Andres Rodriguez (andreserl) wrote :

@to-hiro,

That's probably becuase you are using 2.4.0 *beta2*. You should be using 2.4.0 final.

https://lists.ubuntu.com/archives/maas-devel/2018-May/002835.html

Trent Lloyd (lathiat) wrote :

2.40-beta2 is still in the bionic archive as of now. To get 2.4.0 final you need to enable the ppa:maas/stable -- since it released 2 weeks ago I assume an SRU for this is being worked on but isn't yet finalised?

Otherwise as stated earlier, the workaround for this issue is to just explicitly enable syncing the xenial image on the images tab.

to-hiro (to-hiro) wrote :

Thank you Blake, Andres and Trent.

I tried to use Xenial image but MAAS was stuck in sync. I will try to recreate VMs again.

Thanks,

Robie Basak (racb) wrote :

My mistake about the tag - it wasn't as a result of an SRU that this bug triggered. But it still currently affects Xenial AIUI?

Changed in maas (Ubuntu):
status: New → Triaged
Changed in maas (Ubuntu Xenial):
status: New → Triaged
tags: added: regression-update
Changed in maas (Ubuntu):
status: Triaged → Invalid
tags: removed: regression-update
no longer affects: maas (Ubuntu)
no longer affects: maas (Ubuntu Xenial)
Eduardo Pérez (eperezf) wrote :

Hi, I'm having this issue on MAAS 2.4.2 using Ubuntu Server 18.04.1 LTS. I'm trying to deploy OpenStack using MAAS and Juju.

 ServerError: 400 Bad Request ({"distro_series": ["\'xenial\' is not a valid distro_series. It should be one of: \'\', \'ubuntu/bionic\'."]})']

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers