[2.4, UI] Context menu regression

Bug #1766781 reported by Mike Pontillo on 2018-04-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
Critical
Karl Williams

Bug Description

This bug was seen on the domain details page, but it could be present on other pages as well.

A recent change to the styles seems to have caused a regression on the domain details page: the context menu no longer opens properly.

Steps to reproduce:

(1) Browse to the details page for any domain
(2) Add a record (TXT records are easy for this purpose, since they can contain any data)
(3) Click the "burger" menu on the right side of the table (on the row for the newly-added record)

Expected behavior:

Context menu appears for the given row, overlapping other portions of the page (as necessary).

Actual behavior:

A small scrollable viewport appears inside the row; the context menu appears inside.

Tags: ui Edit Tag help

Related branches

Changed in maas:
importance: High → Critical
milestone: none → 2.4.0beta3
Changed in maas:
status: Triaged → In Progress
Changed in maas:
status: In Progress → Fix Committed
Changed in maas:
milestone: 2.4.0beta3 → 2.4.0rc1
Changed in maas:
milestone: 2.4.0rc1 → 2.4.0beta3
Changed in maas:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers