[2.4, regression] UI action confirmation messages are missing

Bug #1766680 reported by Andres Rodriguez on 2018-04-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
Critical
Lee Trager

Bug Description

Missing confirmation message to acquire machine.

Related branches

Andres Rodriguez (andreserl) wrote :

Issue wans't present on d6fef78f1 but present on b08e4a321:

commit b08e4a321e661a140b411a17fb53336c770e9265
Author: Alberto Donato <email address hidden>
Date: Tue Apr 24 13:08:46 2018 +0000

    backport some of the template/js logic for resource pool to free repo

commit aa8897209f46f7f50ee2d1b3fa5774f66a0f633d
Author: Lee Trager <email address hidden>
Date: Fri Apr 20 22:06:12 2018 +0000

    LP: #1754334 - Fix Javascript error when loading interfaces tab.

    Before new interfaces have been added they are set to {}. On page load all
    interfaces are validated including new interfaces. Ignore validation on new
    interfaces as the object must be fully defined.

My guess is that the regression is b08e4a321e661a140b411a17fb53336c770e9265

Changed in maas:
importance: Undecided → Critical
milestone: none → 2.4.0rc1
status: New → Triaged
summary: - [2.4] UI action confirmation messages are missing
+ [2.4, regression] UI action confirmation messages are missing
tags: added: regression
Andres Rodriguez (andreserl) wrote :

Actually i think it is aa8897209f46f7f50ee2d1b3fa5774f66a0f633d

Andres Rodriguez (andreserl) wrote :
Changed in maas:
assignee: nobody → Lee Trager (ltrager)
Lee Trager (ltrager) wrote :

This was due to b08e4a3, some end tags were missing causing the messages for release, delete, and other actions to not show.

Changed in maas:
status: Triaged → In Progress
Changed in maas:
status: In Progress → Fix Committed
Changed in maas:
milestone: 2.4.0rc1 → 2.4.0beta3
Changed in maas:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers