maas insists on running the proxy, even when it's disabled

Bug #1762673 reported by Jason Hobbs on 2018-04-10
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
MAAS
Undecided
Unassigned

Bug Description

This is with 2.3.1.

My maas proxy appears to be stale. To investigate it, I want to turn off the proxy and wipe out the cache.

I can't do this, because maas keeps restarting the proxy, even when I've disabled the proxy in maas settings and stopped it manually with systemd.

I see this in the maas.log:
Apr 10 08:55:50 dratini maas.service_monitor: [info] Service 'maas-proxy' is not on, it will be started.
Apr 10 08:55:50 dratini maas.service_monitor: [info] Service 'maas-proxy' has been started and is 'running'.

It should not be starting the proxy if I've disabled the proxy in MAAS settings.

Andres Rodriguez (andreserl) wrote :

Hi Jason,

It is by design that the proxy is always running. You cannot "disable" the running proxy per se, but rather, you disable machines using the proxy.

Keep in mind that if you were to have deployed machines or others using the proxy, and you were to stop the service, those machines wouldn't be able to obtain new packages (when you mean to stop new machines from using it).

Changed in maas:
status: New → Won't Fix
Andres Rodriguez (andreserl) wrote :

Actually, it seems there's some inconsistency on when the proxy gets stopped.

If we use an upstream proxy, then the proxy gets stopped.
If we disable the proxy, it continues to run.

We'll investigate the inconsistency, but the intended was as the comment above.

Changed in maas:
milestone: none → 2.4.0beta3
importance: Undecided → Medium
status: Won't Fix → Triaged
importance: Medium → Low
importance: Low → Undecided
Changed in maas:
milestone: 2.4.0beta3 → 2.4.0beta4
Changed in maas:
milestone: 2.4.0beta4 → 2.4.x
Gregory Orange (gregoryo2017) wrote :

We at least want disk usage control over the squid proxy, and thought we could disable the service and delete all of the cache files. I don't mind if the service is running (see what happens with your investigation into the run/stop inconsistency you mentioned), but can I get some clarity on controlling that?

Of course I could stop the proxy manually, delete all the directories, make the parent directory /var/spool/maas-proxy read-only. Then when service_monitor restarts maas-proxy it will probably just complain. But that feels like a hack.

TIA,
Greg.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers