[2.4] Executing actions in the UI (e.g. deploying, commissioning) is too slow

Bug #1761600 reported by Andres Rodriguez on 2018-04-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
High
Lee Trager

Bug Description

Trying to execute actions in the UI for a set of machines is too slow.

Either the UI is providing slow feedback, or the backend is now taking too long to execute these actions.

Related branches

Changed in maas:
importance: Undecided → High
milestone: none → 2.4.0beta2
status: New → Triaged
Changed in maas:
assignee: nobody → Lee Trager (ltrager)
Lee Trager (ltrager) wrote :

Were you in HA mode using HAProxy when this occurred? I think this may be related to LP:1761601. I've tested with MAAS in HA mode using Apache and in the CI. Commissioning and deploying in both takes the normal amount of time(a few seconds to change status and verify action has started with power state change).

Changed in maas:
status: Triaged → Incomplete
Andres Rodriguez (andreserl) wrote :

I can still reproduce this! No HA proxy here. directly connected.

Changed in maas:
status: Incomplete → New
status: New → Confirmed
Andres Rodriguez (andreserl) wrote :

The issue is that the action waits for the machine to power on successfully or fail.

Changed in maas:
milestone: 2.4.0beta2 → 2.4.0rc1
Changed in maas:
status: Confirmed → In Progress
Lee Trager (ltrager) wrote :

This is due to b352322cc702588f0d91cd457e2eff582305f41e which switches the backend for twisted to asyncio. deferLater is now returned which causes the power_change RPC call to wait on the response. Previously deferLater would run in parallel while the RPC call was returned.

I tried just reverting the adding the return but this breaks a number of tests. It seems the return was added to fix those tests.

Changed in maas:
status: In Progress → Fix Committed
Changed in maas:
milestone: 2.4.0rc1 → 2.4.0beta3
Changed in maas:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers