[2.4, UI, websockets] UI triggers/websockets on subnet details page not auto-updating subnet's IP listing

Bug #1761281 reported by Dean Henrichsmeyer on 2018-04-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
Medium
Mike Pontillo

Bug Description

When I click on the subnets tab in the MAAS UI at the top it doesn't actually pull the current data from the database. I have to reload the page to get it to actually give me the current data. It should be current.

Related branches

Andres Rodriguez (andreserl) wrote :

Hi Dean,

Can you clarify what data are you referring to?

Changed in maas:
status: New → Incomplete
summary: - The subnets page does not pull data on view
+ [2.4, UI] The subnets page does not pull data on view

and more importantly, how to reproduce? Cause this may be an issue with the cache on the browser, as MAAS tries to force the cache to be reloaded when accessing pages (which could or could not be broken).

Dean Henrichsmeyer (dean) wrote :

Load the MAAS machine listing. Launch a container in a node. Go to the subnets page, click the subnet, you won't see the container. You'll have to reload the page. Confirmed that it happens in both Chrome and Firefox.

Changed in maas:
status: Incomplete → New
Dean Henrichsmeyer (dean) wrote :

To be clear, by launch a container in a node I'm referring to lxc launch on a machine that's part of a MAAS integrated LXD cluster, thereby using MAAS for IPAM.

summary: - [2.4, UI] The subnets page does not pull data on view
+ [2.4, UI] UI triggers on subnet details page not auto-updating subnet's
+ IP listing
Changed in maas:
importance: Undecided → High
status: New → Triaged
assignee: nobody → Lee Trager (ltrager)
importance: High → Medium
Changed in maas:
assignee: Lee Trager (ltrager) → nobody
summary: - [2.4, UI] UI triggers on subnet details page not auto-updating subnet's
- IP listing
+ [2.4, UI, websockets] UI triggers/websockets on subnet details page not
+ auto-updating subnet's IP listing
Changed in maas:
milestone: 2.4.0beta2 → 2.4.0rc1
Changed in maas:
assignee: nobody → Mike Pontillo (mpontillo)
Changed in maas:
status: Triaged → In Progress
Mike Pontillo (mpontillo) wrote :

There was an existing trigger for notifying the subnet when IP addresses were updated, but it was missing triggers for insertion and deletion.

Changed in maas:
status: In Progress → Fix Committed
Changed in maas:
milestone: 2.4.0rc1 → 2.4.0beta3
Changed in maas:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers