[2.4, UI] Errors when loading the interfaces tab

Bug #1754334 reported by Lee Trager on 2018-03-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
High
Lee Trager

Bug Description

The following errors are seen in the browser console when loading the Interface or Storage tab on the node-details page.

Interface tab:

Error: nic is null
./src/maasserver/static/js/angular/controllers/node_details_networking.js/</$scope.isInterfaceNameInvalid@http://10.0.0.2:5240/MAAS/static//js/bundle/maas-min.js?v=2.4.0~alpha2(6705-ga8b3132-0ubuntu1):1:63115
fn0@http://10.0.0.2:5240/MAAS/combo/angular.js?v=2.4.0~alpha2(6705-ga8b3132-0ubuntu1) line 7 > Function:4:644
expressionInputWatch@http://10.0.0.2:5240/MAAS/combo/angular.js?v=2.4.0~alpha2(6705-ga8b3132-0ubuntu1):8:4533
$digest@http://10.0.0.2:5240/MAAS/combo/angular.js?v=2.4.0~alpha2(6705-ga8b3132-0ubuntu1):8:19723
$apply@http://10.0.0.2:5240/MAAS/combo/angular.js?v=2.4.0~alpha2(6705-ga8b3132-0ubuntu1):8:22200
./src/maasserver/static/js/angular/factories/region.js/</RegionConnection.prototype.onResponse@http://10.0.0.2:5240/MAAS/static//js/bundle/maas-min.js?v=2.4.0~alpha2(6705-ga8b3132-0ubuntu1):1:307651
./src/maasserver/static/js/angular/factories/region.js/</RegionConnection.prototype.onMessage@http://10.0.0.2:5240/MAAS/static//js/bundle/maas-min.js?v=2.4.0~alpha2(6705-ga8b3132-0ubuntu1):1:307379
./src/maasserver/static/js/angular/factories/region.js/</RegionConnection.prototype.connect/this.websocket.onmessage@http://10.0.0.2:5240/MAAS/static//js/bundle/maas-min.js?v=2.4.0~alpha2(6705-ga8b3132-0ubuntu1):1:305563

Tags: ui Edit Tag help

Related branches

Lee Trager (ltrager) on 2018-03-08
tags: removed: vanilla-transition
summary: - [2.4, UI, vanilla] Errors when loading the storage tab
+ [2.4, UI] Errors when loading the storage tab

I'm not sure yet about the first error, but I know what the problem is on the storage tab; I plan to fix it as a drive-by in my next branch.

Lee Trager (ltrager) wrote :

Updated bug as the storage error has been fixed. The interfaces error does remain.

description: updated
Lee Trager (ltrager) on 2018-04-06
Changed in maas:
milestone: 2.4.x → 2.4.0beta3
Lee Trager (ltrager) on 2018-04-20
summary: - [2.4, UI] Errors when loading the storage tab
+ [2.4, UI] Errors when loading the interfaces tab
Changed in maas:
status: Triaged → In Progress
assignee: nobody → Lee Trager (ltrager)
Changed in maas:
status: In Progress → Fix Committed
Changed in maas:
milestone: 2.4.0beta3 → 2.4.0rc1
Changed in maas:
milestone: 2.4.0rc1 → 2.4.0beta3
Changed in maas:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers