[2.4] MAAS doesn't set the right DNS server when rackd.conf:maas_url is localhost

Bug #1750689 reported by Andres Rodriguez on 2018-02-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
High
Mike Pontillo

Bug Description

Deploying a machine with these settings resulted in the wrong DNS for the deployed machines:

 - 192.168.1.0/24 - external network
 - 10.90.90.0/24 - internal network

ubuntu@maas00:~$ sudo cat /etc/maas/regiond.conf
database_host: localhost
database_name: maasdb
database_pass: YtO9mTBSk9Q7
database_port: 5432
database_user: maas
maas_url: http://192.168.1.13:5240/MAAS

ubuntu@maas00:~$ sudo cat /etc/maas/rackd.conf
cluster_uuid: 9342b4df-c4a9-446e-995f-8ccedfe1fab5
maas_url: http://localhost:5240/MAAS

dhcp snippet:

shared-network vlan-5002 {
    subnet 10.90.90.0 netmask 255.255.255.0 {
           ignore-client-uids true;
           next-server 10.90.90.1;
           option subnet-mask 255.255.255.0;
           option broadcast-address 10.90.90.255;
           option domain-name-servers 192.168.1.13;
           option domain-name "maas";
           option domain-search "maas", "maaslab";
           option routers 10.90.90.1;
           option ntp-servers 10.90.90.1;

           #
           # Subnet DHCP snippets
           #
           # No DHCP snippets defined for subnet
           pool {
              range 10.90.90.190 10.90.90.253;
           }
    }
}

# Machine network configuration
network:
    version: 2
    ethernets:
        enp0s25:
            match:
                macaddress: b8:ae:ed:7d:17:d2
            mtu: 1500
            nameservers:
                addresses:
                - 192.168.1.13
                search:
                - maaslab
                - maas
            set-name: enp0s25
    bridges:
        br0:
            addresses:
            - 10.90.90.3/24
            gateway4: 10.90.90.1
            interfaces:
            - enp0s25
            parameters:
                forward-delay: 15
                stp: false

Related branches

summary: - [2.4] MAAS doesn't set the right DNS server
+ [2.4] MAAS doesn't set the right DNS server when rackd.conf:maas_url is
+ localhost
Changed in maas:
milestone: none → 2.4.0alpha2
importance: Undecided → High
status: New → Triaged
Changed in maas:
milestone: 2.4.0alpha2 → 2.4.0beta1
Changed in maas:
milestone: 2.4.0beta1 → 2.4.0beta2
Changed in maas:
milestone: 2.4.0beta2 → 2.4.0beta3
Changed in maas:
assignee: nobody → Mike Pontillo (mpontillo)
milestone: 2.4.0beta3 → 2.4.0rc1
Changed in maas:
status: Triaged → In Progress
Changed in maas:
status: In Progress → Fix Committed
Changed in maas:
milestone: 2.4.0rc1 → 2.4.0beta3
Changed in maas:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers