[2.3] Image download hardlinks the hwe-*-edge as the generic kernel instead of the ga-* kernel.

Bug #1749246 reported by Scott Moser on 2018-02-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
Medium
Lee Trager
2.3
Medium
Lee Trager

Bug Description

When I boot a node into 'rescue mode', it is booting into 4.13 kernel.
the maas has no minimum kernel set (globally) nor does the node.

$ maas crash-and-burn maas get-config name=default_min_hwe_kernel
""
$ maas crash-and-burn nodes read
[
...
        "min_hwe_kernel": "",

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: maas 2.3.0-6434-gd354690-0ubuntu1~16.04.1
ProcVersionSignature: Ubuntu 4.4.0-112.135-generic 4.4.98
Uname: Linux 4.4.0-112-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.15
Architecture: amd64
Date: Tue Feb 13 16:54:06 2018
JournalErrors:
 Error: command ['journalctl', '-b', '--priority=warning', '--lines=1000'] failed with exit code 1: Hint: You are currently not seeing messages from other users and the system.
       Users in the 'systemd-journal' group can see all messages. Pass -q to
       turn off this notice.
 No journal files were opened due to insufficient permissions.
PackageArchitecture: all
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: maas
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Scott Moser (smoser) wrote :
Andres Rodriguez (andreserl) wrote :

Can you provide /var/log/maas/rackd.log when the machine is PXE booting and the MAC address of the PXE interface?

Changed in maas (Ubuntu):
status: New → Incomplete
Changed in maas:
status: New → Incomplete
Scott Moser (smoser) wrote :

Well, in order to fix an issue where nodes were "stuck" in "exiting rescue mode", I restarted region and rackd. Next time I put into rescue mode it booted 4.4

Andres Rodriguez (andreserl) wrote :

roaksoax@rivals:/var/lib/maas/boot-resources/current/ubuntu/amd64$ md5sum hwe-16.04-edge/xenial/daily/boot-kernel
e82babf4ccdef259c29e932a099416b2 hwe-16.04-edge/xenial/daily/boot-kernel
roaksoax@rivals:/var/lib/maas/boot-resources/current/ubuntu/amd64$ md5sum generic/xenial/daily/boot-kernel
e82babf4ccdef259c29e932a099416b2 generic/xenial/daily/boot-kernel
roaksoax@rivals:/var/lib/maas/boot-resources/current/ubuntu/amd64$ md5sum ga-16.04/xenial/daily/boot-kernel
4720fbda6a4a6c058cda1831ed64d38c ga-16.04/xenial/daily/boot-kernel

Changed in maas:
status: Incomplete → Confirmed
milestone: none → 2.4.x
summary: - nodes boot into 4.13 (hwe kernel) with no minimum kernel set
+ [2.3] Image download hardlinks the hwe-*-edge as the generic kernel
+ instead of the ga-* kernel.
Changed in maas:
importance: Undecided → Medium
assignee: nobody → Lee Trager (ltrager)
Lee Trager (ltrager) on 2018-02-13
Changed in maas:
status: Confirmed → In Progress
Scott Moser (smoser) on 2018-02-14
Changed in maas (Ubuntu):
status: Incomplete → Confirmed
Changed in maas:
status: In Progress → Fix Committed
Changed in maas:
milestone: 2.4.x → 2.4.0alpha2
Changed in maas:
status: Fix Committed → Fix Released
no longer affects: maas (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers