[2.3, API, wishlist] not possible to get bios_boot_mode from MAAS CLI

Bug #1747688 reported by Junien Fridrick on 2018-02-06
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
Undecided
Unassigned

Bug Description

Hi,

Using "node read" from the MAAS CLI does not display the bios_boot_method for a node. You have to look in the database to find it. It's not exposed in the MAAS web UI either, as far as I can see.

Could we please get access to this information ?

Thanks

This is with MAAS 2.3.0-6434-gd354690-0ubuntu1~16.04.1

Changed in maas:
status: New → Incomplete
Andres Rodriguez (andreserl) wrote :

Hi Junien,

Is there any particular reason of why you want to have access to the node's bios_boot_method attribute? I'm trying to understand what's the use case.

summary: - not possible to get bios_boot_mode from MAAS CLI
+ [API, wishlist] not possible to get bios_boot_mode from MAAS CLI
tags: added: internal
Changed in maas:
milestone: none → 2.4.x
summary: - [API, wishlist] not possible to get bios_boot_mode from MAAS CLI
+ [2.3, API, wishlist] not possible to get bios_boot_mode from MAAS CLI
Junien Fridrick (axino) wrote :

The use case is that I need this information to decide if I must create a /boot/efi partition or not (see also related bug 1747685, which got marked as a duplicate of bug 1591336)

Changed in maas:
status: Incomplete → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers