[2.x] MAAS not adding mtu size change to dhcpd.conf

Bug #1735207 reported by Jeff Hillman on 2017-11-29
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
High
Mike Pontillo
2.3
High
Mike Pontillo

Bug Description

When editing the MTU size for a VLAN and DHCP is enabled on that VLAN, MAAS is not adding the line

option interface-mtu <mtu size>;

to that VLAN.

Using a DHCP snippit is a work around for this, but MAAs should be performing this action when that value is changed.

In my case, I had enabled DHCP, then later altered the MTU size. I have not tested in the reverse order.

This entire issue was causing PXE to fail.

Related branches

summary: - MAAS not adding mtu size change to dhcpd.conf
+ [2.x] MAAS not adding mtu size change to dhcpd.conf
Changed in maas:
importance: Undecided → High
status: New → Triaged
milestone: none → 2.4.x
Christian Reis (kiko) wrote :

Escalating to high (has unobvious workaround)

Changed in maas:
milestone: 2.4.x → 2.4.0alpha1
Jeff Hillman (jhillman) wrote :

My apologies for this omission on the initial report.

maas 2.2.2-6099-g8751f91-0ubuntu1 on Xenial

Andres Rodriguez (andreserl) wrote :

As per the bug report from Jeff:

"Using a DHCP snippit is a work around for this"

This combined with the fact that MAAS has a feature that allows to perform custom configuration for DHCP, tells me that the work around is very obvious and very easy to perform.

Kiko, do you disagree?

Christian Reis (kiko) wrote :

By unobvious I meant that the path from seeing the symptom to deciding where the problem is and how to fix is not obvious.

In more detail: Jeff, Ante and I had to spend hours debugging the issue to find out the root cause -- MTU issues are just a pain and we shouldn't let people fall into this trap. So I'd keep it at High.

Changed in maas:
assignee: nobody → Mike Pontillo (mpontillo)
Dean Henrichsmeyer (dean) wrote :

I agree the bug priority should stay high but it doesn't need to be covered under the field high SLA. It doesn't match the criteria.

Changed in maas:
milestone: 2.4.0alpha1 → 2.4.0alpha2
Changed in maas:
milestone: 2.4.0alpha2 → 2.4.0beta1
Mike Pontillo (mpontillo) wrote :

Hm, for some reason the merge proposal for this didn't get linked. This landed in MAAS 2.4.

https://code.launchpad.net/~mpontillo/maas/+git/maas/+merge/337408

Changed in maas:
status: Triaged → Fix Committed
status: Fix Committed → Fix Released
Changed in maas:
milestone: 2.4.0beta1 → 2.4.0alpha2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers