Nodes fail deploying with 17.10 due to hang on "waiting for network" at boot

Bug #1726909 reported by David Tenty on 2017-10-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
Undecided
Unassigned
maas (Ubuntu)
Undecided
Unassigned
Xenial
Critical
Unassigned

Bug Description

When I try to deploy an Artful image to nodes that previously deployed properly with 16.04, deployment fails due to timeout. It seems that the curtin install finishes successfully but the nodes are hanging at 'Waiting for network' on boot.

After looking into the image it seems as though MaaS/Curtin are setting the node up with '/etc/network/interfaces' instead of netplan, which is no longer supported.

Output of 'dpkg -l '*maas*'|cat':

||/ Name Version Architecture Description
+++-===============================-====================================-============-=============================================
un maas <none> <none> (no description available)
ii maas-cli 2.2.2-6099-g8751f91-0ubuntu1~16.04.1 all MAAS client and command-line interface
ii maas-common 2.2.2-6099-g8751f91-0ubuntu1~16.04.1 all MAAS server common files
ii maas-dns 2.2.2-6099-g8751f91-0ubuntu1~16.04.1 all MAAS DNS server
ii maas-proxy 2.2.2-6099-g8751f91-0ubuntu1~16.04.1 all MAAS Caching Proxy
ii maas-region-api 2.2.2-6099-g8751f91-0ubuntu1~16.04.1 all Region controller API service for MAAS
ii maas-region-controller 2.2.2-6099-g8751f91-0ubuntu1~16.04.1 all Region Controller for MAAS
un maas-region-controller-min <none> <none> (no description available)
un python-django-maas <none> <none> (no description available)
un python-maas-client <none> <none> (no description available)
ii python3-django-maas 2.2.2-6099-g8751f91-0ubuntu1~16.04.1 all MAAS server Django web framework (Python 3)
ii python3-maas-client 2.2.2-6099-g8751f91-0ubuntu1~16.04.1 all MAAS python API client (Python 3)
ii python3-maas-provisioningserver 2.2.2-6099-g8751f91-0ubuntu1~16.04.1 all MAAS server provisioning libraries (Python 3)

David Tenty (daltenty) wrote :
David Tenty (daltenty) wrote :
Andres Rodriguez (andreserl) wrote :

Hi David,

The reason of the failure is because you need a newer curtin version. Artful has changed the way it does network (no longer e/n/i, but netplan) and as such, a newer curtin is needed to work alongside cloud-init to write the networking moving forward.

Changed in maas:
status: New → Invalid
Andres Rodriguez (andreserl) wrote :

Also, you can obtain the new version of curtin by enabled -proposed as a repository.

[1] https://launchpad.net/ubuntu/+source/curtin

Dimitri John Ledkov (xnox) wrote :

I believe there was a similar bug report from manjo before. which was fixed by upgrading to the stable PPA.

However, we do request and require that MAAS as installed from xenial-updates (and all deps) are working correctly.

What is missing from xenial-updates? Please make this bug report affect those packages with xenial series as affected.

Changed in maas:
status: Invalid → Confirmed
Changed in maas (Ubuntu Xenial):
importance: Undecided → Critical
Changed in maas (Ubuntu):
status: New → Fix Released
Changed in maas (Ubuntu Xenial):
status: New → Confirmed
Andres Rodriguez (andreserl) wrote :

You need a newer version of curtin, which is currently available on xenial-proposed.

Changed in maas:
status: Confirmed → Invalid
Changed in maas (Ubuntu Xenial):
status: Confirmed → Invalid
Dimitri John Ledkov (xnox) wrote :

Please install curtin from -proposed, and help verifying curtin SRU which should resolve this problem https://bugs.launchpad.net/ubuntu/+source/curtin/+bug/1721808

David Tenty (daltenty) wrote :

Upgrading to curtin from xenial-proposed seems to resolve this issue. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers