[1.9] Unable to install 14.04, shim.efi.signed renamed

Bug #1713795 reported by zdw on 2017-08-29
48
This bug affects 6 people
Affects Status Importance Assigned to Milestone
MAAS
Critical
Andres Rodriguez
maas (Ubuntu)
Critical
Unassigned
Trusty
Undecided
Unassigned

Bug Description

[Impact]
After a recent update, it's no longer possible to install Ubuntu 14.04 with MaaS 1.9.5 . This is on a new installation of MaaS on 14.04.

The change appears to be related to this change: https://launchpad.net/ubuntu/+source/shim-signed/1.32~14.04.2

[Test Case]
1. Install maas 1.9
2. Attempt to import images
2.1 without the fix, MAAS wont be able to import images.
2.2. with the fix, MAAS will be able to import images.

[Regression Potential]
Minimal. Since only the name of a binary has changed, this has minimal impact provided the binary doesn't get renamed again.

Related branches

zdw (zdw) wrote :
Changed in maas:
importance: Undecided → Critical
Changed in maas (Ubuntu):
importance: Undecided → Critical
assignee: nobody → Andres Rodriguez (andreserl)
status: New → Triaged
Changed in maas:
status: New → Triaged
Changed in maas:
assignee: nobody → Andres Rodriguez (andreserl)
milestone: none → 1.9.6
John Lewis (jlewis-johnlewis) wrote :

So, the reason the suggested workaround doesn't work is because this file is extracted from a copy of the package which is downloaded on the fly by /usr/lib/python2.7/dist-packages/provisioningserver/boot/uefi.py

On line 146, you need to change shim.efi.signed to shimx64.efi.signed to reflect the file's updated name/location in the shim-signed package. You then either need to restart maas services or reboot so that bytecode (pyc) is refreshed/recompiled.

/usr/lib/python2.7/dist-packages/provisioningserver/boot/uefi.py is part of maas-provisioning-server

HTH

John Lewis (jlewis-johnlewis) wrote :

I should correct myself, the package name where the .py file resides is actually python-maas-provisioningserver

Andres Rodriguez (andreserl) wrote :

Hi John,

There's a patch attached which you can apply to resolve this issue. We are working to get this SRU'd.

Thanks!

Changed in maas:
status: Triaged → In Progress
Changed in maas (Ubuntu):
status: Triaged → In Progress
Changed in maas (Ubuntu):
status: In Progress → New
assignee: Andres Rodriguez (andreserl) → nobody
John Lewis (jlewis-johnlewis) wrote :

Hi Andres,

Thank you for that, and thank you to the reporter - I actually spent quite a bit of time struggling with this today, and the bug report and reference to shim-signed pointed me in the right direction.

Cheers,

John.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in maas (Ubuntu):
status: New → Confirmed
description: updated
description: updated
tags: added: sts
Brian Murray (brian-murray) wrote :

Will this fix only work with the version of grub in trusty-updates? Does there need to be compatibility with the version in trusty-security?

Changed in maas (Ubuntu):
status: Confirmed → Incomplete
Andres Rodriguez (andreserl) wrote :

Yes, this will work only with the version in trusty-updates, provided that all of our known customers/users are already using trusty-updates, and as such, we do not need to be compatible with trusty-security.

Changed in maas (Ubuntu):
status: Incomplete → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in maas (Ubuntu):
status: New → Confirmed
Brian Murray (brian-murray) wrote :

If this change is incompatible with the version of grub in trusty-security, then I think this should be a versioned dependency.

Andres Rodriguez (andreserl) wrote :

@Brian,

I've uploaded a new version of the package including this change, but I think you may have to reject the previous upload as it shares the same version.

Hello zdw, or anyone else affected,

Accepted maas into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/maas/1.9.5+bzr4599-0ubuntu1~14.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-trusty to verification-done-trusty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-trusty. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in maas (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed verification-needed-trusty
Hennie Marais (hennie-2) wrote :

The update in proposed fix this problem for me on Trusty.

Paul Collins (pjdc) wrote :

Updating tag per comment #13.

tags: added: verification-done-trusty
removed: verification-needed-trusty
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package maas - 1.9.5+bzr4599-0ubuntu1~14.04.2

---------------
maas (1.9.5+bzr4599-0ubuntu1~14.04.2) trusty-proposed; urgency=medium

  * Stable Release Update.
    - debian/patches/fix-shim-name-lp1713795.patch: Grub package in Trusty
      has changed the name of the shim and has caused MAAS to being unable
      to import new images. (LP: #1713795)
    - debian/control: Bump depends on grub-common to ensure latest is
      always installed.

 -- Andres Rodriguez <email address hidden> Thu, 31 Aug 2017 15:22:08 -0400

Changed in maas (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for maas has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in maas:
status: In Progress → Fix Committed
Changed in maas (Ubuntu):
status: Confirmed → Fix Released
Changed in maas:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers