RSD Pod refresh shows ComposedNodeState is "Failed"

Bug #1694759 reported by Newell Jensen on 2017-05-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
Critical
Newell Jensen
2.2
Critical
Newell Jensen
MAAS RSD
Critical
Newell Jensen

Bug Description

When trying to compose an RSD node with remote storage, the allocation succeeds but the assembly process fails, ultimately leading to a failed composition. However, on Pod refresh, MAAS finds the allocated node and then fails to commission it because it is in a ComposedNodeState of Failed.

This bug surfaced due to #1694756

We should be deleted any nodes that were allocated when assembly fails before raising an error the the user.

Related branches

Changed in maasrsd:
status: New → Confirmed
importance: Undecided → Critical
assignee: nobody → Newell Jensen (newell-jensen)
milestone: none → beta
Changed in maas:
status: Confirmed → In Progress
Changed in maasrsd:
status: Confirmed → In Progress
Changed in maas:
status: In Progress → Fix Committed
Changed in maasrsd:
status: In Progress → Fix Committed
Changed in maas:
milestone: 2.3.0 → 2.3.0alpha1
Changed in maas:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers