[2.1+, UI] Hard to tell that HA is not enabled for DHCP on a VLAN

Bug #1675981 reported by Peter Matulis on 2017-03-25
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
MAAS
Medium
Steve Rydz

Bug Description

A complete MAAS environment was installed via the 'maas' metapackage. On another host I installed and registered a second rack controller, to achieve HA on the rackd level. I confirmed that both rackd were recognized in the region (via web UI and CLI). Nodes could be enlisted, commissioned and deployed using MAAS-managed DHCP.

To test HA, the original rackd was turned off:

sudo service maas-rackd stop

I was expecting DHCP to become available, via the second rackd, but this wasn't the case. It never came on. This was reflected in the web UI ('dhcpd' was not green). Enlistment and Deployment (two different nodes) also failed.

2.2.0~beta3+bzr5815-0ubuntu1 was used on both hosts.

Blake Rouse (blake-rouse) wrote :

Did you set the secondary rack controller as the "secondary_rack" on the VLAN that is providing DHCP. Setting up the HA is a manual process, once setup it allows one of those two racks on that VLAN to go down that is it.

Changed in maas:
status: New → Incomplete
Peter Matulis (petermatulis) wrote :

When a second rack controller is added, when the initial rack controller is already providing DHCP, it is automatically added as a secondary for the VLAN (that has DHCP enabled). I confirmed this (in the web UI) before submitting this issue. Apologies for not having included that information.

Blake Rouse (blake-rouse) wrote :

Please provide a screenshot of the WebUI. I do not believe that is the case.

Peter Matulis (petermatulis) wrote :

I had unregistered the second rackd (pmatulis-imp-rack) to allow me to continue with other testing. Simply rebooting it brought me back to where I was before. The original rackd is on pmatulis-imp-maas:

https://goo.gl/KnTpQO

I've tested stopping the new rackd and things are working. I then restarted it.

To re-confirm the original issue, stopping the original rackd leads to the new rackd that doe not supply DHCP. I confirmed that the first screenshot above is still valid (both rackd are present):

https://goo.gl/d7G2vN

A booting (fresh) node cannot enlist due to absent DHCP.

Blake Rouse (blake-rouse) wrote :

I am correct you did not set the rack controller as the secondary rack controller if you did you would have another field:

Secondary Rack: pmatulis-imp-rack

You only have:

Rack controllers: pmatulis-imp-rack pmatulis-imp-maas

So that is why its not working. You need to use the action panel to reconfigure DHCP to set it as the secondary rack controller, only then would DHCP be started. I am going to mark this as a UI bug, as I agree that it is confusing.

summary: - Rackd HA doesn't work, DHCP unavailable
+ [2.1+, UI] Hard to tell that HA is not enabled for DHCP on a VLAN
tags: added: ui ux
Changed in maas:
status: Incomplete → Triaged
importance: Undecided → Medium
milestone: none → next
Peter Matulis (petermatulis) wrote :

Wow ok! Time to update the documentation.

Changed in maas:
status: Triaged → Invalid
Changed in maas:
status: Invalid → Triaged
Changed in maas:
assignee: nobody → Lilyana Videnova (lilyanavidenova)

Proposed solution to improve the experience: https://zpl.io/2Gyxqpj

Changed in maas:
assignee: Lilyana Videnova (lilyanavidenova) → Steve Rydz (steverydz)
status: Triaged → In Progress
milestone: next → 2.6.0rc1
Changed in maas:
milestone: 2.6.0rc1 → 2.6.0rc2
Changed in maas:
milestone: 2.6.0rc2 → 2.7.0beta1
Changed in maas:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers