[2.x, UI] [Device discovery] Enable/Disable toggle is hidden

Bug #1669744 reported by Maria Vrachni on 2017-03-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
Low
Andres Rodriguez
2.2
Low
Andres Rodriguez

Bug Description

MAAS Version 2.2.4, [Device discovery] Enable/Disable toggle is hidden until all devices are discovered

Bug description:
The toggle hidden until all the devices have been discovered. It it possible that the user wants to disable the device discovery because it's affecting the performance of their machine or they are not interested in the discovery. Even if the back end functionality is not available, the component should be on the screen in a disabled state.

* Current result:

Given that I am in the device discovery table
When I want to disable the device discovery
Then  there is no way to do it

* Expected/ correct result:

Given that I am in the device discovery table
When I want to disable the device discovery
Then  I can disable it from the toggle

[OS X Sierra]

[Chrome, 53.0.2785.116 (64-bit)]

Related branches

Maria Vrachni (m-vrachnis) wrote :
Maria Vrachni (m-vrachnis) wrote :
Changed in maas:
status: New → Triaged
tags: added: papercut
summary: - [Device discovery] Enable/Disable toggle is hidden
+ [2.x] [Device discovery] Enable/Disable toggle is hidden
Changed in maas:
milestone: none → 2.3.0
summary: - [2.x] [Device discovery] Enable/Disable toggle is hidden
+ [2.x, UI] [Device discovery] Enable/Disable toggle is hidden
Changed in maas:
importance: Undecided → Low
Changed in maas:
assignee: nobody → Andres Rodriguez (andreserl)
Changed in maas:
status: Triaged → Fix Committed
Changed in maas:
milestone: 2.3.0 → 2.3.0alpha1
Changed in maas:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers