[2.1,2.2] Column Sort on Nodes page is broken

Bug #1665000 reported by Jeff Lane on 2017-02-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
Low
Unassigned

Bug Description

I just tried sorting by column on the nodes page and it seems to be broken... Note this is on our production server running MAAS Version 2.1.2+bzr5555-0ubuntu1 (16.04.1)

So on the nodes page, we have all our nodes listed. I click on the Disks header expecting the rows to resort based on the number of disks in the node from high to low or low to high. The nodes ARE re-arranged, in some sort of order, but not in any order that makes sense.

SO I try sorting based the Storage(GB) column by clicking it's header. Again, the rows appear to resort but again in no understandable order, they SHOULD be re-ordering by Storage Size in GB, low-high or high-low.

I've attached a short video demonstrating this.

Jeff Lane (bladernr) wrote :
Changed in maas:
importance: Undecided → Low
milestone: none → 2.2.0
status: New → Triaged
summary: - Column Sort on Nodes page is broken
+ [2.1,2.2] Column Sort on Nodes page is broken

I seem to be able to reproduce this for disks, but not for storage as seems to be the case in the video. On trunk that is

Changed in maas:
milestone: 2.2.0 → 2.2.x
Changed in maas:
status: Triaged → Fix Committed
milestone: 2.2.x → next
milestone: next → 2.3.0
Changed in maas:
milestone: 2.3.0 → 2.3.0alpha1
Changed in maas:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers