Unable to change disk name using maas gui

Bug #1651165 reported by Dave Chiluk on 2016-12-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
High
Newell Jensen
2.2
High
Newell Jensen

Bug Description

Under Available disks and partitions, click the edit button then modify the name.

Click save.

The changes never happen.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: maas 2.1.1+bzr5544-0ubuntu1~16.04.1
ProcVersionSignature: Ubuntu 4.4.0-53.74-generic 4.4.30
Uname: Linux 4.4.0-53-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.4
Architecture: amd64
Date: Mon Dec 19 09:16:58 2016
PackageArchitecture: all
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: maas
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Dave Chiluk (chiluk) wrote :
Andres Rodriguez (andreserl) wrote :

Hi Dave,

I can't reproduce this. I have successfully changed the name of a this in 2.1.

Changed in maas:
status: New → Incomplete
Changed in maas (Ubuntu):
status: New → Incomplete
Andres Rodriguez (andreserl) wrote :

@Dave,

Can you confirm that the issue is not that it takes a long time because it is a very remote MAAS ?Also, can you attach logs ?

Dave Chiluk (chiluk) wrote :

Did you refresh the page after changing the name? Also this maas is on my local lan.

I created a video showing exactly what I'm doing.
https://www.youtube.com/watch?v=cJbHoVR6FBc&feature=youtu.be

I checked the logs and couldn't find anything related to my operation.

FYI. This machine has been upgraded from 1.7->1.9->2.0->2.1. I'm not sure if that matters in this case though.

I attached the /var/log/maas logs for completeness.

Changed in maas:
status: Incomplete → New
Changed in maas (Ubuntu):
status: Incomplete → Opinion
status: Opinion → New
Dave Chiluk (chiluk) wrote :

Looks like I'm getting errors from javascript out of my browser. I suspect something is cached that shouldn't be. I'll clear cache and try again.

jquery.js?v=2.1.1+bzr5544-0ubuntu1(16.04.1):3 GET http://192.168.1.5/MAAS/static/assets/img/backgrounds/image-background-paper.png 404 (Not Found)
maas-angular.js?v=2.1.1+bzr5544-0ubuntu1(16.04.1):7716 Detected new MAAS version; forcing reload.
jquery.js?v=2.1.1+bzr5544-0ubuntu1(16.04.1):5 GET http://192.168.1.5/MAAS/static/assets/fonts/ubuntumono-r-webfont.woff2
jquery.js?v=2.1.1+bzr5544-0ubuntu1(16.04.1):5 GET http://192.168.1.5/MAAS/static/assets/fonts/ubuntu-li-webfont.woff2
/MAAS/#/node/4y3h8b:1 This page includes a password or credit card input in a non-secure context. A warning has been added to the URL bar. For more information, see https://goo.gl/zmWq3m.

Dave Chiluk (chiluk) wrote :

Clearing cache did not help. Trying firefox did not help.

I can reproduce this - if the disk name shouldn't be editable than it should be disabled in the UI

Changed in maas:
status: New → Triaged
importance: Undecided → High
Changed in maas:
milestone: none → 2.3.0
no longer affects: maas (Ubuntu)
Changed in maas:
assignee: nobody → Newell Jensen (newell-jensen)
status: Triaged → In Progress
Changed in maas:
status: In Progress → Fix Committed
Changed in maas:
milestone: 2.3.0 → 2.3.0alpha1
Changed in maas:
status: Fix Committed → Fix Released
Dave Chiluk (chiluk) wrote :

I can confirm that with 2.3.0~alpha1 (6165-geae082b-0ubuntu1~16.04.1, the user is no longer able to change the disk name or partition name via the maas UI. Although not what I had intended, I think this is better than being able to change the name via the UI, but having it fail.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers